RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Site Administration Forums > Broadcastify/Live Audio Administration

Broadcastify/Live Audio Administration - Administration topics for live audio broadcasting on Broadcastify.com. This forum is for feed providers to get support. Other audio questions go here: Streaming /Broadcasting / Audio Recording forum

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #61 (permalink)  
Old 04-18-2017, 8:17 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 34
Default

Hi DC31, first step to success with this is to make sure you can stay logged on with your feed to broadcastify with squelch set to zero (-l 0). If that doesn't work then there are other problems.

And thanks again for following up on the questions on why this has never worked before Until now that is .

Last edited by JACK26; 04-18-2017 at 9:38 AM..
Reply With Quote
Sponsored links
  #62 (permalink)  
Old 04-19-2017, 5:55 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 34
Default

One other thing when you're experimenting with your feed to Broadcastify, it can take up to 90 seconds or more before your connection shows up as "connected" again. It takes a lot of patience to get this working.

Also, regarding the previous post, I have no idea if the keenerd fork worked before on rpi2 since I am using an rpi3 but I doubt it .

Last edited by JACK26; 04-19-2017 at 6:03 AM..
Reply With Quote
  #63 (permalink)  
Old 04-19-2017, 5:58 AM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 727
Default

I am working on it now. For testing purposes, I set up an icecast server on the pi and stream there rather than to bcfy. I seem to have the stream up and running white noise now with the squelch setting -l 0. Waiting on some radio traffic on the channel.
Reply With Quote
  #64 (permalink)  
Old 04-19-2017, 6:25 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 34
Default

If you are successfully feeding to Broadcastify with the rtl-fm parameters then your channel should appear as online within a few minutes.

BTW, Icecast does not work with SDR USB stick only. You need to to use ezstream .
Reply With Quote
  #65 (permalink)  
Old 04-19-2017, 6:28 AM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 727
Default

Quote:
Originally Posted by DC31 View Post
I am working on it now. For testing purposes, I set up an icecast server on the pi and stream there rather than to bcfy. I seem to have the stream up and running white noise now with the squelch setting -l 0. Waiting on some radio traffic on the channel.
Okay, so I got some radio traffic. Still with the -l 0 setting. The radio traffic comes through but it is almost totally unintelligible.


I changed the -l setting. When I do that, my stream does not connect.
Reply With Quote
Sponsored links
  #66 (permalink)  
Old 04-19-2017, 6:42 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 34
Default

I know the posts here are delayed a little but icecast does not work with the USB rtl sticks. You need to follow the instructions for ezstream. That was also part of my learning experience to make this work .
Reply With Quote
  #67 (permalink)  
Old 04-19-2017, 7:20 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 34
Default

Also, suggest you install this fork:
https://github.com/blantonl/RTLSDR-Airband

Not sure if it affects this issue but I have installed it and everything is working so far.
Reply With Quote
  #68 (permalink)  
Old 04-19-2017, 7:21 AM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 727
Default

I took down one of my bcfy feeds and connected to it from the rtl pi. It would stream white noise with the squelch setting at -l 0 for about 30 sec. then disconnect. Here is what I see:

pi@raspberrypi_rtlsdr:~ $ sudo /usr/local/bin/rtl_fm -d 0 -M fm -f 460.400M -p 54 -l 0 -g 15 -t 5 -E pad -s 12k | /usr/bin/lame -r -s 12 --resample 22.05 -m m -b 16 --cbr --lowpass 4 - - | /usr/bin/ezstream -q -c /etc/ezstream_bcfy.xml
Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
ezstream: Connected to http://audio1.broadcastify.com:80/XXXXXXXX
ezstream: Streaming from standard input
Found Rafael Micro R820T tuner
Tuner gain set to 14.40 dB.
Tuner error set to 54 ppm.
Tuned to 460652000 Hz.
Oversampling input by: 84x.
Oversampling output by: 1x.
Buffer size: 8.13ms
Exact sample rate is: 1008000.009613 Hz
Sampling at 1008000 S/s.
Output at 12000 Hz.


Streaming to icecast works also. I run the same ezstream to do the streaming, just direct the output to icecast on the pi in the configuration file rather than to bcfy. streaming to icecast the stream stays on, it doesn't drop after 30 seconds. Radio transmissions come through the white noise but are totally unintelligible.

I haven't install the airband fork, so I guess i will try that next
Reply With Quote
  #69 (permalink)  
Old 04-19-2017, 7:29 AM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 727
Default

Quote:
Originally Posted by JACK26 View Post
Also, suggest you install this fork:
https://github.com/blantonl/RTLSDR-Airband

Not sure if it affects this issue but I have installed it and everything is working so far.
Some instructions Please?

In the wiki, I find
Install rtl_airband customized for Broadcastify
but that doesn't seem to refer to the github file that you are referencing.
Reply With Quote
Sponsored links
                          
  #70 (permalink)  
Old 04-19-2017, 7:50 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 34
Default

If you are really connected, you should be able to reload the feed from broadcastify and hear your feed within about 30 seconds if you are successfully feeding even though the web page may show you as offline. I would suggest trying a gain -g 45 setting just to make sure you are transmitting static.

Regarding server icecast vs ezstream, all I know is that icecast does not work with a USB SDR stick and when I googled icecast I've seen a lot of questions about it and a few posters who responded that icecast does not work with streaming the audio from an SDR stick to Broadcastify. I tried for many hours to make that work without success.

My suggestion is to try ezstream.

PS: This is the webpage I've been refering to. If you follow all the instructions and use the ezstream part instead of the icecast part, it should work.
http://wiki.radioreference.com/index...R_Broadcastify

pps if you look up this webpage again it looks like the author removed the icecast install instructions recently. Start over with those instructions and it should work .

Last edited by JACK26; 04-19-2017 at 9:39 AM..
Reply With Quote
  #71 (permalink)  
Old 04-19-2017, 11:05 AM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 727
Default

Quote:
Originally Posted by JACK26 View Post
If you are really connected, you should be able to reload the feed from broadcastify and hear your feed within about 30 seconds if you are successfully feeding even though the web page may show you as offline. I would suggest trying a gain -g 45 setting just to make sure you are transmitting static.

Regarding server icecast vs ezstream, all I know is that icecast does not work with a USB SDR stick and when I googled icecast I've seen a lot of questions about it and a few posters who responded that icecast does not work with streaming the audio from an SDR stick to Broadcastify. I tried for many hours to make that work without success.

My suggestion is to try ezstream.

PS: This is the webpage I've been refering to. If you follow all the instructions and use the ezstream part instead of the icecast part, it should work.
Raspberry Pi RTL-SDR Broadcastify - The RadioReference Wiki

pps if you look up this webpage again it looks like the author removed the icecast install instructions recently. Start over with those instructions and it should work .


Are you perhaps confusing icecast and darkice? Ezstream and darkice are audio streamers. Icecast is a sound server.

I have been using Ezstream to do the streaming all along. Darkice does not work with the rtl-sdr sticks as it cannot accept the audio from stdin. Ezstream can use stdin as an audio source. Stdin is the only option when using the rtl-sdr stick.

To use icecast, install it on the pi at the command line sudo apt-get install icecast2

Accept the default passwords.

Then set up your Ezstream configuration file in /etc as follows (use any number for the mount point):

<ezstream>
<url>http://localhost:8000/12345678</url>
<sourcepassword>hackme</sourcepassword>
<format>MP3</format>
<filename>stdin</filename>
<svrinfoname>EZStream</svrinfoname>
<svrinfourl>http://www.broadcastify.com</svrinfourl>
<svrinfogenre>Scanner</svrinfogenre>
<svrinfodescription></svrinfodescription>
<svrinfobitrate>16</svrinfobitrate>
<svrinfochannels>1</svrinfochannels>
<svrinfosamplerate>22050</svrinfosamplerate>
<svrinfopublic>0</svrinfopublic>
</ezstream>


then from another web browser on the same network, browse to piipaddress:8000 Click on the m3u button and it will stream.
Attached Images
 
Reply With Quote
  #72 (permalink)  
Old 04-20-2017, 4:59 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 34
Default

Stand corrected. Confused icecast with darkice. Thanks for the info on using icecast. Have you tried it without using icecast? This introduces an extra complication that may be causing problems.

If you can't stay logged on using -l 0 then there are other problems. Even with the keenerd fork, I was able to stay logged on for a few seconds with squelch enabled (-l 75). With squelch -l 0 I could stay logged on successfully with a lot of static. So if you can't stay logged on with -l 0 then there is some other problem besides the pad 0 problem. Is there audible constant static with -l 0?

PS: On the link for the RTLSDR-Airband that I used, I was refering to this quote from the wiki:

"If you want to use the original working source for rtl_airband for any other distribution, please follow the instructions on the rtl_airband git source page:
https://github.com/blantonl/RTLSDR-Airband"

I don't know if that would make any difference but it is the one I installed but I haven't tested it yet.

Last edited by JACK26; 04-20-2017 at 5:27 AM..
Reply With Quote
  #73 (permalink)  
Old 04-20-2017, 5:45 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 34
Default

You probably already did this but make sure you re-run the black list commands with the sdr stick unplugged:

sudo su -
echo "blacklist r820t" >> /etc/modprobe.d/dvb-blacklist.conf
echo "blacklist rtl2832" >> /etc/modprobe.d/dvb-blacklist.conf
echo "blacklist rtl2830" >> /etc/modprobe.d/dvb-blacklist.conf
echo "blacklist dvb_usb_rtl28xxu" >> /etc/modprobe.d/dvb-blacklist.conf
exit

Also I would suggest not having any other usb devices connected except keyboard, mouse and monitor to get this working the first time.

ps: I'm still not clear if you are staying logged on with -l 0 squelch. If you are staying online then the problem still sounds like the keenerd rtl-sdr fork vs osmocom fork which is working for me.

Last edited by JACK26; 04-20-2017 at 6:01 AM..
Reply With Quote
  #74 (permalink)  
Old 04-20-2017, 7:24 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 34
Default

I re-read your previous posts and it sounds like your rtl-fm -f and -p parameters might be off. I just duplicated the same problem when I switched sdr sticks and forgot to apply the appropriate -p (ppm offset) value.

I used gqrx on the rpi3 to determine those values.

One other thing, if you change your password on rr it changes the feed password and mount so you have to edit the ezstream_bcfy file too. I did not know that before.

Also, if you set everything up and then move the antenna around and vary the signal strength, you have to mess with the -g gain and -l settings again. rtl-fm seems to be very sensitive to that. I used SDR# on win8 pc to find optimum settings for those parameters and still tweaking on the squelch setting.

Last edited by JACK26; 04-20-2017 at 7:49 AM..
Reply With Quote
  #75 (permalink)  
Old 04-21-2017, 3:43 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 34
Default

Update still tweaking on all the parameters for narrow band fm reception. Tweaking on the lame paramerters to get rid of annoying buzz that is not coming from the sdr stick. So far this is working the best for me. Note that the first line -f -p -l -g parameters are critical to the specific usb sdr stick, target freq and signal strength. Those parameters should be determined with a graphic interface like SDR# on a windows PC. Only small adjustments when transferring to the rpi may be needed after that:

sudo /usr/local/bin/rtl_fm -d 0 -M fm -f 482.862M -p 19 -l 73 -g 14 -t 10 -E pad -s 12k | \
/usr/bin/lame -r -s 12 --resample 22.05 -m m -b 24 --vbr-new -V 0 --lowpass 4 --highpass 0.25 - - | \
/usr/bin/ezstream -q -c /etc/ezstream_bcfy.xml

Best info I could find so far on lame is here. If anyone else is trying to make this work well or have made it work with rpi3 (or any rpi), please share:

https://linux.die.net/man/1/lame
http://ryanve.com/lame/

ps: gqrx does not have the background buzz on the same rpi. That is how I know it's not a usb sdr or hardware problem. I've minimized the buzz with the above lame parameters so far, but it has not been eliminated completely. The foreground audio on the rpi3 is actually much better than the scannercast audio from my windows 8 pc so for me, it's worth the effort to get this working well.

Last edited by JACK26; 04-21-2017 at 5:11 AM..
Reply With Quote
Sponsored links
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 7:43 PM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2015 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions