RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Software > Digital Voice Decoding Software

Digital Voice Decoding Software For discussion of software applications which decode digital voice formats such as P25, NXDN, MotoTRBO, etc. Please use the HF Digital Signals forum for anything below 30MHz.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 05-23-2010, 2:22 PM
Member
   
Join Date: Feb 2010
Location: Oregon
Posts: 338
Question DSD 1.3 open audio device error.

Code:
dsd
Error, couldn't open /dev/audio
ioctl reset error 
ioctl speed error 
ioctl stereo error 
ioctl setfmt error 
Audio In/Out Device: /dev/audio
/dev/audio does exist on my Linux openSuSE 11.2 distro and I am running dsd as root.
What should I look for to get dsd to work properly?
There is also a /dev/audio1 that I also tried to select with dsd -i /dev/audio1 but received the same complaint about /dev/audio

BTW, anyone know of any audio files on the Net that can be used as a sample to decode for those of us with no nearby digital?
__________________
Best Regards, Keith http://home.comcast.net/~kilowattradio/ BCProgTool.TCL 4 Mac, Win98/XP/7 & Linux
BCT15X, BC245XLT, PRO92, PRO83
Vet 101st Arbrn & 3rd ID
Reply With Quote
Sponsored links
  #2 (permalink)  
Old 05-23-2010, 6:39 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: May 2003
Location: DM12JQ
Posts: 167
Default

kilowa22,

I have heard this can happen if the audio device you are addressing is not recognized by Linux. Someone we know got this result attempting to use their onboard audio chipset which was not.

For them, this was resolved by installing an additional audio card, such as the cheap and readily available Diamond SX71, which is cited on *Ubuntu* sites as fully functional under that OS. Probably would work under SuSE, as well.

If you are using the native ALSA wave player, you likely already know how to determine audio1, audio2, et. al, by the command, aplay -l

Just in case, here's a link: Aplay - ALSA wiki

-rb-

Last edited by offsite; 05-23-2010 at 6:42 PM..
Reply With Quote
  #3 (permalink)  
Old 05-23-2010, 6:59 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Jun 2009
Location: Iowa
Posts: 225
Default

I get the same thing from time to time. open up the alamixer and close it and try dsd again. if still not working then do a restart and try again. Sometimes you just have to talk nice to her
__________________
Brian
Uniden B C D 396 xt, GRE 500, RS PRO 197, RS PRO 160, RS Pro 528, RS Pro 97 X 2 and RS PRO 2027(this unit is the best for non digital)
Reply With Quote
  #4 (permalink)  
Old 01-25-2013, 2:31 PM
Member
   
Join Date: Mar 2008
Posts: 196
Default

I am getting this same error on ubuntu 12.10. has anyone figured out a fix? thanks
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 2:20 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2011 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions