RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Site Administration Forums > Forums Administration

Forums Administration - For administrative questions about the forums or problems with its use. Before you ask, did you read here first?

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 01-07-2017, 4:14 AM
Timmeh-31's Avatar
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Jan 2008
Location: Syracuse, NY
Posts: 53
Default Tracking "Messages Read"

I've been noticing over the past week or so that the forums are rather hit-or-miss when it comes to accurately tracking which messages/sub-forums have already been read and which ones still have new/unread posts. Have there been any updates to the forum software which may account for this?

I've tried wiping my history on Chrome (sometimes it picks up a bad cookie somewhere along the line) but this doesn't seem to help. I've taken to manually using the Quick Links>Mark Forums Read at the end of each session, which does somewhat help when I return later. But within a session, I can read and re-read the same message multiple times, go up a level and it still shows that thread as unread.

It's a trifling matter in the grand scheme of things, but thought it worth bringing to the admin's attention just in case it's a symptom of something larger going on in the background. Thanks for enduring my rambling.
__________________
Tim
BCD996P2 / BC246T / UBC220XLT / Old School Bearcat 220 (retired)
Reply With Quote
Sponsored links
  #2 (permalink)  
Old 01-07-2017, 6:35 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Feb 2012
Posts: 1,714
Default

This will happen if you are blocking any of the cookies from radioreference.com, viglink.com and from d39pklu5rpk118.cloudfront.net.

Hope this helps,
__________________
73 QDP
Reply With Quote
  #3 (permalink)  
Old 01-07-2017, 8:20 AM
MikeOxlong's Avatar
Forums Manager/Global DB Admin
  RadioReference Database Admininstrator
Database Admin
 
Join Date: Jun 2001
Location: Central Ontario
Posts: 9,043
Default Tracking "Messages Read"

No, no changes have been made to the Forums software.

I haven't seen any problems myself but I'll keep an eye out for it.
__________________
Mike.

Sorry but I don't accept PM's. Please use email instead.

Last edited by MikeOxlong; 01-07-2017 at 10:51 PM..
Reply With Quote
  #4 (permalink)  
Old 01-07-2017, 8:13 PM
dave3825's Avatar
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Feb 2003
Location: United States
Posts: 1,670
Default

Quote:
Originally Posted by QDP2012 View Post
This will happen if you are blocking any of the cookies from radioreference.com, viglink.com and from d39pklu5rpk118.cloudfront.net.

Hope this helps,
How would blocking a cookie from a site other than radio reference affect whether it shows a thread was read or not. Could you explain how a company, like viglink.com VigLink -- Powering Content-Driven Commerce would have any effect on or ability to change a threads status?

viglink.com identifys commercial products mentioned within a publisher’s content, VigLink automatically transforms those terms into revenue generating hyperlinks whose destinations are determined in real-time, advertiser-bid auctions.

Just curious.
__________________
DMR436HP Br330T Pro 93 Pro 95
Arc330Pro ProScan Freescan BCDX36HP Easy Manual Id Tracker
Reply With Quote
  #5 (permalink)  
Old 01-07-2017, 10:20 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Feb 2012
Posts: 1,714
Default

Quote:
Originally Posted by dave3825 View Post
How would blocking a cookie from a site other than radio reference affect whether it shows a thread was read or not. Could you explain how a company, like viglink.com VigLink -- Powering Content-Driven Commerce would have any effect on or ability to change a threads status?

viglink.com identifys commercial products mentioned within a publisher’s content, VigLink automatically transforms those terms into revenue generating hyperlinks whose destinations are determined in real-time, advertiser-bid auctions.

Just curious.
As to why RadioReference would allow a 3rd-party to have that much influence, I cannot say, only RR leadership could.

But, when I use FireFox with NoScript and block the viglink and cloudfront cookies mentioned earlier, it creates the problem described by the OP. When I permit the cookies, the problem resolves. I've been dealing with this issue for years on multiple computers, and found that when cookies from those three sites are permitted, the problem does not happen.

I assume a similar result would happen with any equivalent browser and cookie/script-blocker software.

Again, about the question of why, I defer to RR staff who know the behind-the-scenes coding, and the relationship(s) with the 3rd-party site(s)..

Hope this helps,
__________________
73 QDP

Last edited by QDP2012; 01-07-2017 at 10:24 PM..
Reply With Quote
Sponsored links
  #6 (permalink)  
Old 01-08-2017, 12:11 AM
Timmeh-31's Avatar
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Jan 2008
Location: Syracuse, NY
Posts: 53
Default

Well, here's the odd thing then. I'm not aware of blocking anything from RR or the other sites (although AdBlocker may be purposely blocking anything it perceives to be malware/adware.) Also peculiar is that this behavior slowly exhibited itself; that is, the new message tracking worked fine for the first couple of weeks, and has gradually deteriorated over the past week or so to its current state.

I'll try flushing the cache again and see if that helps. Strange.
__________________
Tim
BCD996P2 / BC246T / UBC220XLT / Old School Bearcat 220 (retired)
Reply With Quote
  #7 (permalink)  
Old 01-08-2017, 7:01 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Feb 2012
Posts: 1,714
Default

Quote:
Originally Posted by Timmeh-31 View Post
Well, here's the odd thing then. I'm not aware of blocking anything from RR or the other sites (although AdBlocker may be purposely blocking anything it perceives to be malware/adware.) Also peculiar is that this behavior slowly exhibited itself; that is, the new message tracking worked fine for the first couple of weeks, and has gradually deteriorated over the past week or so to its current state.

I'll try flushing the cache again and see if that helps. Strange.
Do you have any anti-virus/security-suite software that might be trying to "clean up" cookies, temp files, etc.?

Years ago I used a software package that tried to do that based upon its default settings, which caused similar issues, so I manage them differently now and don't let it 'automagically" clean them up on its own.

I've also seen such things happen after the AV/Security software installed its own updates, because it "reset" certain settings.

Hope this helps,
__________________
73 QDP
Reply With Quote
  #8 (permalink)  
Old 01-08-2017, 9:55 AM
safetyobc's Avatar
Member
  Shack Photos
Shack photos
 
Join Date: Sep 2004
Location: South Arkansas
Posts: 4,098
Default

Using an iPad, I've noticed that if I click on "New Posts" it will sometimes say there is nothing new, even if it has been a day since I last logged on. Alternatively I click on "Forums" then "Today's Posts" and that will bring up everything I haven't read. For whatever reason, on the iPad you can't be in the forums and click on "Forums" to get to "Today's Posts." I have to go to the classifieds, then click on Forums to get the drop down to click "Today's Posts."
__________________
.
Scanner Video Reviews - YouTube
Reply With Quote
  #9 (permalink)  
Old 01-08-2017, 12:18 PM
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: May 2015
Location: Hammond, IN
Posts: 1,029
Default

I have experienced more than once that if I spend "too much time" (usually more than ten minutes on average) composing a reply, when I complete my post suddenly there are no longer any unread messages...

...when there were up to six or seven pages of unread posts prior to making my post!
__________________
Bill
N4GIX - Ham / WQWU626 - GMRS
Leixen VV-898, Kenwood TK-840(N), 2xTYT-7800, 2xUV5R v2+, Home Patrol 1, BCD436HP, Kenwood TMV7A, Ritron RRX-450 Repeater, MD-380, 2xCS800, Bridgecom BCR-40U Repeater
Reply With Quote
Sponsored links
                          
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 2:09 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2015 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions