RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Site Administration Forums > Live Audio Feed Administration

Live Audio Feed Administration Administration topics for live audio broadcasting on Broadcastify.com. This forum is for feed providers to get support.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 05-21-2011, 10:17 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Mar 2011
Location: Long Reach, NB
Posts: 14
Red face Need some help with "device" setting in Darkice

HI there..I've been steadily making progress, but I've hit a bump. My feed has no output, even though the mic input is turned on and I can hear the scanner in my server's internal speaker when I turn it on. My problem (I think) is with my "device = " setting. The only variable I can put in there that will allow the program to run is "default". However, when I run it with "device = default" I'm getting no output.

I see other people using "device = /dev/sda" or device = /dev/dsp (trying various incarnations of this always gives me this error:

"DarkIce: OssDspSource.cpp:202: can't set format [16]"

I also see people using

device = hw:0,0

Which gives me

ALSA lib pcm.c:2212snd_pcm_open_noupdate) Unknown PCM device = hw:0,0
DarkIce: DarkIce.cpp:1187: can't open connector [0]

At my wits end here. Thanks for any help you can give me.

Last edited by longreacher; 05-21-2011 at 10:20 AM..
Reply With Quote
Sponsored links
  #2 (permalink)  
Old 05-21-2011, 10:20 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Mar 2011
Location: Long Reach, NB
Posts: 14
Default

If it helps, here is the output from

aplay-l




**** List of PLAYBACK Hardware Devices ****
card 0: ICH5 [Intel ICH5], device 0: Intel ICH [Intel ICH5]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: ICH5 [Intel ICH5], device 4: Intel ICH - IEC958 [Intel ICH5 - IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0
Reply With Quote
  #3 (permalink)  
Old 05-23-2011, 8:34 AM
bradmc's Avatar
Member
  Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Sep 2003
Location: Cincinnati, OH
Posts: 4
Default Some Notes

Hi,

I don't know how much help this might be, but I took some notes a couple years ago when I switched from a dedicated linux box to a linux vmware instance. I remember it being a bit of an ordeal. It's amazing I took any notes at all.

On the old server, I was able to just use /dev/dsp and have it work. I don't remember whether I was forced to switch to ALSA on the new server, or whether I just did it by choice. It looks like I set up it up first to just emulate ALSA, so that programs could still use the "/dev/dsp" device. And then I got it working with darkice so it could directly use the device hw:0,0

In my notes I mentioned two links that were the most helpful, one of which was TroubleShooting - ALSA wiki - and one that doesn't appear to exist anymore... http://alsa.opensrc.org/index.php/FAQ - So I imagine you can probably just go to Main Page - ALSA wiki and poke around in general.

The rest of this is just what I have in my notes. My memory is bad enough that I don't remember much about it, so I'm not sure if asking me any follow up questions is going to help much, but I'd be glad to look at devices and configs on my server.

---------------------------------------------
Notes:

Use 'alsamixer' to adjust the soundcard volume. It works just like the windows sound mixer.
Use tab to go through the screens.
Everything was defaulted to being muted. So I unmuted and turned up everything.
Before I could produce a decent volume, I also had to turn on capture.

Once I had the mixer set right, and the capture for line-in turned on, I did not need OSS
emulation for darkice (as described below). I just set the sound device to hw:0,0 and it
worked fine.

IMPORTANT: after setting stuff up in alsamixer, run 'alsactl store' to save it.

-----

OSS Emulation

To use ALSA's OSS emulation so that you can use the device “/dev/dsp”, do the following:

See if the modules are loaded:
lsmod | awk '$1~/oss/ || NR==1'

This line means they're not:
Module Size Used by Not tainted

Load the modules:
echo snd-seq-oss snd-pcm-oss snd-mixer-oss | xargs -n 1 modprobe

Put them in /etc/modules to have them automatically loaded.

Then you can use the device:
/dev/dsp
---------------------------------------------
end of notes

Also, I just checked to see which alsa packages I have installed on debian, and they are alsa-base, also-oss, and alsa-utils

The input of my darkice config section is:

[input]
device = hw:0,0
sampleRate = 22050
bitsPerSample = 16
channel = 2

Hope that helps at least some...

Brad
__________________
Brad McConahay, N8QQ - n8qq.com
Weather Amateur Radio Network - warn.org
Reply With Quote
  #4 (permalink)  
Old 05-23-2011, 4:00 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Mar 2011
Location: Long Reach, NB
Posts: 14
Default

Success! Thanks so much BradMC. I'm not sure which part of your help put me over, but we are now up and running. Still learning the linux thing, but it's more fun to tinker than to plug and pray anyways!
Reply With Quote
  #5 (permalink)  
Old 05-27-2011, 10:57 AM
bradmc's Avatar
Member
  Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Sep 2003
Location: Cincinnati, OH
Posts: 4
Default Cool!

Quote:
Originally Posted by longreacher View Post
Success! Thanks so much BradMC. I'm not sure which part of your help put me over, but we are now up and running. Still learning the linux thing, but it's more fun to tinker than to plug and pray anyways!
Excellent! Glad that helped. I've been using linux (Unix, bsd, etc.) for about 15 years for work and home, mostly server-related stuff, and every area is always a new puzzle. Definitely a tinkerer's dream - totally frustrating at times, but somewhat addicting and satisfying. And definitely worth the stability compared to Win/Mac. For server stuff anyway.
__________________
Brad McConahay, N8QQ - n8qq.com
Weather Amateur Radio Network - warn.org
Reply With Quote
Sponsored links
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 4:41 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2011 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions