RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Computer Aided Monitoring and Programming > Software Defined Radio


Software Defined Radio - A forum for general discussion of software defined radio (SDR) receiver equipment.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 06-29-2013, 4:09 PM
Dog's Avatar
Dog Dog is offline
Member
   
Join Date: Jun 2003
Location: Oklahoma
Posts: 252
Default Help with SDRSharp, UniTrunker, and DSD

I could use some help and suggestions.

I have SDRSharp up and running. Set to control channel. Unitrunker shows activity. (I am using 2 TV28T V2s)
The second instance of SDRSharp is up and running changing frequencies as it should.

I have 2 problems.

1 When I try to calibrate to a frequency. I click "front end", change the "frequency correction" and nothing happens. I have tried everything I can think of to get it to do anything at all but nothing changes.

2 When I run DSD every once in a while I will get some garbled sound but mostly it stays silent. I think the problem is with the "frequency correction". I "hope" by solving problem one it will solve problem 2.

Does anyone have any advice or suggestions?

Thank you for your time.
Reply With Quote
Sponsored links
  #2 (permalink)  
Old 06-29-2013, 5:58 PM
DaveNF2G's Avatar
Member
  Premium Subscriber
Premium Subscriber
Amateur Radio Operator
Amateur Radio
 
Join Date: Jan 2001
Location: Rensselaer, NY
Posts: 8,485
Default

Don't try to change any SDR# settings while receiving. The program needs to be stopped, adjusted, and started in order for changes to have any effect.
__________________
David T. Stark
NF2G WQMY980 KYR7128
ARRL VE & Registered Licensing Instructor
Reply With Quote
  #3 (permalink)  
Old 06-29-2013, 6:17 PM
Dog's Avatar
Dog Dog is offline
Member
   
Join Date: Jun 2003
Location: Oklahoma
Posts: 252
Default

I have tried to adjust it while it was running. Stopping, changing, then starting again. Changing, closing completely then starting again. Nothing, no change at all. This is frustrating.
Reply With Quote
  #4 (permalink)  
Old 06-29-2013, 8:56 PM
Tweekerbob's Avatar
Member
   
Join Date: May 2004
Posts: 617
Default

Just use the frequency shift function within SDR# to correct the frequency if the other method is unavailable.

For example, I know a CC I want to tune is 853.775MHz. However in SDR# it's showing up as 853.556MHz. I tell SDR# to "shift-up" 219kHz and now the frequency reads correctly. After making the correction, SDR# correctly followed the trunked system.

My frequency adjustment is working correctly, so I adjusted the dongle way off frequency to illustrate how this works. There are some days for whatever reason the frequency correction is ineffective, so the "shift" method comes in handy.

And you can change quite a few things in SDR# with it running. The main thing you can't change (and it's pretty obvious because it won't let you) whilst running is the audio out channel.
Attached Images
  
__________________
I'm OCD with ADD. Everything's gotta be perfect...just for a little bit.

Last edited by Tweekerbob; 06-29-2013 at 8:59 PM..
Reply With Quote
  #5 (permalink)  
Old 06-29-2013, 9:49 PM
Dog's Avatar
Dog Dog is offline
Member
   
Join Date: Jun 2003
Location: Oklahoma
Posts: 252
Default

I finally got the calibration sorted out. I still Have nothing coming out of DSD.

I have the default recording device set to line 1 from "Virtual Audio Cable". I have the "signal" set to line 2 of VAC. I have the "control"/voice instance of SDR# set to line 1. DSD will scroll some text every once in awhile but not often. And even more rare I will get some garbled sound from the speakers.

Any suggestions?

Thanks for the help so far.

I think my problem with the calibration was my own fault. I moved some files around and it started working. Not sure exactly what made it work though.
Reply With Quote
Sponsored links
  #6 (permalink)  
Old 06-29-2013, 10:53 PM
Tweekerbob's Avatar
Member
   
Join Date: May 2004
Posts: 617
Default

Sounds like you have the audio routed correctly.

Check the obvious first. Make sure "Filter Audio" box is unchecked in both instances of SDR#.

If that checks clear, move onto the VAC control panel. Open that puppy up and take a look at what's going on.

Check to see that both lines are showing active. Both of the active lines will have info similar to what's in the green rectangle in the screenshot. If Line 1 is saying it's active, then you need to investigate why DSD is not getting much of a signal to work with. Do you have the AF gain up high enough in SDR#?

Check Line 1 in the far right and see if there are any OFlows or UFlows stacking up. This indicates a mismatch in sampling rates and DSD hates that. Also, ensure that NC (number of channels) is set to 2 (stereo). I don't know why, but that's what works. Check out the print screen below. Set-up your Line 1 exactly like I have my line 3 and you should start getting more action from DSD.
Attached Images
 
__________________
I'm OCD with ADD. Everything's gotta be perfect...just for a little bit.
Reply With Quote
  #7 (permalink)  
Old 06-29-2013, 11:20 PM
Dog's Avatar
Dog Dog is offline
Member
   
Join Date: Jun 2003
Location: Oklahoma
Posts: 252
Default

I really appreciate the help and ideas.

I figured out my problem. It has been awhile since I have been scanning. I didn't realize the system I am listening to is all analog. I checked "filter audio" and I have voices in the air.

I have some other systems to check out so all this "learning" should help out in the long run anyway.

Again thank you for the help.
Reply With Quote
  #8 (permalink)  
Old 07-01-2013, 7:27 AM
Boatanchor's Avatar
Member
   
Join Date: Jul 2011
Posts: 989
Default

Quote:
Originally Posted by Tweekerbob View Post
Sounds like you have the audio routed correctly.

Check the obvious first. Make sure "Filter Audio" box is unchecked in both instances of SDR#.

If that checks clear, move onto the VAC control panel. Open that puppy up and take a look at what's going on.

Check to see that both lines are showing active. Both of the active lines will have info similar to what's in the green rectangle in the screenshot. If Line 1 is saying it's active, then you need to investigate why DSD is not getting much of a signal to work with. Do you have the AF gain up high enough in SDR#?

Check Line 1 in the far right and see if there are any OFlows or UFlows stacking up. This indicates a mismatch in sampling rates and DSD hates that. Also, ensure that NC (number of channels) is set to 2 (stereo). I don't know why, but that's what works. Check out the print screen below. Set-up your Line 1 exactly like I have my line 3 and you should start getting more action from DSD.
Thanks so much to this poster

I've been trying to get DSD and VAC cable running for months without much success.
All I had to do was tweak the VAC settings to match the screenshot above and BAM, it works!

Once again, thanks..
__________________
What can go wrong, will inevitably go wrong!
Reply With Quote
  #9 (permalink)  
Old 07-01-2013, 2:22 PM
Dog's Avatar
Dog Dog is offline
Member
   
Join Date: Jun 2003
Location: Oklahoma
Posts: 252
Default

I have a few more questions.

What files do I need to "back up"?

Can I make multiple folders so I don't have to set everything each time I change systems or want to test something else?

Is there an easy way to "lock" ON a talk group? I figured out how to lock talk groups out but do I have to lockout everything or is there a way to listen to one or a couple of talk groups?

The system I am listening to is mostly analog but has a couple of digital talk groups. Is there a way to listen to both at the same time? I can listen to the digital talk groups through DSD or the analog groups through SDR# but I haven't figured out how to do both.
Reply With Quote
  #10 (permalink)  
Old 01-16-2014, 10:21 PM
Bote's Avatar
Member
   
Join Date: Dec 2002
Location: Ft. Lauderdale, FL, U.S.A.
Posts: 653
Default V.A.C. settings

I run V.A.C. on my scanner feeds to loop the audio through a WinAmp plug-in to punch up the speech. It really helps on those mumblers on the radio.

Anyway, I discovered that each pass through a V.A.C. line would drop the audio by 6dB unless I set each line to use "cable range" and fix the sample rate min and max to the desired rate, don't let it figure it out by itself just tell it explicitly. Once I did this I got lossless audio through V.A.C. and life is good.

Hope this helps.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 1:36 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2015 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions