RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Software > Streaming / Broadcasting / Audio Recording

Streaming / Broadcasting / Audio Recording Interested in putting your scanner online for others to hear? Want to listen to other radios on the internet. This forum is here for you to discuss these topics related to streaming scanners online.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 10-23-2010, 10:05 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Oct 2010
Location: Los Angeles, California
Posts: 11
Default ubuntu 10.10 server and darkice

I am currently confirguring 2 devices with ubuntu 10.10 server and darkice. I would like to stream 4 feeds from 2 sound cards.

Device one
Card 1 - line in - left channel - feed 1
Card 1 - line in - right channel - feed 2
Card 2 - line in - left channel - feed 3
Card 2 - line in - right channel - feed 4

Device two
Card 1 - line in - left channel - feed 5
Card 1 - line in - right channel - feed 6
Card 2 - line in - left channel - feed 7
Card 2 - line in - right channel - feed 8

Can someone walk me through the steps to get it configured?

Thanks,
Reply With Quote
Sponsored links
  #2 (permalink)  
Old 10-27-2010, 7:19 AM
richtidd's Avatar
Live Audio Administrator
  RadioReference Database Admininstrator
Database Admin
Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Dec 2002
Location: San Mateo, Ca
Posts: 985
Default

Quote:
Originally Posted by LACoFD View Post
I am currently confirguring 2 devices with ubuntu 10.10 server and darkice. I would like to stream 4 feeds from 2 sound cards.

Device one
Card 1 - line in - left channel - feed 1
Card 1 - line in - right channel - feed 2
Card 2 - line in - left channel - feed 3
Card 2 - line in - right channel - feed 4

Device two
Card 1 - line in - left channel - feed 5
Card 1 - line in - right channel - feed 6
Card 2 - line in - left channel - feed 7
Card 2 - line in - right channel - feed 8

Can someone walk me through the steps to get it configured?

Thanks,
I sent this help request to the RR owner, Lindsay to help here.

Post you darkice.cfg file to this thread here so he can have a look.
__________________
--
Richard Tidd
Broadcastify.com
Live Audio Administrator

richtidd@broadcastify.com

My online scanners:
SMCo, Tuolumne Co
Reply With Quote
  #3 (permalink)  
Old 10-27-2010, 2:55 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Oct 2010
Location: Los Angeles, California
Posts: 11
Default

I have configured my PC (feed-box-1) with the following just to get the feed working/tested (step from howto on this site)

LAC-Feed-Box-1 (10/26/2010)

Step 1: Install Ubuntu Server 10.10
1. Full user name: lacfeed
2. User name: username
3. Password: password
4. leave http proxy information blank
5. Upgrade management: Install security updates automatically
6. Install no extra software

Step 2: Install Darkice
1. Sudo apt-get update (update current list of packages)
2. Sudo apt-get install darkice screen (fetch & install software)
3. Create darkice.cfg (sudo nano darkice.cfg)


Darkice Config File

[general]
duration = 0
bufferSecs = 1
reconnect = yes

[input]
device = default
sampleRate = 22050
bitsPerSample = 16
channel = 2

[icecast2-0]
format = mp3
bitrateMode = vbr
quality = 0.1
channel = 1
lowpass = 5000
server = audio3.radioreference.com
port = 80
password = password given
mountPoint = mount given
name = Los Angeles County Fire - Blue 1
description =

Step 3 Start Darkice
1. Sudo darkice c darkice.cfg

Received the following error:
Using config file: darkice.cfg
Using ALSA DSP input device: default
Using ROSIX real-time scheduling, priority 98
Darkice: LameLibEncoder.cpp:75: lame lib opening underlying sink error [0]

Found forum posts stating that this error is unable to connect to server either incorrect password or port.

Any ideas?

Once I can get this to connect to the server I will try and configure each feed as listed in first post via jackd

I am a firefighter not a programmer so it takes a little longer to configure things.

Thanks for you help and patience.

Dave
Reply With Quote
  #4 (permalink)  
Old 10-27-2010, 2:58 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Oct 2010
Location: Los Angeles, California
Posts: 11
Default

I forgot to add.

The darkice version is 1.0
Reply With Quote
  #5 (permalink)  
Old 10-29-2010, 11:19 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Oct 2010
Location: Los Angeles, California
Posts: 11
Default

I am still getting the error when trying to start darkice

Darkice: LameLibEncoder.cpp:75: lame lib opening underlying sink error [0]



I also installed jackd and tried to run it and got the following output:

no message buffer overruns
JACK complied with System V SHM support.
loading driver ..
creating alsa driver ... hw:0:hw:0:1024:2:48000:0:0:nomon:swmeter:-:32bit
control device hw:0
configuring for 48000hz, period = 1024 frames (21.3 ms), buffer = 2 periods
ALSA: mmap-based access is not possible for the capture stream of this audio interface
ALSA: cannot configure capture channel
cannot load driver module alsa

The 3 cards I have in this computer are:

[Solo1] : ES1938 - ESS ES1938 (Solo-1) ESS ES1938 (Solo-1) rev 0, irq 9

[Solo1.1] : ES1938 - ESS ES1938 (Solo-1) ESS ES1938 (Solo-1) rev 0, irq 10

[182801BAICH2] ICH - intel 82801BA-ICH2 Intel 82801BA-ICH2 with AD1885 at irq 10

Any help would be great.

Thanks
Reply With Quote
Sponsored links
  #6 (permalink)  
Old 11-01-2010, 11:50 AM
blantonl's Avatar
Founder and CEO
  Shack Photos
Shack photos
RadioReference Database Admininstrator
Database Admin
Audio Feed Provider
Audio Feed Provider
 
Join Date: Dec 2000
Location: Whitefish, MT
Posts: 8,173
Default

Try changing the device section to:

Code:
device = /dev/audio
__________________
Lindsay C. Blanton III
CEO - RadioReference.com / Broadcastify
Facebook: RadioReference | Broadcastify | Twitter: @RadioReference
Reply With Quote
  #7 (permalink)  
Old 11-01-2010, 6:10 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Oct 2010
Location: Los Angeles, California
Posts: 11
Default

I am having trouble connecting to RR. I have tried with Password/mount given for linux configuration and I get errors:

Darkice: LameLibEncoder.cpp:75: lame lib opening underlying sink error [0]
(search shows wrong port and/or password)

So I tried using my windows laptop to rule out linux issue by downloading scannercast, installed it on my laptop, logged in, selected feed and started broadcasting and get a connection error 103:

Failed to get reply from RR server audio3.radioreference.com/175405886
Unable to read data from transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

I have tried all of the feeds I submitted and get the same problem

Any suggestions?
Reply With Quote
  #8 (permalink)  
Old 11-01-2010, 8:53 PM
Live Audio Administrator
  RadioReference Database Admininstrator
Database Admin
Audio Feed Provider
Audio Feed Provider
 
Join Date: Dec 2002
Location: Hoschton, Georgia
Posts: 527
Default

It looks like one of your connection attempts succeeded earlier, the one at 4:23 PT.

When configuring DarkIce, try using "175405886" instead of "/175405886" for the mount point name, if I remember correctly it prepends the "/" for you.

-- Gordon
Reply With Quote
  #9 (permalink)  
Old 11-01-2010, 9:12 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Oct 2010
Location: Los Angeles, California
Posts: 11
Default

Quote:
Originally Posted by GordonE View Post
It looks like one of your connection attempts succeeded earlier, the one at 4:23 PT.

When configuring DarkIce, try using "175405886" instead of "/175405886" for the mount point name, if I remember correctly it prepends the "/" for you.

-- Gordon
Thanks for the reply. Didn't work.

I also used a windows machine with the scannercast software from this site I get connection errors with the internal configurations.

Everything I am reading & seeing points to an error with the server.

So I am pulling my hair out.

Last edited by LACoFD; 11-01-2010 at 9:14 PM..
Reply With Quote
Sponsored links
  #10 (permalink)  
Old 11-01-2010, 9:39 PM
Live Audio Administrator
  RadioReference Database Admininstrator
Database Admin
Audio Feed Provider
Audio Feed Provider
 
Join Date: Dec 2002
Location: Hoschton, Georgia
Posts: 527
Default

Try running ScannerCast again, then click on the Advanced tab, then change the Logging Level setting to Detailed, and then try using it to provide audio again. After doing so, take a look at the ScannerCast.log log file to see if it provides any clues as to what the problem is.

-- Gordon
Reply With Quote
  #11 (permalink)  
Old 11-01-2010, 9:57 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Oct 2010
Location: Los Angeles, California
Posts: 11
Default

Quote:
Originally Posted by GordonE View Post
Try running ScannerCast again, then click on the Advanced tab, then change the Logging Level setting to Detailed, and then try using it to provide audio again. After doing so, take a look at the ScannerCast.log log file to see if it provides any clues as to what the problem is.

-- Gordon
Here are the logs from my windows visa machine using scannercast.

Code:
01-Nov-2010 19:51:43	Server start requested.
01-Nov-2010 19:51:43	Retrieving initial auto-config for user 'lacofd'
01-Nov-2010 19:51:44	
Feed Info:
01-Nov-2010 19:51:44	6456
01-Nov-2010 19:51:44	Los Angeles County Fire - Blue 1
01-Nov-2010 19:51:44	audio3.radioreference.com
01-Nov-2010 19:51:44	/175405886
01-Nov-2010 19:51:44	80
01-Nov-2010 19:51:44	
Feed Info:
01-Nov-2010 19:51:44	6460
01-Nov-2010 19:51:44	Los Angeles County Fire - Blue 1, 3, 6, 8, and 12 
01-Nov-2010 19:51:44	audio1.radioreference.com
01-Nov-2010 19:51:44	/137180735
01-Nov-2010 19:51:44	80
01-Nov-2010 19:51:44	
Feed Info:
01-Nov-2010 19:51:44	6459
01-Nov-2010 19:51:44	Los Angeles County Fire - Blue 12
01-Nov-2010 19:51:44	audio3.radioreference.com
01-Nov-2010 19:51:44	/82388396
01-Nov-2010 19:51:44	80
01-Nov-2010 19:51:44	
Feed Info:
01-Nov-2010 19:51:44	6457
01-Nov-2010 19:51:44	Los Angeles County Fire - Blue 3
01-Nov-2010 19:51:44	audio3.radioreference.com
01-Nov-2010 19:51:44	/657844165
01-Nov-2010 19:51:44	80
01-Nov-2010 19:51:44	
Feed Info:
01-Nov-2010 19:51:44	6458
01-Nov-2010 19:51:44	Los Angeles County Fire - Blue 6
01-Nov-2010 19:51:44	audio3.radioreference.com
01-Nov-2010 19:51:44	/244933709
01-Nov-2010 19:51:44	80
01-Nov-2010 19:51:44	Selected Feed: Los Angeles County Fire - Blue 1, 3, 6, 8, and 12 (6460)
01-Nov-2010 19:51:44	Selected Feed: Los Angeles County Fire - Blue 1, 3, 6, 8, and 12 (6460)
01-Nov-2010 19:51:44	Sound Card: Microphone / Line In (SigmaTel High Definition Audio CODEC) (1)
01-Nov-2010 19:51:44	Starting audio capture.
01-Nov-2010 19:51:44	Audio capture started.
01-Nov-2010 19:51:44	Audio will recycle on 11/3/2010 3:19 AM
01-Nov-2010 19:51:44	MP3 BitRate: 16Kbps
01-Nov-2010 19:51:44	Stream name: Los Angeles County Fire - Blue 1, 3, 6, 8, and 12 
01-Nov-2010 19:51:44	Connecting to Icecast server audio1.radioreference.com/137180735
01-Nov-2010 19:51:55	Failed to get reply from Icecast server audio1.radioreference.com/137180735: Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
01-Nov-2010 19:51:57	Silently continuing to retry contact (103).
01-Nov-2010 19:52:17	Failed to get reply from Icecast server audio1.radioreference.com/137180735: Unable to read data from the transport connection: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
01-Nov-2010 19:52:28	Server stop requested.
01-Nov-2010 19:52:31	Stopping Push Connection.
01-Nov-2010 19:52:31	Server Stopping Sound Capture.
01-Nov-2010 19:52:31	Stopping audio capture.
01-Nov-2010 19:52:31	Audio capture stopped.
01-Nov-2010 19:52:31	Server Final Cleanup.
01-Nov-2010 19:52:31	Server Stopped.
Now I get this with all 5 feeds. 1 feed connected enough to change from coming soon to offline.

Everything I see on my end is a problem with the RR server.

Thanks for your help
Reply With Quote
  #12 (permalink)  
Old 11-02-2010, 7:18 AM
Live Audio Administrator
  RadioReference Database Admininstrator
Database Admin
Audio Feed Provider
Audio Feed Provider
 
Join Date: Dec 2002
Location: Hoschton, Georgia
Posts: 527
Default

Try configuring DarkIce to use port 8000 instead of 80, a firewall may be blocking the response from RR's server.

You can do so using ScannerCast by installing the non-RR-specific version that's available at ScannerCast Download

-- Gordon
Reply With Quote
  #13 (permalink)  
Old 11-02-2010, 2:17 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Nov 2006
Location: West Sacramento
Posts: 145
Default

Can your computer ping audio1.radioreference.com?

Justin
Reply With Quote
  #14 (permalink)  
Old 11-02-2010, 7:20 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Oct 2010
Location: Los Angeles, California
Posts: 11
Default

Yes I can ping audio1.radioreference.com ave 8ms. I also was able to get the Windows system to connect thanks to Rich.

So now it looks like I need to work at the sound input and darkice.conf.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 7:52 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2011 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions