RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Software > Streaming / Broadcasting / Audio Recording

Streaming / Broadcasting / Audio Recording Interested in putting your scanner online for others to hear? Want to listen to other radios on the internet. This forum is here for you to discuss these topics related to streaming scanners online.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #621 (permalink)  
Old 05-08-2012, 5:11 PM
Member
  Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Feb 2007
Posts: 71
Default

Damn. That'd be ideal.
Reply With Quote
Sponsored links
  #622 (permalink)  
Old 05-09-2012, 3:12 PM
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Jan 2006
Location: Grant Co, IN
Posts: 282
Default

I have done everything I have found here in the forum but still can not get the new program to start up. It is version 55a and will not start from command prompt or double clicking. I have put the ffmpeg.exe in with it as directed in instructions. I am running Windows 7 Ultimate. Any help?
__________________
1RWN: IN12

Shack: Realistic Pro-52, Bearcat 155, Motorola Minitor V, Radio Shack Pro-106, Radio Shack Pro-197, Radio Shack Pro-151
Reply With Quote
  #623 (permalink)  
Old 05-09-2012, 8:04 PM
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Jan 2006
Location: Grant Co, IN
Posts: 282
Default

Error message that I was able to capture:

Traceback (most recent call last):
File "(string)", line 104, in {module}
File "D:\Python\build\pyi.win32\TwoToneDetect551_debug\ outPYZ1.pyz/base64", line 76, in b64decode
TypeError: Incorrect Padding
__________________
1RWN: IN12

Shack: Realistic Pro-52, Bearcat 155, Motorola Minitor V, Radio Shack Pro-106, Radio Shack Pro-197, Radio Shack Pro-151
Reply With Quote
  #624 (permalink)  
Old 05-10-2012, 1:15 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Aug 2005
Posts: 841
Default

Quote:
Originally Posted by whitesox4life View Post
Error message that I was able to capture:

Traceback (most recent call last):
File "(string)", line 104, in {module}
File "D:\Python\build\pyi.win32\TwoToneDetect551_debug\ outPYZ1.pyz/base64", line 76, in b64decode
TypeError: Incorrect Padding
Are you editing your config.cfg file manually? If so, don't. Use the original config.cfg file that came with the download, start the program, and then edit it from within the program. The error you're getting is related to how the email password is stored in that file. Usually this is caused by a manual edit.

Andy
Reply With Quote
  #625 (permalink)  
Old 05-13-2012, 11:24 AM
MikeOxlong's Avatar
Global DB Admin/Senior Mod
  RadioReference Database Admininstrator
Database Admin
 
Join Date: Jun 2001
Location: Central Ontario
Posts: 6,164
Default

Is a BC780XLT too old to work with the scanner control part of the program?
__________________
Mike.

Sorry but I don't accept PM's. Please use email instead.
Reply With Quote
Sponsored links
  #626 (permalink)  
Old 05-13-2012, 11:32 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Aug 2005
Posts: 841
Default

Quote:
Originally Posted by MikeOxlong View Post
Is a BC780XLT too old to work with the scanner control part of the program?
Yes, it uses an older control protocol.
Reply With Quote
  #627 (permalink)  
Old 05-13-2012, 12:10 PM
MikeOxlong's Avatar
Global DB Admin/Senior Mod
  RadioReference Database Admininstrator
Database Admin
 
Join Date: Jun 2001
Location: Central Ontario
Posts: 6,164
Default

Drat!

I was hoping to use an old one to replace the current uncontrollable scanner I've got doing the job now.

Guess I'll keep my eyes open for a cheap controllable scanner at Dayton next week.
__________________
Mike.

Sorry but I don't accept PM's. Please use email instead.
Reply With Quote
  #628 (permalink)  
Old 05-13-2012, 1:21 PM
Member
  Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Feb 2007
Posts: 71
Default

Does anyone know of a program that will open, sound an alert tone or two, and then close? I'd like to use it as a station alert with TTD using the alert_command parameter, and I'd rather not program it myself if I can help it.

Thanks.
Reply With Quote
  #629 (permalink)  
Old 05-14-2012, 5:11 PM
silfam1's Avatar
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2007
Location: Connecticut
Posts: 72
Default

Wirelessly posted (Mozilla/5.0 (iPod; CPU iPhone OS 5_1_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9B206 Safari/7534.48.3)

I am getting a bunch of false trips lately. Using v55. One was during feedback so I am assuming the freqs of the feedback must have been close to the actual tones. Anyone else having similar issues?
__________________
Joe
Reply With Quote
Sponsored links
  #630 (permalink)  
Old 05-14-2012, 7:06 PM
gfdfortynine's Avatar
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Nov 2011
Location: Eastern, Ontario
Posts: 239
Default

Quote:
Originally Posted by silfam1 View Post
Wirelessly posted (Mozilla/5.0 (iPod; CPU iPhone OS 5_1_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9B206 Safari/7534.48.3)

I am getting a bunch of false trips lately. Using v55. One was during feedback so I am assuming the freqs of the feedback must have been close to the actual tones. Anyone else having similar issues?
I have had a false trip during feedback also. My debug file shows alot of a tone found, so maybe increasing your b tone length a touch might help. I'm using v52.
Reply With Quote
  #631 (permalink)  
Old 05-14-2012, 7:10 PM
silfam1's Avatar
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2007
Location: Connecticut
Posts: 72
Default

Wirelessly posted (Mozilla/5.0 (iPod; CPU iPhone OS 5_1_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9B206 Safari/7534.48.3)

Ok I will try that. Thanks for the reply.
__________________
Joe
Reply With Quote
  #632 (permalink)  
Old 05-15-2012, 5:52 PM
aliby19's Avatar
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Mar 2005
Location: Whitestown, IN
Posts: 186
Default

With v55a I am getting a new, strange error. During my county's nightly tone test, TwoToneDetect crashes. I end up with a white box instead of the typical TTD window and (Not Responding) in the header. Also, no further pages are received.

Also strangely - The two feeds I provide using the same system go offline as soon as TTD crashes. Not sure why that is, but it has been consistent for the past few nights.

To fix both TTD and my feeds, I have to reboot the machine. I can't just kill TTD and restart it as it never comes back up, and Debug mode has been no help (when restarting it, at least).

I'm assuming it's because the large number of stacked tones/pages that are coming in, but I can't say for certain.

Andy/All - Any idea how I might go about figuring out what's causing this?

Thanks in advance.
__________________
FF/EMT | Boone Co, IN Feeds: Public Safety & Fire/EMS Dispatch
Radios: Moto 1550XLS VHF, XTS2500 800MHz, Yaesu VX7R, FT51R, 7800R
Scanners: BCD396XT, BCD996XT, HomePatrol-1, Regency MX3000
Reply With Quote
  #633 (permalink)  
Old 05-20-2012, 12:58 AM
Member
  Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Feb 2008
Location: Somerville, NJ
Posts: 174
Default

Quote:
Originally Posted by bblboy54 View Post
I would love to have the ability to specify for twotonedetect to listen specifically to either the right or left channel on the line-in port. Currently I am using this program on the same machine that I am using to broadcast scanner feeds to RR and my set up is a stereo stream with two different frequencies on each. For the most part it seems to work ok but I could see if a tone is on channel 1 at the same time someone is talking on channel 2 it may mess up the frequency that the program is detecting.
I echo this, though I am unsure if it has yet been addressed. I run both my feeds off the same audio port, but I want TTD to focus exclusively on the LEFT channel (thus recording mono audio and emailing a single-channel audio file).

Is this in the works??
__________________
KC2ZHY | 1RWN NJ808 | FF / EMT | Somerset County Emergency Services Feed
* BCD996XT * BCT15X * XPR 7550 VHF Hi * HT1250 VHF Hi * XTS2500 UHF R2 *
Reply With Quote
  #634 (permalink)  
Old 05-20-2012, 10:10 AM
silfam1's Avatar
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2007
Location: Connecticut
Posts: 72
Default TTD occasionally not sending emails

Hi Andy/all,
Twice yesterday TTD didn't send out the emails. It stated page received but did not proceed to the point where it sent the emails. It has never done this before. I am using v55, win7. We use only 1 two tone set. The only change I have done is set the debounce to 1 after a couple of false trips. It has been working flawlessly since we started using it approx 5 weeks ago. Does anyone have any ideas? Do I need to provide the debug screen? Thanks for a great program! Everyone loves it. We have approx 50 members who receive it. Thanks.
Joe
Reply With Quote
  #635 (permalink)  
Old 05-25-2012, 11:00 AM
   
Join Date: May 2012
Posts: 1
Default Excited to try this

Hi Andy,

I'm excited to try your software out. We are in Monroe, Maine, and trying to find an economic means of integrating notification systems without requiring an update to the dispatch system. This pager tone approach sounds like a great way to do it.

Nice move on porting it into python! I dont have a lot of python experience myself, but I'm sure that I can figure it out. I might even want to port this to Node.js. Ever think of putting the code up on github? I see that you already have it on Sourceforge.

Hope to hear from you soon!
Reply With Quote
Sponsored links
  #636 (permalink)  
Old 05-25-2012, 11:16 AM
motomeso's Avatar
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Dec 2002
Location: Ontario
Posts: 874
Default

Do what the rest of us do and buy a ton of those $.99 USB soundcards off Ebay and do it properly.

Quote:
Originally Posted by sjmars0x View Post
I echo this, though I am unsure if it has yet been addressed. I run both my feeds off the same audio port, but I want TTD to focus exclusively on the LEFT channel (thus recording mono audio and emailing a single-channel audio file).

Is this in the works??
Reply With Quote
  #637 (permalink)  
Old 05-28-2012, 8:40 PM
   
Join Date: May 2012
Posts: 3
Default

I downloaded the program and have gotten it to work fine on my laptop with Windows XP, but my desktop with vista the program runs but it will not pick up any audio, I have my line in set as default, and when sound comes across I see it working on the computer's line in visual but the program is not picking it up. Also my department's tones are 847.5 for A and 727.5 for B, watching the program numerous times it shows A tone as 844 and B tone 725 so if I switch the tones to those in the config file, set btonelength at 3, btonebounce to 2 and tone tolerance to 0.0% I should not get any false trips correct? It works now using the actual tones but I get false trips after the initial tones from just the dispatcher talking. Thanks
Reply With Quote
  #638 (permalink)  
Old 06-01-2012, 12:17 AM
aliby19's Avatar
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Mar 2005
Location: Whitestown, IN
Posts: 186
Default

Quote:
Originally Posted by aliby19 View Post
With v55a I am getting a new, strange error. During my county's nightly tone test, TwoToneDetect crashes. I end up with a white box instead of the typical TTD window and (Not Responding) in the header. Also, no further pages are received.

...
This has been a consistent problem over the past few weeks. I am having to reboot my system at least once per day to fix TwoToneDetect and my RR feeds, which is getting to be quite annoying :-(

Now, it doesn't seem to have any sort of pattern to it. I can go 12 hours with no issues, or have this happen right after firing up TTD, which is what happened just now. I rebooted my machine and a tone set was detected. The email with recorded audio got sent just fine, but something crashed TTD right after that (along with my RR feeds).

Most recently it crashed after detecting this tone set: 879/928.1. Figured it might help to potentially recreate the issue, although I don't think it's limited to just this one tone set. I'll keep digging to see what I can find out. If anyone has any other thoughts or ideas, please let me know.
__________________
FF/EMT | Boone Co, IN Feeds: Public Safety & Fire/EMS Dispatch
Radios: Moto 1550XLS VHF, XTS2500 800MHz, Yaesu VX7R, FT51R, 7800R
Scanners: BCD396XT, BCD996XT, HomePatrol-1, Regency MX3000

Last edited by aliby19; 06-01-2012 at 12:30 AM..
Reply With Quote
  #639 (permalink)  
Old 06-02-2012, 9:47 PM
   
Join Date: May 2012
Posts: 3
Default

I keep getting a crash on ffmpeg, geting error
unhandles exception in thread started by <function alert at 0x031A68B0>
Traceback <most recent call last>:
File "<string>", line 469 in alert
File "<string>", line 301, in mail
IOError: [Errno 2] No such file or directory: './audio/Mascoutah_Fire_2012-06-0221_39_54_394000.mp3'

in the audio file only thing that shows up is .wav files, is no .mp3 files
Reply With Quote
  #640 (permalink)  
Old 06-02-2012, 10:23 PM
   
Join Date: May 2012
Posts: 3
Default

Well on my last two post, I deleted then re installed the program and it's picking up the scanner off the line in. And the ffmmeg.exe file I downloaded the file prior to the latest and it is working just fine now, the latest doesn't work om my computer with Vista. Thanks
Reply With Quote
Reply

Tags
twotonedetect

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:14 PM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2011 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions