RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Software > Streaming / Broadcasting / Audio Recording

Streaming / Broadcasting / Audio Recording Interested in putting your scanner online for others to hear? Want to listen to other radios on the internet. This forum is here for you to discuss these topics related to streaming scanners online.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #21 (permalink)  
Old 07-22-2014, 8:33 PM
Member
  Premium Subscriber
Premium Subscriber
Amateur Radio Operator
Amateur Radio
 
Join Date: Apr 2011
Location: Nesconset, NY
Posts: 87
Default

Scott,
That is a good idea for individual colors. It is not setup for that now, but I don't think it would be too difficult to implement, as well as the font size selection. My plan right now is to finish up the documentation, and initial scanner interface (Uniden Bearcat series), then I'll work on those.

John,
Yup, Long Island here, Nesconset (near the Smithaven Mall). This software is actually an offshoot of software I wrote for Nesconset FD (hence the "Fireground" mode), but that software interfaced with MotoTRBO radios only. Once I get the scanner and TPS support done, I will probably add in the MotoTRBO support as well. If anyone doesn't know what TPS is, it is a P25 Unit ID transmitted over an analog channel (similar to MDC-1200). It allows the Unit ID to be up to 8 characters, instead of the 4 of MDC-1200.

BTW: The scrolling for the settings has been posted, you'll see an update prompt next time you restart the app.
Reply With Quote
Sponsored links
  #22 (permalink)  
Old 07-22-2014, 8:36 PM
scancapecod's Avatar
ScanNewEngland Webmaster
  RadioReference Database Admininstrator
Database Admin
Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Oct 2002
Location: Cape Cod, Massachusetts
Posts: 1,779
Default

Another thought...there is no apparent indication of some type of "red flag" when a feed on the display is offline. Maybe some sort of visual after a certain period of time.

It's obvious when the program starts that it takes a certain time for it to connect up to all of the feeds. One time I started it the program acted like it never connected to several feeds. Certain ones worked fine, others that surely should have had activity, namely Boston Police/Fire/EMS, never lit up with activity. Not sure if that was a glitch or just "one of those things". I stopped and restarted and it worked fine.
__________________
Scott - Scan New England Webmaster
http://www.scan-ne.net
Radio Reference MA, RI, & CT Database Admin
Reply With Quote
  #23 (permalink)  
Old 07-22-2014, 8:39 PM
scancapecod's Avatar
ScanNewEngland Webmaster
  RadioReference Database Admininstrator
Database Admin
Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Oct 2002
Location: Cape Cod, Massachusetts
Posts: 1,779
Default

Quote:
Originally Posted by KC2YSI View Post
Scott,
My plan right now is to finish up the documentation, and initial scanner interface (Uniden Bearcat series), then I'll work on those.
Logical, and understood. Any of my drivel, if even feasible, should be secondary. Understand that my programming skills end at being able to record my favorite TV shows (there aren't many) via the Comcast DVR, so at any ludicrous and/or unrealistic suggestions on my part kindly feel free to give me the virtual dope slap.
__________________
Scott - Scan New England Webmaster
http://www.scan-ne.net
Radio Reference MA, RI, & CT Database Admin
Reply With Quote
  #24 (permalink)  
Old 07-22-2014, 9:05 PM
thecop's Avatar
Member
  Shack Photos
Shack photos
Premium Subscriber
Premium Subscriber
Amateur Radio Operator
Amateur Radio
 
Join Date: Dec 2002
Location: Wilmington, NC
Posts: 314
Default

Another anomaly...when entering a new agency under Settings->Manage Agencies, the keystrokes are not visible until you click on OK.
__________________
"We sleep safe in our beds because rough men stand ready in the night to visit violence on those who would do us harm" George Orwell
Reply With Quote
  #25 (permalink)  
Old 07-22-2014, 9:53 PM
Member
  Premium Subscriber
Premium Subscriber
Amateur Radio Operator
Amateur Radio
 
Join Date: Apr 2011
Location: Nesconset, NY
Posts: 87
Default

Quote:
Originally Posted by thecop View Post
Another anomaly...when entering a new agency under Settings->Manage Agencies, the keystrokes are not visible until you click on OK.
Thanks, I am checking that and several other issues people have mentioned. I'll post an update ASAP.
Reply With Quote
Sponsored links
  #26 (permalink)  
Old 07-23-2014, 8:06 AM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Dec 2013
Location: NE Kansas
Posts: 66
Default

Quote:
Originally Posted by KC2YSI View Post
Hello everyone, I have a new software package available to record and log streaming audio as well as input from a scanner or radio. Right now the software will decode and log MDC-1200 and GE-Star signaling, and will be expanded to log QuickCall-II, FleetSync and Motorola Tactical Public Safety (used by FDNY) over the next few weeks as testing on those formats are completed.

You can find out more at ResponderApps

Thanks,
KC2YSI
I have just finished setting up he trial. I love it. Thanks for the trial which gives us an idea on what it looks like and how it works, etc.

I also agree with another poster that the price for what you are giving is very reasonable.

Now my question: If I read right, the above listed formats only work with the software at this time?

Will their be a format for the P-25 system? I am asking as I am unable to get any streaming per your instructions from a later post. I have put the streaming info in but am unable to hear anything thru the software. However I can hear the stream thru the mobile app.

Not sure if I am doing something wrong or the software at this time is not able to do the stream.

Thanks
Reply With Quote
  #27 (permalink)  
Old 07-23-2014, 8:20 AM
Member
  Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Feb 2007
Posts: 74
Default

Any idea how this runs under Wine?


Sent from my iPad using Tapatalk
Reply With Quote
  #28 (permalink)  
Old 07-23-2014, 8:21 AM
scancapecod's Avatar
ScanNewEngland Webmaster
  RadioReference Database Admininstrator
Database Admin
Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Oct 2002
Location: Cape Cod, Massachusetts
Posts: 1,779
Default

Some questions and observations:

1. It appears the licensing is on a per-computer basis. I tried to install the software on the PC I "really" want it and it would not accept the key from the original registration. If that's the case that's fine; again for the price there's really no gripe. However, I offer this in the event your license covers two PC's, in which case something's wrong.

2. Windows 7 normally allows for the sharing of audio input sources between programs. The above PC I was referring to runs 4 scanner feeds that are sent to Broadcastify. I usually kill the audio to them, but with this software I thought it would make for a nice "front end" for enabling and disabling sound as necessary. However, it does not appear to share the audio input. There is a "channel 1" and "channel 2" that when enabled don't seem to do anything. As a matter of fact they don't allow me to save the configuration at all. Only when both are disabled can I click the OK button and exit the configuration screen.

3. I'm also noticing that when there is a new version clearly available at the download site, it takes two runnings of the software to do the update. In other words, I know there's an updated version available. I run the software and it simply starts. I shut it down and start it again and then I'm prompted to update. This has occurred each and every time there has been an updated version.

4. Font settings are working well; thanks for that.
__________________
Scott - Scan New England Webmaster
http://www.scan-ne.net
Radio Reference MA, RI, & CT Database Admin
Reply With Quote
  #29 (permalink)  
Old 07-23-2014, 8:53 AM
Member
  Premium Subscriber
Premium Subscriber
Amateur Radio Operator
Amateur Radio
 
Join Date: Apr 2011
Location: Nesconset, NY
Posts: 87
Default

t0pk01ne, can you send me a link to the feed you are trying to use? If you don't want to post it publicly, you can send it to support@responderapps.com and I will take a look.

kc2kvy, I have not tried it under Wine. It is written using WPF, which I am not sure if Wine supports.

scancapecod, I just modified the license server to allow up to 3 computers per license. If you continue to have troubles, let me know. As far as the Channel 1/Channel 2 goes, you need to enter a name to save a channel if it is enabled. Not sure if that is your issue, but let me know if that doesn't work for you. I'll be adding a "notes" section to them. As far as updates go, I am using the "ClickOnce" installer from Microsoft. I will also add a manual "Check for Updates" process and some form of automated check to solve that.
Reply With Quote
Sponsored links
  #30 (permalink)  
Old 07-23-2014, 9:21 AM
scancapecod's Avatar
ScanNewEngland Webmaster
  RadioReference Database Admininstrator
Database Admin
Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Oct 2002
Location: Cape Cod, Massachusetts
Posts: 1,779
Default

Thanks for the 3 computers per license; that's very generous. Unfortunately it's still not working. Or not for me anyway. When I paste the key and click Activate License, the program shuts down, restarts, stays grayed-out for about 30 seconds, and then prompts to activate, purchase, or continue trial. This is the latest software version.

With regards to using a scanner or receiver connected via a sound card. It appears that these can't be disabled so to speak, and that RadioLog only can control the volume. I'm assuming that's a limitation considering if I have the Line In properties set to "listen to device" I'm going to hear the audio regardless of whether RadioLog is running or not. Maybe RadioLog can be made to somehow "uncheck" that listen to device box in the recording properties of the sound card? If not it's surely not the end of the world.

Thanks.
__________________
Scott - Scan New England Webmaster
http://www.scan-ne.net
Radio Reference MA, RI, & CT Database Admin
Reply With Quote
  #31 (permalink)  
Old 07-23-2014, 10:10 AM
Member
  Premium Subscriber
Premium Subscriber
Amateur Radio Operator
Amateur Radio
 
Join Date: Apr 2011
Location: Nesconset, NY
Posts: 87
Default

scancapecod, Thank you for letting me know about the licensing issue. I am in the process of sending out keys to everyone that purchased before I made the change on the licensing server.

As far as being able to disable the audio, I will look into the issue. There should be a command available that should allow the software to check/uncheck that "Listen to Device" property on the sound card. I agree that would be a useful feature.
Reply With Quote
  #32 (permalink)  
Old 07-23-2014, 10:37 AM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Oct 2003
Location: Westminster, Ma
Posts: 89
Default

I have downloaded the program and think it has some great potential. Some comments -

1. When a broadcast is active and the voice stops for a second or two, the active light (maybe there is another term for this) drops in and out. It would be nice to have it stay on as long as the signal is there.

2. I have had zero luck with the recording function. There are recording files with just a very short burst of a recording. This may or may not be the same issue as #1 above.

3. I have no real knowledge of how the MDC function works, but it seems erratic. Sometimes it works and other times it does not. This may be because of the streaming function and not a problem with the software. Or, the scanner is picking up a conversation just after the pre-id was transmitted.

4. The text file for the MDC file for one of my feeds has disappeared and I cannot seem to get it show up again. I did not change the default file location.

5. There are some stereo feeds, are there any plans to allow volume and or muting of left and right channels?

This is a great program and I would also like to see the licence available for two computers.
__________________
John
www.scannorthcounty.net
Reply With Quote
  #33 (permalink)  
Old 07-23-2014, 10:56 AM
w2lie's Avatar
New York DB Admin
  RadioReference Database Admininstrator
Database Admin
Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Mar 2004
Location: Long Island, NY
Posts: 726
Default

'YSI,
This is really interesting. I'm going to take a closer look at this during the weekend. Since we are practically neighbors, I would be interested in helping you out in any way I can.

Keep up the good work. This is an awesome piece of software!

I'm wondering now if there would be any way to feed the meta tag data back into ProScan so the feeds can display not only the frequency and alpha tag, but the radio that is keyed up as well.
73
__________________
My Long Island Live Scanner website: www.w2lie.net
Providing RR with the following Scanner Feeds: NCFD | NCPD | SCFD | SCPD
For my Full list of Long Island Feeds & Remote Radio click here
Reply With Quote
  #34 (permalink)  
Old 07-23-2014, 11:08 AM
scancapecod's Avatar
ScanNewEngland Webmaster
  RadioReference Database Admininstrator
Database Admin
Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Oct 2002
Location: Cape Cod, Massachusetts
Posts: 1,779
Default

Wow Joe, you're gonna need beer.

Thanks for the licensing fix. Again, very generous.

A few more observations:

1. Some feeds seem to randomly shut themselves off. There's no pattern to it and it's an exception, not a rule. Wonder if it's a hiccup in the feed itself?

2. Twice now, after the program has run for a considerable period of time, I have noticed one feed "chugging", in other words spitting out small pieces of audio. I wondered if it was some type of buffering as the audio contained an MDC chirp which made the radio ID section scroll incessantly. I think that part of it was just coincidence. The first time I was able to disable the offending feed and the program continued without issue, so maybe it was the feed itself. The second time I was involved in another task on the laptop in question and just shut down the program so I can't offer any more data on that event. Restarting the program eliminates the issue though.

3. I do continue to see what appears like certain feeds not starting when the program is run. Again, a shutdown/restart "seems" to solve this.

Thanks...Scott
__________________
Scott - Scan New England Webmaster
http://www.scan-ne.net
Radio Reference MA, RI, & CT Database Admin
Reply With Quote
  #35 (permalink)  
Old 07-23-2014, 11:18 AM
Member
  Premium Subscriber
Premium Subscriber
Amateur Radio Operator
Amateur Radio
 
Join Date: Apr 2011
Location: Nesconset, NY
Posts: 87
Default

johnmac, Can you provide me with the feed URL you are having problems with? I will check it out. I will be adding settings for the noise filter I use to detect if there is no audio. It sounds like your feed probably has a bunch of static in it, which is causing the issue. That would explain your issues, but I would like to check to be sure. Also, I will be making the "kick" time I use (time between the end of the audio and when I stop recording) adjustable. There will now also be buttons on the settings screen to open up explorer to the log file or recording file folders, which should make things easier.

w2lie, I am looking into integrating with ProScan and several other packages. Some seem easy, others not so much.

scancapecod, I found an issue this morning where if I got any sort of network error, I would shutdown the feed and not try to reconnect until you restarted the app. I will have a fix for that today, along with a long list of minor issues people have reported. The "chugging" is probably related to this feed issue as well. I am also going to add the ability to turn off certain decoders if you know they are not being used on a particular feed.
Reply With Quote
Sponsored links
  #36 (permalink)  
Old 07-23-2014, 11:51 AM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Oct 2003
Location: Westminster, Ma
Posts: 89
Default

[QUOTE=KC2YSI;2222216]johnmac, Can you provide me with the feed URL


http://192.168.1.40:8110/scannorthcounty Try this one. It is a stereo feed, not sure if that is a factor or not.

Also, just noticed that you cannot turn volume down all the way. This may be by design. At any rate, When trying to use the mouse to control volume, it is very jerky. Some programs allow you to use the middle wheel to control the volume once you click on the slider.

And, not to add to the list. Ability to move the different feeds around on the screen.

Great program!!
__________________
John
www.scannorthcounty.net
Reply With Quote
  #37 (permalink)  
Old 07-23-2014, 12:10 PM
Member
  Premium Subscriber
Premium Subscriber
Amateur Radio Operator
Amateur Radio
 
Join Date: Apr 2011
Location: Nesconset, NY
Posts: 87
Default

Hi johnmac, The link you gave is an internal link, which I can't get to. I went to the Scan North County Live web site and got the URLs you should use. I have tested these and they work.

Northern Worcester County Fire and EMS: Northern Worcester County Fire and EMS
Fitchburg and Lunenburg Fire and Mid State Control: Fitchburg and Lunenburg Fire and Mid State Control
Ashburnham Area Fire Departments: Ashburnham Area Fire Departments

Just click on each feed link and when they open in your browser, copy that link.
Reply With Quote
  #38 (permalink)  
Old 07-23-2014, 12:13 PM
Member
  Premium Subscriber
Premium Subscriber
Amateur Radio Operator
Amateur Radio
 
Join Date: Apr 2011
Location: Nesconset, NY
Posts: 87
Default

Just a quick update for everyone, I will be doing a big update tonight based on everyone's feedback. Thank you to everyone that has given feedback, it is very appreciated. Also, scanner integration will be posted tonight, and I will be posting a scanner raffle to go with it... More info tonight.
Reply With Quote
  #39 (permalink)  
Old 07-23-2014, 7:27 PM
scancapecod's Avatar
ScanNewEngland Webmaster
  RadioReference Database Admininstrator
Database Admin
Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Oct 2002
Location: Cape Cod, Massachusetts
Posts: 1,779
Default

Joe, not sure if this has been mentioned before or not. Now that I'm actually in front of the feed PC, I am noticing that my feed scanners are not lighting up their respective sources in the software. To be clear these are local scanners attached to multiple line in devices on this PC.

I know you're working on things now but this may be another "issue". Thanks.

Scott
__________________
Scott - Scan New England Webmaster
http://www.scan-ne.net
Radio Reference MA, RI, & CT Database Admin
Reply With Quote
  #40 (permalink)  
Old 07-23-2014, 7:58 PM
w2lie's Avatar
New York DB Admin
  RadioReference Database Admininstrator
Database Admin
Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Mar 2004
Location: Long Island, NY
Posts: 726
Default

Scott, I noticed the exact same issue when I started my locally connected scanners. Using the same radio as a 'stream' lit up the box just fine.

I've also noticed that my radio sources seem to vanish.

(Both were documented off-line, via e-mail) I'm CC'ing the issues here for record keeping.

73
__________________
My Long Island Live Scanner website: www.w2lie.net
Providing RR with the following Scanner Feeds: NCFD | NCPD | SCFD | SCPD
For my Full list of Long Island Feeds & Remote Radio click here
Reply With Quote
Reply

Tags
feed url, logging, software, streaming, streaming audio

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 1:18 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2011 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions