• Effective immediately we will be deleting, without notice, any negative threads or posts that deal with the use of encryption and streaming of scanner audio.

    We've noticed a huge increase in rants and negative posts that revolve around agencies going to encryption due to the broadcasting of scanner audio on the internet. It's now worn out and continues to be the same recycled rants. These rants hijack the threads and derail the conversation. They no longer have a place anywhere on this forum other than in the designated threads in the Rants forum in the Tavern.

    If you violate these guidelines your post will be deleted without notice and an infraction will be issued. We are not against discussion of this issue. You just need to do it in the right place. For example:
    https://forums.radioreference.com/rants/224104-official-thread-live-audio-feeds-scanners-wait-encryption.html

Another BCT15 firmware difficulty, need help please

Status
Not open for further replies.
Joined
Apr 9, 2009
Messages
14
Location
Vero Beach, Fl.
#1
So I opened up my BCT15 scanner today and checked the firmware it's v 1.03.04, so I need to update it. I checked the link I found on this discussion board and doenloaded the installer and the firmware update. Useing a RS USB to Comm cable w/driver I attempted to load the firmware. I seemed to have it on my computer ok and the installer works. But an error message with several options comes up.with several possabilities.
1.Bad connection. The RS cable had just communicated fine with my GPS So I cheked all of the com port numbers and speed to match, computer and radio. I started BCtool and it connects fine and is logging and controlling BCT15.
2. No power to BCT15, I;m looking at a blank orange screen with backlight on.
3. Did not press L/O and #6 while turning on, see #3 above.
4. Removed batteries I do not know about batteries for the BCT15
5. Firmware version is corrupted download another.
\Anyone know another source for the firmware?
Any other suggestions?

Larry Grayam N7XIV
 

davidmc36

Member
Premium Subscriber
Joined
Nov 14, 2004
Messages
1,847
Location
South East Ontario
#2
1.Bad connection. The RS cable had just communicated fine with my GPS So I cheked all of the com port numbers and speed to match, computer and radio. I started BCtool and it connects fine and is logging and controlling BCT15.


4. Removed batteries I do not know about batteries for the BCT15
You are right about the batteries, no batteries in the 15.

Did you try doing a restart on your computer after you shut down BCTool. That might make sure BCTool is not still keeping the comm port busy. Make sure no other program is tying up the comm port.
 
Last edited:

DaveIN

Founders Curmudgen
Database Admin
Joined
Jan 5, 2003
Messages
6,508
Location
West Michigan
#3
I would open the device manage in Windows and verify the Com port number. In the BC_UP is there a pull down with multiple ports available? If you use a hotsynk for PDA or another device make sure it's not running in the background.

When you set the radio up for the update, the power supply should be connected. Be sure you hold the L/O and 6 button, then turn on the power switch. The display will be blank with the orange/red background only.
 
Joined
Apr 9, 2009
Messages
14
Location
Vero Beach, Fl.
#4
Thanks everyone for the help. The problem seemed to be a corrupt BC uploader software as soon as I replaced it with another download I was able to update the firmware to 1.06. Now all I have to do is get this to recognize an EDACS system. BTW I'm now trunk tracking the St. Lucie County F;orida Public Safety system fine. The renanding firmware seems to do the trick, that rebanding is why I got the new BCT15 scanner in the first place. Thanks again-Larry Grayam N7XIV
 
Status
Not open for further replies.
Top