• Effective immediately we will be deleting, without notice, any negative threads or posts that deal with the use of encryption and streaming of scanner audio.

    We've noticed a huge increase in rants and negative posts that revolve around agencies going to encryption due to the broadcasting of scanner audio on the internet. It's now worn out and continues to be the same recycled rants. These rants hijack the threads and derail the conversation. They no longer have a place anywhere on this forum other than in the designated threads in the Rants forum in the Tavern.

    If you violate these guidelines your post will be deleted without notice and an infraction will be issued. We are not against discussion of this issue. You just need to do it in the right place. For example:
    https://forums.radioreference.com/rants/224104-official-thread-live-audio-feeds-scanners-wait-encryption.html

Austin Spectra died

Status
Not open for further replies.

soupster

Member
Joined
Jan 5, 2005
Messages
30
I checked all the connections all ok. It seems some of the ferrules are loose and theres considerable corosion. Its been on the truck for 3 years . Guess its time to upgrade. Any suggestions....?
 

kf4lne

Member
Joined
Jul 31, 2005
Messages
440
Location
Bristol, VA
get some good electronics contact cleaner and clean it up well, use some dielectric spark plug wire grease when you put it back together to prevent corrosion. If you want to replace it, look into a commercial mobile antenna such as a larsen or one of the PCTEL brands like AS or Maxrad, they both make multi-band antennas and both are excellent for both operation and durability.
 
Status
Not open for further replies.
Top