Brand new XTS5000 battery charging?

MedicDavid78

Member
Premium Subscriber
Joined
Jul 7, 2010
Messages
455
Location
The Astro25mosP25ere
#1
Hey guys & gals, just a quick question. I just received a brand new Impres Li-ion high-capacity 4500-mAh battery for my XTS5000. I just put it in the charger for the first time and it’s conditioning Itself! Now I can’t recall any of my other batteries ever doing this but it’s been a while since I have gotten a new one. I assumed a new battery should already have been thru this already since it’s factory-spec’d. Is this normal function for a new battery or do I need to remove it right away? Thanks.
 
Joined
Jul 8, 2002
Messages
9,972
Location
Taxachusetts
#2
IF memory serves me, if a Battery has not seem an Impress Charger in 20-45 Days, it will automatically go into conditioning mode. The time seemed to vary depending on the firmware version.

So.. it sounds like it is doing what it should, as there is no knowing how long the battery sat in the factory before being assigned to your purchase
A bypass is when you see it go to Condition, immediately pull it an reset it [sometimes a quick double drop] and it will go to normal "red" charging.
Hey guys & gals, just a quick question. I just received a brand new Impres Li-ion high-capacity 4500-mAh battery for my XTS5000. I just put it in the charger for the first time and it’s conditioning Itself! Now I can’t recall any of my other batteries ever doing this but it’s been a while since I have gotten a new one. I assumed a new battery should already have been thru this already since it’s factory-spec’d. Is this normal function for a new battery or do I need to remove it right away? Thanks.
 
Joined
Feb 12, 2017
Messages
99
Location
NV
#3
Normally all Moto impress batteries will go though the conditioning (yellow light) cycle the first time you take them out of the box. Not sure why, but we buy several batteries every year and every one of them goes though the conditioning cycle the first time.
 

n8dhw

Member
Premium Subscriber
Joined
Dec 19, 2002
Messages
402
Location
Middletown, Ohio
#4
If I recall correctly it’s the first initializing process for a New Impres battery. They all do that when you first pull them out of the box and put them on the charger for the first time.


Sent from my iPad using Tapatalk
 
Top