• Effective immediately we will be deleting, without notice, any negative threads or posts that deal with the use of encryption and streaming of scanner audio.

    We've noticed a huge increase in rants and negative posts that revolve around agencies going to encryption due to the broadcasting of scanner audio on the internet. It's now worn out and continues to be the same recycled rants. These rants hijack the threads and derail the conversation. They no longer have a place anywhere on this forum other than in the designated threads in the Rants forum in the Tavern.

    If you violate these guidelines your post will be deleted without notice and an infraction will be issued. We are not against discussion of this issue. You just need to do it in the right place. For example:
    https://forums.radioreference.com/rants/224104-official-thread-live-audio-feeds-scanners-wait-encryption.html

EZ-Scan DMR Import Bug

Status
Not open for further replies.

Forts

Mentor
Database Admin
Joined
Dec 19, 2002
Messages
5,510
Location
Ontario, Canada
#1
I just noticed this morning that it sometimes imports incorrect talkgroups for DMR systems. After importing a few channels local to me I wondered why I wasn't receiving any traffic... turns out the talkgroups are all wrong.

I was importing the following:

Lambton County, Ontario (ON) Scanner Frequencies and Radio Frequency Reference

Lambton County - Sarnia

- Sarnia Fire TAC 1 thru 4
- Sarnia Transit
- Sarnia CareAvan
- Sarnia works

In the EZ-Scan import wizard the talkgroups show the proper values but after importing I'm seeing this:

Code:
Talkgroup       Correct TG     Imported TG
SFRS TAC 1       15378490       43066
SFRS TAC 2       15378491       43067
SFRS TAC 3       15378492       43068
SFRS TAC 4       15378494       43070
Transit          51234          51234 (ok!)
CareAvan         51235          51235 (ok!)
Works            2912041        28457
If you look at 13578490 in hex it's 00EA A83A, while 43066 is A38A so it seems any bytes over FFFF are being thrown away. I've also submitted this to the bug report email address that Wendy provided. So if you are importing DMR users with large talkgroups, double check what is actually being imported!
 

Forts

Mentor
Database Admin
Joined
Dec 19, 2002
Messages
5,510
Location
Ontario, Canada
#4
Hmmm... strange. I just exited the app, restarted and made a new, blank configuration. Imported the above channels and they came in correctly. How bizarre! It was 100% repeatable using my existing configuration with the current app.
 
Status
Not open for further replies.
Top