• Effective immediately we will be deleting, without notice, any negative threads or posts that deal with the use of encryption and streaming of scanner audio.

    We've noticed a huge increase in rants and negative posts that revolve around agencies going to encryption due to the broadcasting of scanner audio on the internet. It's now worn out and continues to be the same recycled rants. These rants hijack the threads and derail the conversation. They no longer have a place anywhere on this forum other than in the designated threads in the Rants forum in the Tavern.

    If you violate these guidelines your post will be deleted without notice and an infraction will be issued. We are not against discussion of this issue. You just need to do it in the right place. For example:
    https://forums.radioreference.com/rants/224104-official-thread-live-audio-feeds-scanners-wait-encryption.html

Fake Watson?

Status
Not open for further replies.

WhittyNick

Member
Joined
Jan 27, 2014
Messages
4
I just bought a Watson W-881 through Amazon. I thought I'd check it when it arrived as i had read that there are fake versions of this antenna. Upon inspecting the antenna I noticed a couple of discrepancies. The first is that it is advertised as being 41cm in length whereas mine is only 40cm. Also I have been looking at images of the antenna on the net and the writing on the label at the base of the antenna runs vertically up the antenna whereas mine runs around the circumference. The little yellow plasic wallet that it comes in looks genuine, but who knows. I might just be being paranoid.
 

WhittyNick

Member
Joined
Jan 27, 2014
Messages
4
I think I might have a fake then coz reception isn't much better than the little rubber ducky that came as standard. I get one extra signal bar if I'm lucky.

Sent from my Nexus 7 using Tapatalk
 

Fast1eddie

Member
Premium Subscriber
Joined
Mar 4, 2004
Messages
544
Location
Crafton Pennsylvania
Doubt one measly centimeter is causing your reception troubles. Reexamine your installation and pay extremely close attention to your terminated RF connector to the radio and antenna. Not familiar with this model, but some antennas have a bent center tab at the bottom base which provides a physical contact to the mount. Possibly there is corrosion or maybe the tab is broken or not making a good electrical (remember, RF is electrical) connection.

Finally, maybe you have a defective antenna. Defects do occur in manufacturing.

Good Signals,

ed
 
Status
Not open for further replies.
Top