G4 antenna connector failure

Joined
Dec 19, 2002
Messages
67
Location
Pamlico County, NC
#1
Aaaaurgh! Antenna connector failure on 1 week old G4. I have a message into Ray about this but I think I got to the bottom of why my stock antenna performed so poorly. Took it off this afternoon and the center pin in the radio came out! Not real happy at this point of ownership.
 

Attachments

N6ML

Member
Premium Subscriber
Joined
Sep 26, 2008
Messages
361
Location
SF Bay / Delta, CA
#2
Aaaaurgh! Antenna connector failure on 1 week old G4. I have a message into Ray about this but I think I got to the bottom of why my stock antenna performed so poorly. Took it off this afternoon and the center pin in the radio came out! Not real happy at this point of ownership.
Ahh just bend it a bit with needle-nose and stuff it back in the hole!

I'm kidding!

Will have to keep an eye on mine :/
 
Joined
Dec 19, 2002
Messages
67
Location
Pamlico County, NC
#3
Working with Ray now on how to return. Unication themselves said I should only use their stock antenna. But had to try others since the stock did not work well. I guess I know why the stock may not have been working well.

If you look at the end of the pin it does not look broken, nor can I see any solder, so I am guess int was a poorly manufactured connector.

Oh, I did stuff it back in the hole for the time being!
 

iMONITOR

Member
Premium Subscriber
Joined
Sep 20, 2006
Messages
5,828
Location
MACOMB, MI.
#4
It's probably nothing more than a stubby piece of coax with the pin crimped on the center conductor and the wire pulled out of the nylon a little. Have you tried pushing it back in?
 

BenScan

Member
Premium Subscriber
Joined
May 12, 2001
Messages
580
#5
I had that happen when I used an SMA to BNC adapter. I just shoved it back in, and it's been working fine for my use.
 
Joined
Dec 19, 2002
Messages
67
Location
Pamlico County, NC
#7
just got UPS notification my G4 is inbound from Unication after being repaired. 7 days from when it left my house to being back to my house. Nice turn-around.

So no more non-OEM antennas for me on the G4.
 
Joined
Mar 7, 2002
Messages
2,529
Location
New Orleans region
#10
My first guess is that it might have been a press fit. But press fits with soft metal won't last long. The long term solution is for the connection to be soldered. There are several ways to solder the connection.

But until the warranty runs out, you did the normal route and went back to the source.
 
Top