• Effective immediately we will be deleting, without notice, any negative threads or posts that deal with the use of encryption and streaming of scanner audio.

    We've noticed a huge increase in rants and negative posts that revolve around agencies going to encryption due to the broadcasting of scanner audio on the internet. It's now worn out and continues to be the same recycled rants. These rants hijack the threads and derail the conversation. They no longer have a place anywhere on this forum other than in the designated threads in the Rants forum in the Tavern.

    If you violate these guidelines your post will be deleted without notice and an infraction will be issued. We are not against discussion of this issue. You just need to do it in the right place. For example:
    https://forums.radioreference.com/rants/224104-official-thread-live-audio-feeds-scanners-wait-encryption.html

Help needed with DSDPlus, SDRSharp & VAC

Status
Not open for further replies.

Reelfishguy

Member
Premium Subscriber
Joined
May 30, 2011
Messages
32
#1
I have those installed on my laptop with the RTL2832U dongle. I have 2 portable radios--one DMR and one NXDN. My soundcard recording is set to Line 1-VAC, the playback is set to the laptop internal speakers. I do not hear the decoded digital audio in the speakers but I can hear analog audio in the speakers. I cannot see any audio waveform in the DSD screen. I tried to run Zadig.exe but the RTL dongle is not listed as a device although List All Devices is checked. I probably have several problems but would like to get this finally working. Thanks for all the suggestions.
 
Joined
Dec 31, 2005
Messages
1,717
#2
Post some screenshots of your audio set up for SDR# and DSD+.

Filter audio is unchecked on SDR#, right?
 

Reelfishguy

Member
Premium Subscriber
Joined
May 30, 2011
Messages
32
#4
Thanks for the help!! I did make some changes today. I am feeding the laptop with a discriminator output in to the mic in and it does decide both DMR and NXDN. I am hearing in the speakers both the decoded audio and the discriminator audio (which is the raw digital audio). My setup for the sound card is Control Panel>Sound>Playback--Line 1 in (Virtual Audio Cable) set to Default, and Speakers (internal) Ready; Recording--Microphone is set to Default Device and Line 1 (Virtual Audio Device) is set to Default Communications Device. Using a separate receiver certainly made the decoding very stable. I just hear both the discriminator audio and the decoded digital audio at the same time. Just want to hear the decoded audio. Thanks again for the help
 
Joined
Sep 19, 2002
Messages
5,206
Location
Toronto, Ontario
#5
If you're using a discriminator tap, then there is no need for a virtual audio cable, so at this time, I wouldn't suggest installing one - or since you already have, just uninstall it for the time being. You can always reinstall it later.

With no virtual cable present, your onboard sound device should be input device #1 as well as output device #1 - which are also the default devices that DSD+ uses for input and output, so easy peasy, nothing needs to be specified on the DSD+ command line.

If you're still hearing the raw audio through your speakers, there's typically a setting you need to adjust. Here, I have to click on Sound / Playback devices / Speakers / Configure / Speakers Properties; once I'm there, there are mute buttons for Microphone and Line In; when they're muted, raw audio doesn't come through the speakers.
 
Status
Not open for further replies.
Top