• Effective immediately we will be deleting, without notice, any negative threads or posts that deal with the use of encryption and streaming of scanner audio.

    We've noticed a huge increase in rants and negative posts that revolve around agencies going to encryption due to the broadcasting of scanner audio on the internet. It's now worn out and continues to be the same recycled rants. These rants hijack the threads and derail the conversation. They no longer have a place anywhere on this forum other than in the designated threads in the Rants forum in the Tavern.

    If you violate these guidelines your post will be deleted without notice and an infraction will be issued. We are not against discussion of this issue. You just need to do it in the right place. For example:

Linux, Darkice, Alsa, plughw and sample rates

Not open for further replies.
Apr 11, 2010
Knoxville, TN
I'm currently having some trouble getting darkice to play nicely with this sound card.

I've figured out that this sound card will only open capture at 48000. If I stream at 48000 it sounds great, but the specs for Radioreference call for 22050kHz.

Streaming at 22050 is impossible using hw:1,0 for the device. Using plughw:1,0 works, but the sample rate is apparently configured to convert from 44100. This makes the audio choppy and the voice sound slightly lower pitched and distorted. ( Knoxville Police Dispatch ) I need to configure (Alsa) to convert from 48000 instead when using "plughw"

I have very little experience using either or Darkice or Alsa, and since Darkice cannot do any sample rate conversions, I am now tackling the issue of properly configuring "plughw" The Alsa documention is very limited and quite confusing when it comes to this simple matter. I was hoping someone here could point to the configuration options to do this.

I could get another card that will do 22050 directly, but I was hoping someone could offer a configuration fix.



Premium Subscriber
Aug 7, 2012
Scheveningen, Zuid-Holland
Same problem


I currently have the same problem. When encoding at 44100 the feed sounds perfect. But this is against the rules so I'd like to reduce to 22050 but as soon as I do the feed is lower in pitch and slowed down.

In darkice there are two sections: input and icecast2-0 both of which you can put samplerate, bitspersample and channel, etc. I don't know the correct combination or if it's just a problem with my usb sound device or something.

Have you figured it out?


Not open for further replies.