NXDN TGID format issue

DaveNF2G

Member
Premium Subscriber
Joined
Jan 23, 2001
Messages
9,012
Location
Rensselaer, NY
#1
I recently submitted some info on an IDAS-D (NXDN) system that I gathered using DSDPlus.

DSD+ reports talkgroup IDs (and radio IDs) in format n-nnn, which is what I submitted.

Recently, the talkgroup listing in RRDB was changed to format 00-nnnn, where nnnn represents the numbers I submitted. I tried inputting the talkgroups into Sentinel using this adjusted format. Sentinel reports "Invalid Talkgroup" when I do that, but it accepts n-nnn.

I cannot evaluate whether the talkgroups will be followed correctly by my Uniden 436 without taking another road trip, but I suspect this issue might be causing some complaints about Uniden scanner performance on these systems.
 

GTR8000

Troublemaker
Database Admin
Joined
Oct 4, 2007
Messages
6,408
Location
BEE00
#2
Dave, take a look at the system again, I've adjusted the TGID's to (maybe?) more accurately match what you submitted.

RRDB and Sentinel format for NXDN Icom IDAS decimal talkgroup is hh-gggg where hh is Home Repeater (1-30) and gggg is group ID (0001-2047)

So it appears that DSD+ is probably dropping leading zeroes, i.e. 1-119 would be 01-0119 in the RRDB and Sentinel.

I made the changes early Monday afternoon, so they won't be reflected in Sentinel until next week's database pull.
 

DaveNF2G

Member
Premium Subscriber
Joined
Jan 23, 2001
Messages
9,012
Location
Rensselaer, NY
#3
I have been able to add the properly formatted RIDs into Sentinel. You're right about the leading zeroes. I will post a comment about this issue into a DSDPlus thread as the difference can be confusing.

I have also been working under the presumption that the 1. in front of the network ID refers to the Area number. Again, I have to leave my house to test any of this because none of the sites can be received at home, so any confirmation or correction by knowledgeable folk is welcome.
 
Top