• Effective immediately we will be deleting, without notice, any negative threads or posts that deal with the use of encryption and streaming of scanner audio.

    We've noticed a huge increase in rants and negative posts that revolve around agencies going to encryption due to the broadcasting of scanner audio on the internet. It's now worn out and continues to be the same recycled rants. These rants hijack the threads and derail the conversation. They no longer have a place anywhere on this forum other than in the designated threads in the Rants forum in the Tavern.

    If you violate these guidelines your post will be deleted without notice and an infraction will be issued. We are not against discussion of this issue. You just need to do it in the right place. For example:
    https://forums.radioreference.com/rants/224104-official-thread-live-audio-feeds-scanners-wait-encryption.html

PL-660

Joined
May 1, 2019
Messages
3
Location
São Paulo, Brazil
#1
Please, I have a question regarding the PL-660. First let me say that this is my second PL-660. I lost the first one because I forgot the wall charger connect during the night and in the morning the radio was completed died. Now the second one also died , in this case I am using the radio only with the charger without the batteries and for short time. Someone could tell me if have seen problems like this !!
 

N9JCQ

Member
Premium Subscriber
Joined
Aug 30, 2005
Messages
442
#2
Pinezi, the build quality of the Tecsun radios fluctuate. My first PL-660 will now not charge the batteries so I have to charge them on a separate charger. I bought a second PL-660 and it seems much better. Does your radio run on batteries at all?
 
Joined
May 1, 2019
Messages
3
Location
São Paulo, Brazil
#3
N9JCQ, thank you for the reply. The radio is completed die. No light in the display, nothing. The red button POWER does not work. I try using only the batteries but without success. I am looking for the schematic in order to follow the power supply inside the boards.
Times ago I remember some comments on the internet about the 3.3 Volts voltage regulator burned inside. But I need at least the schematic !!
 

N9JCQ

Member
Premium Subscriber
Joined
Aug 30, 2005
Messages
442
#4
I know the schematics are scarce. I think this site has one. I have never really looked at it and I don't know the site at all. Be careful before you download. Good luck and let us all know what you find wrong with the radio. Elektrotanya for electronics experts
 
Joined
Dec 25, 2008
Messages
3,120
Location
New Zealand
#5
IMHO you shouldn't run any radio on the charger without the batteries installed. The charger puts out more (sometimes much more) voltage than the batteries alone to charge them - the batteries in effect become a voltage regulator. Some radios won't turn on with the charger connected and others turn off as soon as you connect the charger simply to protect the radio.
 
Joined
May 1, 2019
Messages
3
Location
São Paulo, Brazil
#6
I found the problem with my PL-660. There is a 3.3 V voltage regulator (IC8) burned inside. I switch on the power supply using the normal wall charger and using a external adjusted power supply I have connected 3,3v in the output pin of the IC8 using a red wire welded at the board. Now it is working again. I do not have the specification of this original IC, but I found a similar from Texas. I bought some of then in the web, when its comes I will change the old one.
 

Attachments

Top