• Effective immediately we will be deleting, without notice, any negative threads or posts that deal with the use of encryption and streaming of scanner audio.

    We've noticed a huge increase in rants and negative posts that revolve around agencies going to encryption due to the broadcasting of scanner audio on the internet. It's now worn out and continues to be the same recycled rants. These rants hijack the threads and derail the conversation. They no longer have a place anywhere on this forum other than in the designated threads in the Rants forum in the Tavern.

    If you violate these guidelines your post will be deleted without notice and an infraction will be issued. We are not against discussion of this issue. You just need to do it in the right place. For example:
    https://forums.radioreference.com/rants/224104-official-thread-live-audio-feeds-scanners-wait-encryption.html

Pro96Com Error: Any ideas?

Status
Not open for further replies.

SCPD

Member
Joined
Feb 24, 2001
Messages
65,126
Location
Virginia
After leaving Pro96Com on for days, I always seem to get a random error that terminates the program. See the attached screen shot but I get the following error:

"Assertion failed: (vbFlag && (errPtr -> ERRcInitDtc >= varType -> tpClass.tpcDtorCount)) || (!vbFlag && (errPtr -> ERRcInitDtc >= varType -> tpClass.tpcNVdtCount)) || flags, file xx.cpp, line 3293"

Followed by:

"Abnormal Program Termination."

It appears to be a custom error message rather than a run-time error.
 

Attachments

pepsima1

Completely Banned for the Greater Good
Banned
Joined
Nov 19, 2008
Messages
1,076
Location
Pimp County, Neveda
After leaving Pro96Com on for days, I always seem to get a random error that terminates the program. See the attached screen shot but I get the following error:

"Assertion failed: (vbFlag && (errPtr -> ERRcInitDtc >= varType -> tpClass.tpcDtorCount)) || (!vbFlag && (errPtr -> ERRcInitDtc >= varType -> tpClass.tpcNVdtCount)) || flags, file xx.cpp, line 3293"

Followed by:

"Abnormal Program Termination."

It appears to be a custom error message rather than a run-time error.
I would say to either do an un-install and re-install of ProCom96. If that does not work then its related to an issue with your computer. I have never had issues running this software for days at a time.
 

SCPD

Member
Joined
Feb 24, 2001
Messages
65,126
Location
Virginia
This has actually been a long lasting problem that has been on previous fresh installs of Windows. Normally it would have taken about two weeks of constant running for this to pop up. There is also nothing to uninstall as Pro96Com is a portable application. I have re-downloaded the program many times before.
 

pepsima1

Completely Banned for the Greater Good
Banned
Joined
Nov 19, 2008
Messages
1,076
Location
Pimp County, Neveda
Well I run it on Windows 7 and Windows 8 with no trouble and I run for a week at a time or so with no trouble. Good Luck. Sound like you need to email the vendor or the software writer
 

mikey60

Member
Premium Subscriber
Joined
Sep 15, 2003
Messages
3,512
Location
Oakland County Michigan
I've been shown that error message before. I believe it to be an issue in one of the compiler libraries as there are no source code files that I created named "xx.cpp". I've converted the code to a newer version of the compiler, so hopefully that will take care of this issue. I have a few more things to look at before I can release an update though.

I don't have a timeframe. Things are pretty hectic around here lately and show no signs up letting up.

Mike
 

SCPD

Member
Joined
Feb 24, 2001
Messages
65,126
Location
Virginia
Thanks. I know how you feel. I'm trying to release a code library but things are hectic here as well. Thanks for your efforts!
 
Status
Not open for further replies.
Top