• Effective immediately we will be deleting, without notice, any negative threads or posts that deal with the use of encryption and streaming of scanner audio.

    We've noticed a huge increase in rants and negative posts that revolve around agencies going to encryption due to the broadcasting of scanner audio on the internet. It's now worn out and continues to be the same recycled rants. These rants hijack the threads and derail the conversation. They no longer have a place anywhere on this forum other than in the designated threads in the Rants forum in the Tavern.

    If you violate these guidelines your post will be deleted without notice and an infraction will be issued. We are not against discussion of this issue. You just need to do it in the right place. For example:
    https://forums.radioreference.com/rants/224104-official-thread-live-audio-feeds-scanners-wait-encryption.html

Radio Shack Pro 96

Status
Not open for further replies.

rchjr

Member
Premium Subscriber
Joined
Dec 26, 2005
Messages
30
Location
Phoenix, Az
#1
I have a Radio Shack Pro 96 that is not working. Anyone have any recommendations as to where in Phx I can take it to get repaired? Prefer not to send out to get fixed.

Thanks,

Rchjr
 
Joined
May 23, 2017
Messages
344
Location
Vrigo Super Cluster, Milky Way Galaxy, Sagatarious
#3
rchjr - I do not recommend fixing a Pro 96 as its Hardware Limited to only onboard programming and its likely a repair might cost more than a WS 1080/1088 scanner NEW.
the Pro 96 is also no longer Supported and you cant add a computer. the Pro-688/ WS 1088 is a better scanner, it has a SD card with the Entire USA/Canada database on it. and you can update with a Windows computer. Programing by PC is much easier and faster than by hand, Bonus, you also get FREE Lifetime updates for the Database and more.
I'm not sure where in AZ you can repair a Scanner, perhaps try HRO ? Ham Radio Outlet.
 

rchjr

Member
Premium Subscriber
Joined
Dec 26, 2005
Messages
30
Location
Phoenix, Az
#6
I use pro 96 software to program it. When I turn it on it seems as if the squelch min max knob is not working properly. I have had this for a long time and this is the only time it has acted up. Other times I turn it on and it seems as if it works ok. Kind of a intermittent thing.

Weird.......thanks for the responses.

Rchjr
 

iMONITOR

Member
Premium Subscriber
Joined
Sep 20, 2006
Messages
5,984
Location
MACOMB, MI.
#7
I use pro 96 software to program it. When I turn it on it seems as if the squelch min max knob is not working properly. I have had this for a long time and this is the only time it has acted up. Other times I turn it on and it seems as if it works ok. Kind of a intermittent thing.

Weird.......thanks for the responses.

Rchjr

I'm assuming you're monitoring analog systems, as digital does not use the squelch control?

Did you try a little squirt of electronic contact cleaner in the potentiometer? Do not attempt this if you're not comfortable taking things apart and putting them back together. Or get an experienced friend to help.


 
Status
Not open for further replies.
Top