• Effective immediately we will be deleting, without notice, any negative threads or posts that deal with the use of encryption and streaming of scanner audio.

    We've noticed a huge increase in rants and negative posts that revolve around agencies going to encryption due to the broadcasting of scanner audio on the internet. It's now worn out and continues to be the same recycled rants. These rants hijack the threads and derail the conversation. They no longer have a place anywhere on this forum other than in the designated threads in the Rants forum in the Tavern.

    If you violate these guidelines your post will be deleted without notice and an infraction will be issued. We are not against discussion of this issue. You just need to do it in the right place. For example:
    https://forums.radioreference.com/rants/224104-official-thread-live-audio-feeds-scanners-wait-encryption.html

RPi 3 & RTL-SDR/OP25?

boatbod

Member
Premium Subscriber
Joined
Mar 3, 2007
Messages
1,560
Location
Talbot Co, MD
I have been scouring the internet for the past couple of days for help on an issue with my rpi and op25. I have it working well and broadcasting on broadcastify but I would like to have alpha tagging showing up on the broadcast. Is there a way to do that with a rpi, or is that not an option yet?
Not supported yet
 
Joined
Jan 18, 2010
Messages
162
Location
People's Republik of Massachusetts
I apologize, I didn't dig through every page of this thread.
I'm relatively green at SDR.. but I have a spare Pi and SDR dongle from doing ADS-B.. I'm interested in monitoring a P25 Phase II system. Is that possible with what's available for the Pi/SDR?
 

maus92

Member
Premium Subscriber
Joined
Jun 23, 2004
Messages
2,824
Location
Annapolis
I apologize, I didn't dig through every page of this thread.
I'm relatively green at SDR.. but I have a spare Pi and SDR dongle from doing ADS-B.. I'm interested in monitoring a P25 Phase II system. Is that possible with what's available for the Pi/SDR?
Yup, it's possible, but I think it will require a 3B+ RP, and a decent dongle. At least that is what works for me. Boatbod has an easy setup procedure once you get your Pi running. I used Raspbian for the OS btw - basically a stock setup. Go back through the thread to find it.
 
Joined
Dec 24, 2011
Messages
3
Can somebody help with getting audio output from OP25 working through the 3.5mm headphone jack?

I have done a fresh, clean Raspbian Stretch install.
I have OP25 up and running with no issues. Tuned to a P25, control channel is working fine, and tunes to audio frequencies fine.
Default audio output is set to 3.5mm headphone jack via alsamixer and by setting audio output via "sudo amixer cset numid=3 1"

Command line speaker-test plays through the headphone jack, as well as VLC media player, browser, etc.

OP25 does not output any audio.

The command I'm using to launch rx.py is as follows:

./rx.py --args 'rtl' -N 'LNA:48' -S 2000000 -n -T thomasville_trunk.tsv -V -2 -O -U 2> stderr.2

I had OP25 up and running with no issues for a few weeks, but had it running on a NOOBS installation. For un-related reasons, I had to wipe the SD card and start fresh. So did the standard raspbian stretch instead of NOOBS. Still had my .tsv files backed up, so I got up and running quickly. Just this audio issue is testing my patience.

I'm out of ideas, and seeing as how this seems to be specific to OP25 (all other programs seem to output audio fine) I don't know where else to search, and have googled myself sick.

Thank you in advance for any assistance.
 

boatbod

Member
Premium Subscriber
Joined
Mar 3, 2007
Messages
1,560
Location
Talbot Co, MD
Can somebody help with getting audio output from OP25 working through the 3.5mm headphone jack?

I have done a fresh, clean Raspbian Stretch install.
I have OP25 up and running with no issues. Tuned to a P25, control channel is working fine, and tunes to audio frequencies fine.
Default audio output is set to 3.5mm headphone jack via alsamixer and by setting audio output via "sudo amixer cset numid=3 1"

Command line speaker-test plays through the headphone jack, as well as VLC media player, browser, etc.

OP25 does not output any audio.

The command I'm using to launch rx.py is as follows:

./rx.py --args 'rtl' -N 'LNA:48' -S 2000000 -n -T thomasville_trunk.tsv -V -2 -O -U 2> stderr.2

I had OP25 up and running with no issues for a few weeks, but had it running on a NOOBS installation. For un-related reasons, I had to wipe the SD card and start fresh. So did the standard raspbian stretch instead of NOOBS. Still had my .tsv files backed up, so I got up and running quickly. Just this audio issue is testing my patience.

I'm out of ideas, and seeing as how this seems to be specific to OP25 (all other programs seem to output audio fine) I don't know where else to search, and have googled myself sick.

Thank you in advance for any assistance.
Try removing the -O command line option. As written it is incorrectly formatted as you are missing the alsa device name so it may be swallowing the -U option which appears next.
e.g. "-O plughw:0,0"

What does the stderr.2 log say? There should be a line that says "audio device: " and the currently chosen device name. (Most often "audio device: default")
 

fredva

Member
Premium Subscriber
Joined
Mar 19, 2007
Messages
1,339
Location
Virginia/West Virginia
I'm running an older version of OP25 on a Raspberry Pi 3. I believe this is a pre-Boatbod build. The software has been getting stuck at times and going silent. I will come to my Windows system and see in the putty window the last frequency and talkgroup identifier displayed, as if it is still decoding traffic. But it is stuck there. This has happened at times in the past, but lately it has been happening more frequently. I've tried tweaking what I believe is called the frequency offset value in the command line, but that hasn't solved the problem. Any ideas? Was this a known issue that might be solved in a newer version? I'm using a Nooelec dongle.
 

boatbod

Member
Premium Subscriber
Joined
Mar 3, 2007
Messages
1,560
Location
Talbot Co, MD
I'm running an older version of OP25 on a Raspberry Pi 3. I believe this is a pre-Boatbod build. The software has been getting stuck at times and going silent. I will come to my Windows system and see in the putty window the last frequency and talkgroup identifier displayed, as if it is still decoding traffic. But it is stuck there. This has happened at times in the past, but lately it has been happening more frequently. I've tried tweaking what I believe is called the frequency offset value in the command line, but that hasn't solved the problem. Any ideas? Was this a known issue that might be solved in a newer version? I'm using a Nooelec dongle.
Sometimes the problem with freezing on a RPi3 has been due to an inadequate power supply. Make sure you have a good one capable of a full 2.1A output.

I'd also advise updating to the latest version of code. While there are no specific fixes for the problem you mention, there are alternative ways of handling audio on a RPi3 which may be of benefit anyway. (Look at the file ~/op25/README-rpi3-liquidsoap for info on enabling pulse audio and using liquid soap as the interface between op25 and the sound hardware.)
 

fredva

Member
Premium Subscriber
Joined
Mar 19, 2007
Messages
1,339
Location
Virginia/West Virginia
I'm confidant that the problem was the inadequate power supply. I've had OP25 running for four days straight without interruption since swapping the adapter. Previously, I was having to restart the program once or twice a day.
 

gskroll

Member
Premium Subscriber
Joined
Jun 17, 2005
Messages
69
Location
Portland, ME
This might have been happening right along but in updating just now to the latest build (doing the get pull from within op25 directory followed by ./install.sh), I spotted a couple errors

"error: no matching function for call to ‘gr::eek:p25_repeater::frame_assembler::make(const char*, int&, gr::msg_queue::sptr&)’"

Is this expected? If not, is there a quick fix or should I try to clear out the op25 install and reinstall?

Also, I would like to fine tune the frequency offset for my Nooelec NESDR SMArt dongle which is off by about 300hz. However, after clicking in the terminal window from which I executed my script:

#!/bin/bash
/home/pi/scanner/rx.py \
--args 'rtl' \
--gains 'lna:32' \
--fine-tune -0 \
-D cqpsk \
-l http:127.0.0.1:8080 \
-P constellation \
-S 1000000 \
-T /home/pi/scanner/trunk.tsv \
-v 1 \
-U \
-2 \
2>stderr.2
# -f 853.7875e6 \
# -O audio_out \
# -o 1.25e3 \
# -q -0 \
# -T /home/pi/scanner/trunk.tsv \
# -w \

and attempting to use the "<" ">" "," and "." keys, the reported tuning error doesn't seem to track with the keypresses to get closer to 0hz error.

What am I doing wrong?

Thanks

Glenn
 

boatbod

Member
Premium Subscriber
Joined
Mar 3, 2007
Messages
1,560
Location
Talbot Co, MD
This might have been happening right along but in updating just now to the latest build (doing the get pull from within op25 directory followed by ./install.sh), I spotted a couple errors

"error: no matching function for call to ‘gr::eek:p25_repeater::frame_assembler::make(const char*, int&, gr::msg_queue::sptr&)’"

Is this expected? If not, is there a quick fix or should I try to clear out the op25 install and reinstall?

Also, I would like to fine tune the frequency offset for my Nooelec NESDR SMArt dongle which is off by about 300hz. However, after clicking in the terminal window from which I executed my script:

#!/bin/bash
/home/pi/scanner/rx.py \
--args 'rtl' \
--gains 'lna:32' \
--fine-tune -0 \
-D cqpsk \
-l http:127.0.0.1:8080 \
-P constellation \
-S 1000000 \
-T /home/pi/scanner/trunk.tsv \
-v 1 \
-U \
-2 \
2>stderr.2
# -f 853.7875e6 \
# -O audio_out \
# -o 1.25e3 \
# -q -0 \
# -T /home/pi/scanner/trunk.tsv \
# -w \

and attempting to use the "" "," and "." keys, the reported tuning error doesn't seem to track with the keypresses to get closer to 0hz error.

What am I doing wrong?

Thanks

Glenn
An interface changed between python and c++ so you'll need to run the build from cmake onward.

cd -/op25/build
make clean
cmake ../
make
sudo make install
 

gskroll

Member
Premium Subscriber
Joined
Jun 17, 2005
Messages
69
Location
Portland, ME
Thanks for the quick response!

Using the commands you provided completed without error.

However, I apparently am misunderstanding what window needs focus for the keystrokes (.,<>) to address:

“Frequency error -248 Hz. (approx)
Fine tune offset: 0”

Shown in the web interface.

I click on the Terminal window (where my Portland.sh command is executed) to ensure focus but the keystrokes to adjust frequency don’t seem to effect the displayed “Frequency error” (but do appear in the last line in the terminal window).

Is there supposed to be another Terminal window that “listens” for the keystrokes?

Thanks

Glenn


Sent from my iPhone using Tapatalk
 

boatbod

Member
Premium Subscriber
Joined
Mar 3, 2007
Messages
1,560
Location
Talbot Co, MD
Thanks for the quick response!

Using the commands you provided completed without error.

However, I apparently am misunderstanding what window needs focus for the keystrokes (.,<>) to address:

“Frequency error -248 Hz. (approx)
Fine tune offset: 0”

Shown in the web interface.

I click on the Terminal window (where my Portland.sh command is executed) to ensure focus but the keystrokes to adjust frequency don’t seem to effect the displayed “Frequency error” (but do appear in the last line in the terminal window).

Is there supposed to be another Terminal window that “listens” for the keystrokes?

Thanks

Glenn


Sent from my iPhone using Tapatalk
248Hz is actually pretty close and I wouldn't worry too much about it. If you want to experiment and tweak a little, go to the "Plots" tab and turn on the "Mix" plot, then use the < or > web buttons to make adjustment. (Keys only work if you are using the default curses text terminal)
 

gskroll

Member
Premium Subscriber
Joined
Jun 17, 2005
Messages
69
Location
Portland, ME
Thanks - I took your suggestion and experimented with the “ >>” buttons within the browser. As you had said, seems like further adjustment is not necessary.

Glenn


Sent from my iPhone using Tapatalk
 

boatbod

Member
Premium Subscriber
Joined
Mar 3, 2007
Messages
1,560
Location
Talbot Co, MD
Thanks - I took your suggestion and experimented with the “ >>” buttons within the browser. As you had said, seems like further adjustment is not necessary.
"<<" and ">>" makes large adjustments of +/- 1200 whereas the "<" and ">" make small adjustments of +/- 100

Any fine tune of more than about +/- 350 should generally be done with a ppm tweak instead.
 
Top