• Effective immediately we will be deleting, without notice, any negative threads or posts that deal with the use of encryption and streaming of scanner audio.

    We've noticed a huge increase in rants and negative posts that revolve around agencies going to encryption due to the broadcasting of scanner audio on the internet. It's now worn out and continues to be the same recycled rants. These rants hijack the threads and derail the conversation. They no longer have a place anywhere on this forum other than in the designated threads in the Rants forum in the Tavern.

    If you violate these guidelines your post will be deleted without notice and an infraction will be issued. We are not against discussion of this issue. You just need to do it in the right place. For example:
    https://forums.radioreference.com/rants/224104-official-thread-live-audio-feeds-scanners-wait-encryption.html

RTL-SDR and Raspberry Pi - Choppy Audio with rtl_fm

Status
Not open for further replies.

Straussberg

Member
Premium Subscriber
Joined
Apr 5, 2008
Messages
4
Location
Virginia
#1
Howdy! I'm new to both RTL-SDR and setting up a scanner provider. I've been following the instructions on the RR Wiki, Raspberry Pi RTL-SDR Broadcastify - The RadioReference Wiki and wanted to ensure the setup was working before I started the feed. As such, I've tried piping the rtl_fm feed to both the speakers and a test icecast server I've setup, and no matter the settings, it seems to have very choppy audio. Could this be my RTL-SDR, or the 1st gen Raspberry Pi I'm using? I have a few extra laptops and radios lying around so I'm sure I could get something working, but I'd like to use the RTL-SDR if possible.

Thanks!
 

aaknitt

Member
Premium Subscriber
Joined
Aug 27, 2005
Messages
1,117
#2
Howdy! I'm new to both RTL-SDR and setting up a scanner provider. I've been following the instructions on the RR Wiki, Raspberry Pi RTL-SDR Broadcastify - The RadioReference Wiki and wanted to ensure the setup was working before I started the feed. As such, I've tried piping the rtl_fm feed to both the speakers and a test icecast server I've setup, and no matter the settings, it seems to have very choppy audio. Could this be my RTL-SDR, or the 1st gen Raspberry Pi I'm using? I have a few extra laptops and radios lying around so I'm sure I could get something working, but I'd like to use the RTL-SDR if possible.

Thanks!
I've had trouble with this as well even on a RPi 3. I can't say I've found a great solution. My experience has been that the squelch setting seems to be the culprit. I've found that in order to get decent audio I need to pretty much run open squelch, which doesn't work well for anything that's not a broadcast station. Here are the settings I've used to receive NOAA weather radio with decent (non-choppy) audio:

Code:
rtl_fm -M fm -s 11025 -f 162.4M -p 47 | play -r 11025 -t raw -e s -b 16 -c 1 -V1 -
Andy
 
Status
Not open for further replies.
Top