• Effective immediately we will be deleting, without notice, any negative threads or posts that deal with the use of encryption and streaming of scanner audio.

    We've noticed a huge increase in rants and negative posts that revolve around agencies going to encryption due to the broadcasting of scanner audio on the internet. It's now worn out and continues to be the same recycled rants. These rants hijack the threads and derail the conversation. They no longer have a place anywhere on this forum other than in the designated threads in the Rants forum in the Tavern.

    If you violate these guidelines your post will be deleted without notice and an infraction will be issued. We are not against discussion of this issue. You just need to do it in the right place. For example:
    https://forums.radioreference.com/rants/224104-official-thread-live-audio-feeds-scanners-wait-encryption.html

The sound capturing device is not ready.

Status
Not open for further replies.

jtodd76

Newbie
Premium Subscriber
Joined
Mar 14, 2018
Messages
4
Location
Abilene, KS
#1
I've been using ScannerCast with Windows 10 for a few weeks not without any trouble. Recently, Windows 10 did some updates and when the computer restarted, I'm getting this message when running ScannerCast: "The sound capturing device is not ready. Is Primary Sound Capture Driver Plugged in?" I haven't made any changes and I'm using the latest version of ScannerCast. I've even tried downloading and installing the Radio Feed software and getting a similar error. I've also checked for driver updates and there aren't any available. Not sure where to go from here. When I click on Stop Broadcast, I get an unhandled exception by .NET Framework.
I've been down for almost a week and would like to resolve this asap.
Hope someone else can help.

Thanks
 

ProScan

Member
Premium Subscriber
Joined
Jul 2, 2006
Messages
3,073
Location
Ontario, Calif.
#2
I've been using ScannerCast with Windows 10 for a few weeks not without any trouble. Recently, Windows 10 did some updates and when the computer restarted, I'm getting this message when running ScannerCast: "The sound capturing device is not ready. Is Primary Sound Capture Driver Plugged in?" I haven't made any changes and I'm using the latest version of ScannerCast. I've even tried downloading and installing the Radio Feed software and getting a similar error. I've also checked for driver updates and there aren't any available. Not sure where to go from here. When I click on Stop Broadcast, I get an unhandled exception by .NET Framework.
I've been down for almost a week and would like to resolve this asap.
Hope someone else can help.

Thanks
Windows Update 1803 broke a few things. There are fixes out there involving editing the registry. You may want to google it. A simply fix if you have a line or mic level cable plugged into a port, Windows will think it's a speaker cable. Simply unplug and replug the cable in and Windows will prompt you for the type of cable you plugged in.
 

jtodd76

Newbie
Premium Subscriber
Joined
Mar 14, 2018
Messages
4
Location
Abilene, KS
#3
Thanks for your response, Bob...
Can you elaborate on your comment about if I have a line or mic level cable part? I've unplugged it several times and even tried plugging into the mic instead of the line in. Seems like I get a message asking me what I plugged in and I respond properly. I'm not sure I understand what you mean by line or mic level cable? You're definitely right about that particular update (Windows feature update 1803). I'm positive that's the update that caused this problem.
 

jtodd76

Newbie
Premium Subscriber
Joined
Mar 14, 2018
Messages
4
Location
Abilene, KS
#4
Okay...I did some more research with your guidance around the 1803 update. I found a few pages referring to this particular update messing with microphone settings and not allowing apps to access the microphone. The steps I took:
In order to get around this issue, it's recommended to enable the microphone in your Privacy settings using these steps:

1.) Open Settings.
2.) Click on Privacy.
3.) Click on Microphone.
4.) Turn on "Allow apps to access your microphone toggle switch."

This seems to work for now. I hope this information will help others that may come across this issue.

Thanks again for your guidance, Bob. You pointed me in the right direction to find the answer.
 
Status
Not open for further replies.
Top