• Effective immediately we will be deleting, without notice, any negative threads or posts that deal with the use of encryption and streaming of scanner audio.

    We've noticed a huge increase in rants and negative posts that revolve around agencies going to encryption due to the broadcasting of scanner audio on the internet. It's now worn out and continues to be the same recycled rants. These rants hijack the threads and derail the conversation. They no longer have a place anywhere on this forum other than in the designated threads in the Rants forum in the Tavern.

    If you violate these guidelines your post will be deleted without notice and an infraction will be issued. We are not against discussion of this issue. You just need to do it in the right place. For example:
    https://forums.radioreference.com/rants/224104-official-thread-live-audio-feeds-scanners-wait-encryption.html

TwoToneDetect always triggers, recording sometimes statis

Status
Not open for further replies.

RiverRidge-WI

Member
Joined
Apr 3, 2010
Messages
9
Location
Webster, WI
Hi, all....

We are running V60 TwoToneDetect. As far as I can tell, it always triggers on all the pages that we have in the system. About half the time, we get perfect recording and emailing of the page audio. The rest of the time, the recording is static only. The failures and successes are seen in pages for all tone sets.
On the successes, there is little to no static in the recording, so I do not believe the audio is being drown out. It seems the audio is not there. Listening to the pages on a Minitor V or radio, there doesn't seem to be any correlation between the audio heard and the failure to record.

I have spent a fair amount of time reading the forums but have not seen this problem or a solution. Can anyone suggest a possible cause or areas I should look at?

Is there any info that I could provide that might aid in sorting this out?

Many thanx........... jt
 

aaknitt

Member
Premium Subscriber
Joined
Aug 27, 2005
Messages
1,131
Hi, all....

We are running V60 TwoToneDetect. As far as I can tell, it always triggers on all the pages that we have in the system. About half the time, we get perfect recording and emailing of the page audio. The rest of the time, the recording is static only. The failures and successes are seen in pages for all tone sets.
On the successes, there is little to no static in the recording, so I do not believe the audio is being drown out. It seems the audio is not there. Listening to the pages on a Minitor V or radio, there doesn't seem to be any correlation between the audio heard and the failure to record.

I have spent a fair amount of time reading the forums but have not seen this problem or a solution. Can anyone suggest a possible cause or areas I should look at?

Is there any info that I could provide that might aid in sorting this out?

Many thanx........... jt
Can you post some of the relevant settings from your Config info and Tone set config? Things like Record Time, Record Release Time, Record Delay, and Ignore After settings would be helpful. Also your Audio Threshold level is something to look at. Finally, if you can post a snapshot of your log.txt file from both a successful and "bad" recording, that would help too.

Thanks,

Andy
 

RiverRidge-WI

Member
Joined
Apr 3, 2010
Messages
9
Location
Webster, WI
Hi, Andy.............

Thanks so much for looking at this....

The config is
email_user = xxxxxxxxxxxxxxxxxxxt@gmail.com ;user id to log in to email account used for sending emails
email_pwd = xxxxxxxxxxxxxxxxxxxxxxx ;password to log into email account used for sending emails encoded in base64
email_server = smtp.gmail.com ;SMTP server address of email provider
email_port = 587 ;port to access email server with
record_seconds = 30.0 ;number of seconds of audio to record after a valid tone set is found
tone_tolerance = 0.02 ;tolerance of tone detection algorithm 1% = .01
input_device_index = 1 ;index of audio input device
output_device_index = 3 ;index of audio output device
audio_threshold = 49 ;threshold of audio squelch. audio signals below this level will be ignored
tone_offset = 0.0 ;tone offset in percentage. .01 = +1% tone offset, -.02 = -2% tone offset, etc.
mp3_bitrate = 32000 ;bit rate of mp3 encoder. Lower bitrate = smaller file size and lower audio quality
BCC = 0 ;1 = email addresses will be BCC'ed (hidden from other recipients). 0 = recipients will see other recipients
email_priority = 3 ;priority of email (1=highest, 3=normal, 5=lowest)
release_time=3.0 ;amount of silence (in seconds) required before recording will stop (max=60 seconds)
 

RiverRidge-WI

Member
Joined
Apr 3, 2010
Messages
9
Location
Webster, WI
Here are a few of the Tone file sets:

[Tone1]
Atone = 802.5 ;A tone frequency in Hz
Btone = 937.5 ;B tone frequency in Hz
Btonelength = 3 ;B tone length in seconds - make this as short as possible but long enough to prevent falsing
Btonedebounce = 2 ;Value between 0 and 4 that specifies how many times in a row the B tone must be detected in order to alert
Description = Webster 1st Responder Page Alert ;Tone set description
mp3_emails = xxx ;Email addresses to send mp3 attachment to. Separate with commas

[Tone2]
Atone = 1122.5 ;A tone frequency in Hz
Btone = 1185.2 ;B tone frequency in Hz
Btonelength = 3 ;B tone length in seconds - make this as short as possible but long enough to prevent falsing
Btonedebounce = 2 ;Value between 0 and 4 that specifies how many times in a row the B tone must be detected in order to alert
Description = NMAS Webster 5101 Page Alert ;Tone set description
mp3_emails = zzzzz
;Email addresses to send mp3 attachment to. Separate with commas

[Tone3]
Atone = 1122.5 ;A tone frequency in Hz
Btone = 1217.8 ;B tone frequency in Hz
Btonelength = 3 ;B tone length in seconds - make this as short as possible but long enough to prevent falsing
Btonedebounce = 2 ;Value between 0 and 4 that specifies how many times in a row the B tone must be detected in order to alert
Description = NMAS Grantsburg 5103 Page Alert ;Tone set description
mp3_emails = ssssss ;Email addresses to send mp3 attachment to. Separate with commas
 

RiverRidge-WI

Member
Joined
Apr 3, 2010
Messages
9
Location
Webster, WI
Snapshot of the log file will have to wait a couple of days.... so I can set up a pager test to capture the log and email results...... unless I catch it while I am work <grin>... I am not at the location of the scanner/computer but am looking at is remotely.
 

DC31

Member
Premium Subscriber
Joined
Feb 19, 2011
Messages
1,083
Location
Massachusetts
Here are a few of the Tone file sets:

[Tone1]
Atone = 802.5 ;A tone frequency in Hz
Btone = 937.5 ;B tone frequency in Hz
Btonelength = 3 ;B tone length in seconds - make this as short as possible but long enough to prevent falsing
Btonedebounce = 2 ;Value between 0 and 4 that specifies how many times in a row the B tone must be detected in order to alert
Description = Webster 1st Responder Page Alert ;Tone set description
mp3_emails = xxx ;Email addresses to send mp3 attachment to. Separate with commas

[Tone2]
Atone = 1122.5 ;A tone frequency in Hz
Btone = 1185.2 ;B tone frequency in Hz
Btonelength = 3 ;B tone length in seconds - make this as short as possible but long enough to prevent falsing
Btonedebounce = 2 ;Value between 0 and 4 that specifies how many times in a row the B tone must be detected in order to alert
Description = NMAS Webster 5101 Page Alert ;Tone set description
mp3_emails = zzzzz
;Email addresses to send mp3 attachment to. Separate with commas

[Tone3]
Atone = 1122.5 ;A tone frequency in Hz
Btone = 1217.8 ;B tone frequency in Hz
Btonelength = 3 ;B tone length in seconds - make this as short as possible but long enough to prevent falsing
Btonedebounce = 2 ;Value between 0 and 4 that specifies how many times in a row the B tone must be detected in order to alert
Description = NMAS Grantsburg 5103 Page Alert ;Tone set description
mp3_emails = ssssss ;Email addresses to send mp3 attachment to. Separate with commas
RR,

Did you upgrade from a previous (pre v60) version of TTD? Starting with v60 Atone length and Btone length parameters are mandatory and Btonedebounce is no longer used. From the program page:

Mandatory Parameters for Two-Tone (A-B format) pages:

Atone – Frequency (in Hz) of the first (A) tone in the two-tone sequence
Btone – Frequency (in Hz) of the second (B) tone in the two-tone sequence
Atonelength - Duration of A tone (in seconds) that must be detected before the program will alert.
Btonelength – Duration of B tone (in seconds) that must be detected before the program will alert

Note: Setting Atonelength and Btonelength both to .6 should be a good starting point for most common two-tone paging formats. Adjust as necessary.

I have excellent luck with both set to .6.

I don't really understand how this might affect the problem that you have described about static in the recordings but it is a place to start.

good luck with it.

Jim
 

RiverRidge-WI

Member
Joined
Apr 3, 2010
Messages
9
Location
Webster, WI
Thx, Jim.... yes... this is a tone file that has come along from several versions. I will go thru and update that and see what happens <grin>. Thanx again........... jt
 

RiverRidge-WI

Member
Joined
Apr 3, 2010
Messages
9
Location
Webster, WI
Here is the log file from an unsuccessful page after making the corrections to the tones.cfg file suggested. Does this suggest anything? Thanx again!!............. jt

Succesfully retrieved local tone info
Succesfully retrieved local tone info
Tone1
Tone2
Tone3
Tone4
Tone5
Tone6
Tone7
Tone8
Tone9
Tone10
Tone11
Tone12
Tone13
Tone14
Tone15
Tone 16
Tone 17
Tone 18
Tone 19
Tone 20
Tone21
Longtone1
Longtone2
1118.0 17425
1118.0 17411
1118.0 17332
1118.0 17240
1118.0 17125
1145.0 16837
1145.0 16470
1145.0 16485
NMAS Danbury 5106 Page Alert Tone Set Found
1145.0 16488
Succesfully retrieved local tone info 1145.0 16486

Tone1
Tone2
Tone3
Tone4
Tone5
Tone6
Tone7
Tone8
Tone9
Tone10
Tone11
Tone12
Tone13
Tone14
Tone15
Tone 16
Tone 17
Tone 18
Tone 19
Tone 20
Tone21
Longtone1
Longtone2
delay timer NMAS Danbury 5106 Page Alert 19:25:57 on 12/21/13
01145.0 16469

delay done NMAS Danbury 5106 Page Alert 19:25:57 on 12/21/13
waiting for audio NMAS Danbury 5106 Page Alert 19:25:57 on 12/21/13
threshold value: 64.0
starting record at 19:25:57 on 12/21/13
1145.0 16470
done recording at 19:25:57 on 12/21/13
32760 max level at 19:25:57 on 12/21/13
threshold exceeded
recording audio NMAS Danbury 5106 Page Alert 19:25:57 on 12/21/13
1145.0 16515
1145.0 16499
1145.0 16436
1145.0 16448
1145.0 16452
1145.0 16484
1145.0 16446
1145.0 16455
1145.0 16440
1145.0 16438
2280.0 2477
1511.0 2992
2231.0 4883
1984.0 11023
2559.0 4775
2215.0 6722
440.0 7263
440.0 5118
2059.0 5879
328.0 8618
1301.0 20181
1527.0 7249
1785.0 18823
457.0 19407
639.0 16136
1812.0 18968
645.0 18242
618.0 17097
559.0 18764
1742.0 15493
1441.0 5354
1376.0 4667
1527.0 5802
1790.0 6451
494.0 19146
457.0 18691
634.0 17180
1941.0 18792
392.0 16890
1887.0 18735
833.0 19770
682.0 18059
2382.0 19778
1903.0 16590
1855.0 6314
1382.0 8146
666.0 19142
575.0 19161
543.0 19681
586.0 19195
602.0 19234
1828.0 6650
1720.0 7896
1860.0 19557
639.0 18514
790.0 20282
2489.0 19663
634.0 17571
693.0 18499
596.0 18058
1925.0 7658
1779.0 8623
1527.0 15290
1457.0 15171
1914.0 7421
1640.0 7763
1769.0 7713
2177.0 6948
1581.0 7437
2290.0 9270
688.0 18555
Waiting for Silence NMAS Danbury 5106 Page Alert 19:26:25 on 12/21/13
Done recording NMAS Danbury 5106 Page Alert 19:27:21 on 12/21/13
done writing WAV NMAS Danbury 5106 Page Alert 19:27:21 on 12/21/13
ffmpeg version N-53987-g443b29e Copyright (c) 2000-2013 the FFmpeg developers
built on Jun 13 2013 03:05:23 with gcc 4.7.3 (GCC)
configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetyp
e --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --ena
ble-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-l
ibopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libsp
eex --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --enable-libvo-
amrwbenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --
enable-libxvid --enable-zlib
libavutil 52. 35.101 / 52. 35.101
libavcodec 55. 16.100 / 55. 16.100
libavformat 55. 8.102 / 55. 8.102
libavdevice 55. 2.100 / 55. 2.100
libavfilter 3. 76.101 / 3. 76.101
libswscale 2. 3.100 / 2. 3.100
libswresample 0. 17.102 / 0. 17.102
libpostproc 52. 3.100 / 52. 3.100
[wav @ 02907a40] max_analyze_duration 5000000 reached at 5015510 microseconds
Guessed Channel Layout for Input Stream #0.0 : mono
Input #0, wav, from './audio/NMAS_Danbury_5106_Page_Alert_2013-12-2119_27_21_041
000.wav':
Duration: 00:01:23.59, bitrate: 176 kb/s
Stream #0:0: Audio: pcm_s16le ([1][0][0][0] / 0x0001), 11025 Hz, mono, s16,
176 kb/s
Output #0, mp3, to './audio/NMAS_Danbury_5106_Page_Alert_2013-12-2119_27_21_0410
00.mp3':
Metadata:
TSSE : Lavf55.8.102
Stream #0:0: Audio: mp3 (libmp3lame), 11025 Hz, mono, s16p, 32 kb/s
Stream mapping:
Stream #0:0 -> #0:0 (pcm_s16le -> libmp3lame)
Press [q] to stop, [?] for help
size= 327kB time=00:01:23.59 bitrate= 32.1kbits/s
video:0kB audio:327kB subtitle:0 global headers:0kB muxing overhead 0.075272%
done converting to MP3 NMAS Danbury 5106 Page Alert 19:27:21 on 12/21/13
MP3 Email sent! NMAS Danbury 5106 Page Alert page received at 19:27:21 on 12/21/
13 19:27:32 on 12/21/13
1957.0 512
 

DC31

Member
Premium Subscriber
Joined
Feb 19, 2011
Messages
1,083
Location
Massachusetts
Thx, Jim.... yes... this is a tone file that has come along from several versions. I will go thru and update that and see what happens <grin>. Thanx again........... jt
Did this problem develop when you moved to v60 or did you experience it with previous versions also?
Did the problem start suddenly when nothing else had changed?

Have you tried a different sound card and different scanner? It appears that TTD is working properly which makes me think the problem might be in the audio source.
 

RiverRidge-WI

Member
Joined
Apr 3, 2010
Messages
9
Location
Webster, WI
The scanner and computer are the same and in the same location. The system hasn't worked correctly since October and I don't know what change was made at that point. I started looking into the problems a couple of weeks ago..... long excuse, I don't know the answer to your questions. Since I posted last night ( and since I added the Atonelength and took out the Btonedebounce for eachtone set) we have had 6 pages and NONE of them triggered the system. This is unusual. So.........

In each tone set, and set Atonelength = 0.6 and Btonelength = 0.6 and took out Btonedebounce. Was this correct or did I misunderstand?

Many thanx, all................... jt ........ I wish everyone a safe and peaceful holiday season..
 

DC31

Member
Premium Subscriber
Joined
Feb 19, 2011
Messages
1,083
Location
Massachusetts
The scanner and computer are the same and in the same location. The system hasn't worked correctly since October and I don't know what change was made at that point. I started looking into the problems a couple of weeks ago..... long excuse, I don't know the answer to your questions. Since I posted last night ( and since I added the Atonelength and took out the Btonedebounce for eachtone set) we have had 6 pages and NONE of them triggered the system. This is unusual. So.........

In each tone set, and set Atonelength = 0.6 and Btonelength = 0.6 and took out Btonedebounce. Was this correct or did I misunderstand?

Many thanx, all................... jt ........ I wish everyone a safe and peaceful holiday season..
You were correct. Did you reboot TTD after making that change? TTD only reads those configuration parameters on start-up.

Is your scanner scanning more than one frequency? Is there a priority channel set? Audio gaps which these things can present could cause missed tone detections.

Have you tried going back to a pre-v60 version of TTD to see if that fixes the problem?
 

aaknitt

Member
Premium Subscriber
Joined
Aug 27, 2005
Messages
1,131
The scanner and computer are the same and in the same location. The system hasn't worked correctly since October and I don't know what change was made at that point. I started looking into the problems a couple of weeks ago..... long excuse, I don't know the answer to your questions. Since I posted last night ( and since I added the Atonelength and took out the Btonedebounce for eachtone set) we have had 6 pages and NONE of them triggered the system. This is unusual. So.........

In each tone set, and set Atonelength = 0.6 and Btonelength = 0.6 and took out Btonedebounce. Was this correct or did I misunderstand?

Many thanx, all................... jt ........ I wish everyone a safe and peaceful holiday season..
In the section of the log file that you posted above, the program triggered and recorded. What did the audio file sound like for that recording? You said that since then you've had six pages that didn't trigger. Can you post the log file for one of those pages?

Andy
 

RiverRidge-WI

Member
Joined
Apr 3, 2010
Messages
9
Location
Webster, WI
I arose this morning to find that there was a great set of pages over night. Six pages of which the 1st, 2nd, & 4th recorded the message. Third,. 5th and 6th were static. 1st & 3rd to one set of tones, 2nd & 4th to another set of tones and 5th & 6th to a third set of tones. I went to copy the log, but alas, apparently the buffer was not large enough.

So......... Is there any way to increase the size of the log buffer? I will continue to watch for a set of tone that work and a set that don't. I really appreciate all the help, folks!!! Happy Holidays.... jt
 

aaknitt

Member
Premium Subscriber
Joined
Aug 27, 2005
Messages
1,131
I arose this morning to find that there was a great set of pages over night. Six pages of which the 1st, 2nd, & 4th recorded the message. Third,. 5th and 6th were static. 1st & 3rd to one set of tones, 2nd & 4th to another set of tones and 5th & 6th to a third set of tones. I went to copy the log, but alas, apparently the buffer was not large enough.

So......... Is there any way to increase the size of the log buffer? I will continue to watch for a set of tone that work and a set that don't. I really appreciate all the help, folks!!! Happy Holidays.... jt
There is no size limit to the log.txt file. Make sure you shut down the program and then access the file. If you don't shut down the program first the file may not be fully written to. Then copy the info from the file before starting the program up again. Once you restart it, it will overwrite the log.txt file.

Andy
 
Status
Not open for further replies.
Top