• To anyone looking to acquire commercial radio programming software:

    Please do not make requests for copies of radio programming software which is sold (or was sold) by the manufacturer for any monetary value. All requests will be deleted and a forum infraction issued. Making a request such as this is attempting to engage in software piracy and this forum cannot be involved or associated with this activity. The same goes for any private transaction via Private Message. Even if you attempt to engage in this activity in PM's we will still enforce the forum rules. Your PM's are not private and the administration has the right to read them if there's a hint to criminal activity.

    If you are having trouble legally obtaining software please state so. We do not want any hurt feelings when your vague post is mistaken for a free request. It is YOUR responsibility to properly word your request.

    To obtain Motorola software see the Sticky in the Motorola forum.

    The various other vendors often permit their dealers to sell the software online (i.e., Kenwood). Please use Google or some other search engine to find a dealer that sells the software. Typically each series or individual radio requires its own software package. Often the Kenwood software is less than $100 so don't be a cheapskate; just purchase it.

    For M/A Com/Harris/GE, etc: there are two software packages that program all current and past radios. One package is for conventional programming and the other for trunked programming. The trunked package is in upwards of $2,500. The conventional package is more reasonable though is still several hundred dollars. The benefit is you do not need multiple versions for each radio (unlike Motorola).

    This is a large and very visible forum. We cannot jeopardize the ability to provide the RadioReference services by allowing this activity to occur. Please respect this.
  • Effective immediately we will be deleting, without notice, any negative threads or posts that deal with the use of encryption and streaming of scanner audio.

    We've noticed a huge increase in rants and negative posts that revolve around agencies going to encryption due to the broadcasting of scanner audio on the internet. It's now worn out and continues to be the same recycled rants. These rants hijack the threads and derail the conversation. They no longer have a place anywhere on this forum other than in the designated threads in the Rants forum in the Tavern.

    If you violate these guidelines your post will be deleted without notice and an infraction will be issued. We are not against discussion of this issue. You just need to do it in the right place. For example:
    https://forums.radioreference.com/rants/224104-official-thread-live-audio-feeds-scanners-wait-encryption.html

TYT MD390 problem

Status
Not open for further replies.

kb9hgi

Member
Premium Subscriber
Joined
Jun 17, 2003
Messages
379
Location
IL
#1
I have a TYT MD 390 with GPS I bought it off ebay in OCt 22nd. I had it on charge and then took it off and turned it on and it powered up with screen then all of a sudden the screen went white. It still works and is programmed but when you turn it on all you get is a white screen and you cant see nothing or tell what group your on. Anyone else had this problem with this radio and is there a fix or is the screen shot after 3 months and only been used a couple times. Can it be fixed or throw in trash?
 
Joined
Mar 1, 2003
Messages
3,015
Location
PALM BEACH, FLORIDA
#2
TYT has a wonderful customer service team. Since the radio is barely 2 months old, I would call them right away to make arrangements for them to repair the radio under warranty.
 

dsalomon

Member
Premium Subscriber
Joined
May 6, 2003
Messages
149
Location
Brooks, GA
#3
I had the same thing happen to mine 2 days after I received it. Tyt's warranty support is good. They should exchange it with no issues. All they asked me to do was send them a short video of the white screen showing the problem. Once they saw it, they sent an RMA. You will have to pay return postage.
 
Joined
Mar 4, 2018
Messages
2
#4
My MD390 suddenly had a problem that never experienced before. As soon as I turned on the radio the display automatically switched to Menu but the keypad was basically dead and there is no response keying up any numeric and functional key. Only thing worked is the side button programmed for H L power switch.

I have tried to upgrade the FW to the latest version as well as flashing again the MD380Tools yet no progress to close this.

Any advice is appreciated.

Kim
 
Status
Not open for further replies.
Top