Uniden BC355N display problems

Status
Not open for further replies.
V

VGSMC_8520

Guest
#1
I have a plain old Uniden BC355N scanner in my truck, but it has recently started displaying erroneous characters on the screen. Example attached.

It appears to operate fine otherwise. Has anyone ever seen this on a BC355N (or any other Uniden scanner)? I suppose I'll be calling up their customer support as the unit was purchased only 6 months ago.
 

Attachments

Last edited:
Joined
May 19, 2006
Messages
1,091
Location
Newport, PA
#2
I have a BC355N that I use as a base in my house and it has been fine for several years. They are a solid scanner. I would definitely call them and look at sending it in for warranty service. As inexpensive as they are, you could also buy another one to use in the meantime until yours comes back from repair. That way, you would be without one and you'll always have a backup.
 
V

VGSMC_8520

Guest
#3
Warranty repair update

I shipped my BC355N to Uniden's repair facility on Jul 31, 2014. It was received and repaired under warranty, and returned to me on Aug 23, 2014. Here is the invoice of the repairs performed:





The display is working correctly again. Uniden was helpful throughout the process when communicating via email, however, I was unable to actually contact anyone by phone due to the extremely long wait times on their 800 number. Hope this helps anyone with a similar issue in the future.

edit:

I should mention that the repair itself comes with a 90 day warranty, and the original 1 year warranty remains in effect until in December 2014. Total cost to me for the repair was $9 to send the unit via UPS to the repair facility in Texas.
 
Status
Not open for further replies.
Top