• Effective immediately we will be deleting, without notice, any negative threads or posts that deal with the use of encryption and streaming of scanner audio.

    We've noticed a huge increase in rants and negative posts that revolve around agencies going to encryption due to the broadcasting of scanner audio on the internet. It's now worn out and continues to be the same recycled rants. These rants hijack the threads and derail the conversation. They no longer have a place anywhere on this forum other than in the designated threads in the Rants forum in the Tavern.

    If you violate these guidelines your post will be deleted without notice and an infraction will be issued. We are not against discussion of this issue. You just need to do it in the right place. For example:
    https://forums.radioreference.com/rants/224104-official-thread-live-audio-feeds-scanners-wait-encryption.html

Uniden BCT15x Warranty/Problem Question

Status
Not open for further replies.

brr2794

Member
Joined
Oct 7, 2013
Messages
1
Location
Maine
Hello. New to the forums... I hope I have placed this in the correct section.

I purchased my BCT15x in the beginning of June, 2013. Worked really well for me up until recently. I went to go turn it on and all I heard were clicking noises. No display, no sound, no lights or sign of anything at all. Just clicks. I had it in my truck one day and I was constantly truing my truck on and off in very short intervals and realized my scanner was on the whole time. (My first thought was some kind of surge with truing it on and off repeatedly) I brought the scanner home, plugged it in and turned it on and only heard the clicks. I checked the power supply and it was fine.

So I sent the scanner in for warranty repair on 12 November 2013. I have two questions-

1) Have you had this problem and what did you do?

2) If you have sent your scanner in for repair, how long was it before you had it back?

Thank you in advance.

-Brian
 

J-fro

Member
Joined
Sep 27, 2012
Messages
17
Location
Chico
I have this same issue when I try to plug it into my wall power supply, thus I have to plug it in with the 12VDC out in my truck.

I'm planning on sending it in to get it repaired, only because I figure once it's repaired it will be used as a home unit. I don't think it can handle the rigors of the road. I'll be looking at another unit to use in my truck.
When I called them to see about repair, the lady said turn around time was I think like, 3-4 weeks. Which I understand is fine, they need to have time to work on it but I use it every day and rely on it a lot. I guess the handheld will have to do until I get it sorted out.

Overall I'm not too happy with this unit. It's been freezing and locking out, until not even receiving radio traffic now. Only option is repair, otherwise I'm stuck with a useless flashy box.
 
Status
Not open for further replies.
Top