XPR 7350, 7550, 7550e voice announcement issues

Joined
Jun 18, 2018
Messages
7
#1
Hey guys,
I'm new to the site but I've found a ton of useful information here, so hats off to you guys for being a tremendous wealth of knowledge. I'm hoping someone here can help me with a voice announcement issue. We're running a trunked repeater setup with a mixed bag of handhelds all of which are XPR 7350, 7550 and 7550e models. My client decided that they wanted to have the voice announcements for channel assignments changed. No problem, all new channel names were recorded as .wav files which fit all the Motorola criteria and loaded into a test batch of radios (3 of each model). The 7550's took all changes perfectly and have no problems. The 7350 & 7550e radios are both exhibiting the same problem, 6 of the 34 announcements get chopped off before the whole announcement has been made. For example "ICS Logistics Alternate" when played on 7350 or 7550e comes out as "ICS Logistic" and that's it. I am able to play all audio files on my PC and they are fine and as I previously stated the same files work fine in a 7550.
I'm using Mototrbo version 15.5, build 797, codeplug version 10.05.06
I've also tried reloading the old files back into all 3 models and there are no issues whatsoever. Has anyone ever ran into a similar issue or does anyone have any idea what might be causing this issue?
 
Joined
Feb 15, 2004
Messages
13
Location
Jacksonville
#2
Hey guys,
I'm new to the site but I've found a ton of useful information here, so hats off to you guys for being a tremendous wealth of knowledge. I'm hoping someone here can help me with a voice announcement issue. We're running a trunked repeater setup with a mixed bag of handhelds all of which are XPR 7350, 7550 and 7550e models. My client decided that they wanted to have the voice announcements for channel assignments changed. No problem, all new channel names were recorded as .wav files which fit all the Motorola criteria and loaded into a test batch of radios (3 of each model). The 7550's took all changes perfectly and have no problems. The 7350 & 7550e radios are both exhibiting the same problem, 6 of the 34 announcements get chopped off before the whole announcement has been made. For example "ICS Logistics Alternate" when played on 7350 or 7550e comes out as "ICS Logistic" and that's it. I am able to play all audio files on my PC and they are fine and as I previously stated the same files work fine in a 7550.
I'm using Mototrbo version 15.5, build 797, codeplug version 10.05.06
I've also tried reloading the old files back into all 3 models and there are no issues whatsoever. Has anyone ever ran into a similar issue or does anyone have any idea what might be causing this issue?
The current CPS build is 16.0 (Build 823) I think it would be best to try and trouble shoot with the latest CPS software installed. If it's still an issue then it's not the CPS.

Just my 2 cents.
 
Joined
Aug 28, 2006
Messages
235
Location
Boyton Beach, FL
#3
First, I would not even begin to think about the new CPS Release till some people have tested it and the related firmware 2.9 in a non production world.

Sounds like you have an ordering issue with string comparison lookup issues. Look at the names and think about the ASCII sort sequence and character comparission values.
 
Joined
Mar 11, 2006
Messages
108
Location
PA
#5
That's odd that they'll take in a 7550 - but not in an "e" version.

You don't specifically say it - but I'm assuming that those 6 .wav files that are getting clipped are the longest files? ie: shorter length .wav files are playing OK?

It appears you've also tried loading ONLY the files you wanted to use - not trying to squeeze your custom files on top of the existing defaults? I've seen that as a problem on some of the older XPR5500 mobiles - but I haven't seen it as a problem on the 7000 series portables. The older design mobiles apparently were not built with enough memory to handle all the announcement files.
 
Joined
Jun 18, 2018
Messages
7
#7
First, I would not even begin to think about the new CPS Release till some people have tested it and the related firmware 2.9 in a non production world.

Sounds like you have an ordering issue with string comparison lookup issues. Look at the names and think about the ASCII sort sequence and character comparission values.
Agreed 100%, my employer never jumps on the absolute latest firmware until it's proven to be better than the last.

Is someone keying up and preempting the voice announcement? Voice traffic takes priority over Voice Announcements
It was an issue when I initially ran through the first batch but after realizing the problem I've been conducting all of my programming and tested in an isolated room and keep the antennas removed from the radios.

That's odd that they'll take in a 7550 - but not in an "e" version.

You don't specifically say it - but I'm assuming that those 6 .wav files that are getting clipped are the longest files? ie: shorter length .wav files are playing OK?

It appears you've also tried loading ONLY the files you wanted to use - not trying to squeeze your custom files on top of the existing defaults? I've seen that as a problem on some of the older XPR5500 mobiles - but I haven't seen it as a problem on the 7000 series portables. The older design mobiles apparently were not built with enough memory to handle all the announcement files.
You are partially correct about the larger file sizes, not all of the ones I'm having trouble with are the largest. I'll Upload a few screen captures to give you guys a better idea of what I'm seeing. With each test radio I am wiping the existing (and default) announcement files and loading only those that I want. From what I know all of the files are within the specified criteria. According to the voice announcement management tool the total combined duration of the files is 133 seconds and there's still 366 seconds available so I'm pretty sure I'm not maxing out the memory.
 
Joined
Jun 18, 2018
Messages
7
#8
Is the firmware the same on all radios?
Good question, complicated answer... I'm dealing with 3 different models and each different model has a different firmware version, however, all of each model has the same firmware which are as follows:
XPR 7550 R02.40.00
XPR 7550e R02.07.01.0000
XPR 7350 R02.06.05.0002

I don't know the logic behind these decisions but my employer has decided that we're using these firmware versions until someone makes us. I have talked to our motorola support contact and he is pretty stumped on this one as well but he did recommend upgrading to R02.08.05.0004
 
Joined
Aug 28, 2006
Messages
235
Location
Boyton Beach, FL
#9
Good question, complicated answer... I'm dealing with 3 different models and each different model has a different firmware version, however, all of each model has the same firmware which are as follows:
XPR 7550 R02.40.00
XPR 7550e R02.07.01.0000
XPR 7350 R02.06.05.0002

I don't know the logic behind these decisions but my employer has decided that we're using these firmware versions until someone makes us. I have talked to our motorola support contact and he is pretty stumped on this one as well but he did recommend upgrading to R02.08.05.0004
These are all Gen 2 radios an really should be on at least the R02.07.01 level. 2.08.5 has a few issues but at the subscriber level is stable. R02.09 is to new.

You said you uploaded some screen shots. Where ?
 

N1GTL

Member
Database Admin
Joined
Jun 14, 2005
Messages
673
Location
CT
#10
Firmware updates can reallocate RAM, reroute audio and a host of other things. I would get them all updated to 2.07.xxx

I agree what others have said...never be the first on the block to update. I'll leave my CPS at 15.5 and firmware's at 2.07 for a few months.
 
Joined
Jun 18, 2018
Messages
7
#11
Here are the screen captures which give a little information on the announcement files that I'm putting in the radios. Not sure if I mentioned this previously but I have tried taking the 6 problematic announcement files and assigning them to different channels just to verify that the problem does follow the announcement file and it does. As of yesterday afternoon (6/20/18) I got he folks back at my office to record those 6 files with a better microphone and send those files out to me, those files cut off at almost the exact same point as the originals.

The whole time that I've been fighting this issue the guys back at our office were able to load the codeplug and audio file in the same radio models, same firmware, same codeplug version and they cannot seem to duplicate the issue. I hopefully have a fix on the way, I'm being shipped a flash drive with the audio files (thinking maybe something happens in the email transfer) and a fully programmed and tested radio which I'll try to clone and see if my problem persists.
 

Attachments

Joined
Jun 18, 2018
Messages
7
#12
Sorry for the long delay in getting back to you guys, I'm working a 14/14 schedule on this location and just got back from days off. I wish I could report that progress has been made but I'm even more confused now than I was when I left. Before I returned to site I picked up a radio from my office that had been programmed and worked correctly as well as a flash drive with the original voice files, I get on site and cloned a few radios with the exact same results as I had before. At this point I'm really thinking that it's an issue with my computer.
 
Joined
Jun 18, 2018
Messages
7
#13
Well guys it doesn't look like the problem is an issue with my PC, I've tried it with 2 others. The only other thing I can think of is a difference in firmware and codeplug versions. I'm waiting on my office to send me flash drive with updated firmware and codeplug versions. I'm crossing my fingers and hoping that will work, will post update after trying that.
 

Attachments

Joined
Jun 18, 2018
Messages
7
#14
Issue finally resolved! As I suspected, and as you guys recommended, upgrading to the latest and greatest firmware solved all of my issues. The hard part was convincing our manager to upgrade firmware so I'm sure you guys can image his reaction when it worked. Thank you to those who responded, your input is appreciated.
 
Top