RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Scanners and Receivers Forums > Uniden Forums > Uniden Owner Tech Support

Uniden Owner Tech Support For current owners to get support with their scanners from existing or past owners. If you do not own or have model experience please restrict yourself to the other sub-forums.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 05-05-2014, 5:15 PM
Member
  Shack Photos
Shack photos
Premium Subscriber
Premium Subscriber
 
Join Date: Sep 2011
Location: Portland Oregon
Posts: 12
Unhappy Not picking up channels now

I have a Uniden BCT15-X that I really like using. It is hooked up in my car and was working great. Last weekend a friend was riding with me and she put her arm against it (between the seats), it beeped a couple of times and now won't pick up channels, I completely reset it and programmed all the frequencies back into it like before. For some reason now, it will just scan and not pick anything up. I definitely checked all the wires and antenna to make sure nothing got damaged. Am I missing something? It seems to still have the latest firmware as well (1.03). Thank you in advance for any help you can provide.
Reply With Quote
Sponsored links
  #2 (permalink)  
Old 05-05-2014, 5:18 PM
Member
   
Join Date: Jan 2003
Location: McLean, VA
Posts: 1,057
Default

Maybe the Global Attenuator was turned on??

Suggest you try to perform a Weather scan or program a FM broadcast station that is close to see if you can receive anything.

Once you know you can receive a Weather channel or FM station, then move on from there.
__________________
AOR AR5000+3 & SDU, AR8000, Icom R71A, R7100, PRO2004, PRO2006, PRO43, PRO96, PRO2096, BC785D, HP1E, 396XT, 996XT, 436HP, 536HP. Probably missed some gear. Man, I gotta get rid of some of this stuff!
Reply With Quote
  #3 (permalink)  
Old 05-05-2014, 6:32 PM
Member
  Shack Photos
Shack photos
Premium Subscriber
Premium Subscriber
 
Join Date: Sep 2011
Location: Portland Oregon
Posts: 12
Default

The global attenuator is turned off and I am still not receiving The Weather Channel
Reply With Quote
  #4 (permalink)  
Old 05-05-2014, 7:23 PM
eyes00only's Avatar
Member
   
Join Date: Jun 2004
Location: Denver Colorado
Posts: 2,277
Default

Check the antenna pin to be sure it's not broken.

JK
__________________
"There is a fine line between 'hobby' and 'mental illness'."
Reply With Quote
  #5 (permalink)  
Old 05-06-2014, 8:21 AM
n4yek's Avatar
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Apr 2004
Location: Newport, Tennessee
Posts: 1,977
Default

Try removing your coax from the scanner and just push a coat hanger into the center of the connector.
If you start receiving again, the coax connector is shorting out from your antenna.
Just a thought.
__________________
Danny Harp Jr.
HAM Radio Operator: N4YEK
A blood donor saved my life (Matthew 26:28).....Remember, Jesus loves you.
If 'con' is opposite of 'pro', is Congress the opposite of progress?
Reply With Quote
Sponsored links
  #6 (permalink)  
Old 05-06-2014, 10:43 AM
Completely Banned for the Greater Good
  Premium Subscriber
Premium Subscriber
 
Join Date: Feb 2013
Location: Hicksville, Long Island, NY
Posts: 1,431
Default

I'm going with the antenna/BNC on this one also. When you said you checked the wires and the antenna, exactly what do you mean? Do you have another spare antenna you can try, preferrably a duck type so there is no coax involved?
Reply With Quote
  #7 (permalink)  
Old 05-06-2014, 5:29 PM
Member
  Shack Photos
Shack photos
Premium Subscriber
Premium Subscriber
 
Join Date: Sep 2011
Location: Portland Oregon
Posts: 12
Default

I tried 2 other antennas and still nothing..not even the weather is being picked up. Seems wierd. I don't know if this makes any difference either but I program manually as I have a MAC so its not easy to find software for me. The fact that I can't even get weather is really odd. I have all the same stuff programmed in my BC346XTC and it works just fine.

Last edited by arcanemirage; 05-06-2014 at 5:37 PM.. Reason: Added info
Reply With Quote
  #8 (permalink)  
Old 05-06-2014, 6:00 PM
Completely Banned for the Greater Good
  Premium Subscriber
Premium Subscriber
 
Join Date: Feb 2013
Location: Hicksville, Long Island, NY
Posts: 1,431
Default

Take the cover off and check to see if the BNC RF wire got disconnected from the BNC jack.
Reply With Quote
  #9 (permalink)  
Old 05-06-2014, 6:30 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: May 2010
Location: Pittsburgh, Pennsylvania
Posts: 37
Default

Try looking at your Firmware. You may need a update!
Reply With Quote
Sponsored links
  #10 (permalink)  
Old 05-06-2014, 6:45 PM
Member
  Shack Photos
Shack photos
Premium Subscriber
Premium Subscriber
 
Join Date: Sep 2011
Location: Portland Oregon
Posts: 12
Default

My Firmware is 1.03 which is what it says is the latest for this scanner. Is there newer firmware I'm missing?
__________________
Bill W. (no not the man who created AA)
BCT15X BC346XTC AustinSpectra Antenna
Reply With Quote
  #11 (permalink)  
Old 05-06-2014, 6:45 PM
Member
  Shack Photos
Shack photos
Premium Subscriber
Premium Subscriber
 
Join Date: Sep 2011
Location: Portland Oregon
Posts: 12
Default

I assume it's fairly easy to remove the cover?
__________________
Bill W. (no not the man who created AA)
BCT15X BC346XTC AustinSpectra Antenna
Reply With Quote
  #12 (permalink)  
Old 05-06-2014, 7:44 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: May 2010
Location: Pittsburgh, Pennsylvania
Posts: 37
Default

Uniden BCT15 Firmware Revision Notes 1.06.00
Reply With Quote
  #13 (permalink)  
Old 05-06-2014, 8:06 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: May 2010
Location: Pittsburgh, Pennsylvania
Posts: 37
Default

I had same version and wasn't picking anything up, same as you. I did the Firmware update and it seem to help. Downloads - Product Information at Uniden
Hope this helps!!!

Brian
Reply With Quote
  #14 (permalink)  
Old 05-06-2014, 8:29 PM
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Feb 2014
Location: Waltham, MA
Posts: 11
Default static zap

Was it an exceptionally cold, dry day? Sounds like an rf stage got blown! In which case, your radio might be today!
Reply With Quote
  #15 (permalink)  
Old 05-06-2014, 8:30 PM
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Feb 2014
Location: Waltham, MA
Posts: 11
Default

I meant 'toast' (auto text sux).
Reply With Quote
Sponsored links
  #16 (permalink)  
Old 05-06-2014, 8:38 PM
Member
  Shack Photos
Shack photos
Premium Subscriber
Premium Subscriber
 
Join Date: Sep 2011
Location: Portland Oregon
Posts: 12
Default

Please don't tell me that. No it really wasn't cold at all.
__________________
Bill W. (no not the man who created AA)
BCT15X BC346XTC AustinSpectra Antenna
Reply With Quote
  #17 (permalink)  
Old 05-06-2014, 8:40 PM
Member
  Shack Photos
Shack photos
Premium Subscriber
Premium Subscriber
 
Join Date: Sep 2011
Location: Portland Oregon
Posts: 12
Default

I was told that the BCT15X is not the same as BCT15..but I'm willing to give it a shot.
__________________
Bill W. (no not the man who created AA)
BCT15X BC346XTC AustinSpectra Antenna
Reply With Quote
  #18 (permalink)  
Old 05-06-2014, 8:51 PM
Mentor
  Premium Subscriber
Premium Subscriber
 
Join Date: May 2004
Location: Dallas, TX
Posts: 3,139
Default

Quote:
Originally Posted by arcanemirage View Post
I was told that the BCT15X is not the same as BCT15..but I'm willing to give it a shot.
The firmware for the BCT15X & BCT15 are not interchangeable.

The most version for the BCT15X is 1.03.00, which is what you said you have.
__________________
Steve
BCD536HP-BCD436HP-BCD396XT(2)-Home Patrol 1(E)-PSR500-BCD396T-BCD996T-BR330T-BC250D-BC780XLT
Reply With Quote
  #19 (permalink)  
Old 05-06-2014, 11:17 PM
Member
  Shack Photos
Shack photos
Premium Subscriber
Premium Subscriber
 
Join Date: Sep 2011
Location: Portland Oregon
Posts: 12
Default Now what?

, it seems that it would be very difficult to take the scanner apart.. I'm not sure where to go from here
__________________
Bill W. (no not the man who created AA)
BCT15X BC346XTC AustinSpectra Antenna
Reply With Quote
  #20 (permalink)  
Old 05-07-2014, 1:19 AM
Member
  Shack Photos
Shack photos
Premium Subscriber
Premium Subscriber
 
Join Date: Sep 2011
Location: Portland Oregon
Posts: 12
Default Now what?

I took the case off and it looks like there's like eight more screws that I need to take out to take the whole thing apart. Is that correct?
__________________
Bill W. (no not the man who created AA)
BCT15X BC346XTC AustinSpectra Antenna
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 1:20 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2011 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions