RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Scanners, Receivers and Related Equipment Forums > Uniden Forums > Uniden Tech Support


Uniden Tech Support - For discussion of all technical aspects of current or future Uniden scanners.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 07-04-2018, 11:23 AM
Finnesotan's Avatar
Member
   
Join Date: Mar 2018
Location: MN
Posts: 10
Default Home Patrol 2 display problem

Recently encountered a problem with display on my Home Patrol 2 when powering on. Very white and washed out screen. The touchscreen still works but can only see the screen by tilting the unit downward. Display is extremely washed out and the brightness and contrast settings do not fix the issue. Restarting multiple times did not change anything. Does this both on batteries and plugged into charger. The unit was not dropped or banged around at all.

I tried to search the forums for others experiencing the same but wasn't able to find anything.

Has anyone seen this and any ideas other than sending in for warranty (unit is less than a year old)? Any feedback would be appreciated.

Will try to attach picture.
Attached Images
 
Reply With Quote
Sponsored links
  #2 (permalink)  
Old 07-04-2018, 11:32 AM
jonwienke's Avatar
Member
   
Join Date: Jul 2014
Location: PA
Posts: 8,884
Default

Try reseating the orange ribbon cable shown in this photo:
https://1drv.ms/u/s!ApJIS-l4xqPtgvALgQvD0l3T8UUz7w
__________________
Gone camping.
Reply With Quote
  #3 (permalink)  
Old 07-04-2018, 12:05 PM
Finnesotan's Avatar
Member
   
Join Date: Mar 2018
Location: MN
Posts: 10
Default

Re-seating the ribbon cable worked. It was a bit difficult to do but resolved the issue. Thanks!

Last edited by Finnesotan; 07-04-2018 at 12:09 PM..
Reply With Quote
  #4 (permalink)  
Old 07-04-2018, 1:13 PM
jonwienke's Avatar
Member
   
Join Date: Jul 2014
Location: PA
Posts: 8,884
Default

You're welcome!
__________________
Gone camping.
Reply With Quote
  #5 (permalink)  
Old 09-11-2018, 9:11 PM
Member
  Premium Subscriber
Premium Subscriber
Amateur Radio Operator
Amateur Radio
 
Join Date: Sep 2006
Location: Whittier, CA
Posts: 33
Default

After the last firmware update, I now have a white line across the bottom of my HP-2 display that wasn't there before the update. It doesn't seem to affect performance, but it's annoying always having that white line there. Anyone else have this same issue or have any suggestions on resolving this issue?

__________________
BCD536HP, BCD436HP, BCD996P2, BCD996XT, BCD396XT, BC780XLT, HomePatrol HP-2, HomePatrol HP-1 & HP-1 Extreme, Motorola XTL5000, XTS5000, XTS3000, Kenwood NX-800, NX-700H, TK-8180, TK-7180, Icom R7000

Last edited by RepomanGP; 09-11-2018 at 9:22 PM.. Reason: Trying to get picture to display properly.
Reply With Quote
Sponsored links
  #6 (permalink)  
Old 09-11-2018, 10:57 PM
hiegtx's Avatar
Mentor
  Premium Subscriber
Premium Subscriber
 
Join Date: May 2004
Location: Dallas, TX
Posts: 5,365
Default

Quote:
Originally Posted by RepomanGP View Post
After the last firmware update, I now have a white line across the bottom of my HP-2 display that wasn't there before the update. It doesn't seem to affect performance, but it's annoying always having that white line there. Anyone else have this same issue or have any suggestions on resolving this issue?

Are you, perhaps, referring to a database update, not one for firmware?

If I recall correctly, there have been zero firmware updates for the HP-2. And Uniden's Wiki page does not show any past updates. There were a couple issued for the HP-1, but the last one was in 2014. The only HP-2 upgrade has been for the Extreme Update, but that involves purchasing a license key & entering into the scanner. There is no separate firmware file associated with it.
__________________
Steve
SDS100-436HP (2)-536HP-TRX-1-325P2-among others
Reply With Quote
  #7 (permalink)  
Old 09-11-2018, 11:32 PM
W8RMH's Avatar
Member
  Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Jan 2009
Location: Grove City, Ohio (A Bearcat not a Buckeye)
Posts: 7,492
Default

There has never been a firmware update for the HP-2. I just did the DB update on mine and I have no line.

Go to Display Options and try changing the Display Mode or Font Size and see if it persists.
__________________
SKYWARN SPOTTER Unication G4 Home Patrol 2 BCD996XT BR330T Bearcat 4
Columbus Police Dispatch - Citywide (Ohio MARCS P25)
Reply With Quote
  #8 (permalink)  
Old 09-11-2018, 11:33 PM
Member
  Premium Subscriber
Premium Subscriber
Amateur Radio Operator
Amateur Radio
 
Join Date: Sep 2006
Location: Whittier, CA
Posts: 33
Default

Quote:
Originally Posted by hiegtx View Post
Are you, perhaps, referring to a database update, not one for firmware?
Steve,

Yes, it's possible that this may very well be what happened. It happened a couple/few months back and I have too many radios and scanners to keep track of. In any event, it was definitely after an update of some sort. The white line first appeared after the HP-2 was ejected from the USB port and was rebooting itself. Now, it's there 100% of the time. It appears during the boot process and I believe it appears before the database begins to load. I honestly don't see how a database update would have any effect on the display.
__________________
BCD536HP, BCD436HP, BCD996P2, BCD996XT, BCD396XT, BC780XLT, HomePatrol HP-2, HomePatrol HP-1 & HP-1 Extreme, Motorola XTL5000, XTS5000, XTS3000, Kenwood NX-800, NX-700H, TK-8180, TK-7180, Icom R7000
Reply With Quote
  #9 (permalink)  
Old 09-12-2018, 6:34 AM
Member
   
Join Date: Sep 2006
Location: Stockholm, Sweden
Posts: 1,837
Default

Does it change when you alter the display to show the Main menu? The bottom part are graphics that are set to be displayed at certain pixels and if the white line are there on every type of screens it must be that some sort of offset to the screen have been introduced, if it isn't a hardware problem the the lcd screen has moved so that the backlight panel are shown.

Try reloading the firmware and if that doesn't help do a memory clear by holding down volume up when powering on and holding down volume down when the Homepatrol screen are shown. Go to Other tests and select Memory Clear. You have to had your settings saved on your computer prior to that to be able to restore them.

/Ubbe
__________________
TRX-2 BCD536 HP1 BCT15 BC246 BC346 BR330 UBC3500 Pro2006 Pro2042 Optocom OS545 Scout PCR1000 ICR2500 IC75 DX394 AR8200 IC-R2 IC-R10 UBC780 MD380 CS580 CS750 Pro96 Perseus ADCR25 AcecoSC1plus RTL-SDR
Reply With Quote
  #10 (permalink)  
Old 09-12-2018, 2:35 PM
Member
  Premium Subscriber
Premium Subscriber
Amateur Radio Operator
Amateur Radio
 
Join Date: Sep 2006
Location: Whittier, CA
Posts: 33
Default

Quote:
Originally Posted by Ubbe View Post
Does it change when you alter the display to show the Main menu?
No, it does not change. The white line is visible no matter what menu or screen I'm viewing.

Quote:
Originally Posted by Ubbe View Post
...if it isn't a hardware problem the the lcd screen has moved so that the backlight panel are shown.
I doubt the LCD panel has moved. This unit is virtually brand new and has never left the top of my desk. It's never been dropped or bumped hard.

Quote:
Originally Posted by Ubbe View Post
Try reloading the firmware...
I was unable to find instructions on how to reload the firmware. I would definitely like to try this. Can you please explain the process?

Quote:
Originally Posted by Ubbe View Post
Go to Other tests and select Memory Clear.
I tried clearing the memory but the white line is still there.

Thanks for all your suggestions.

Greg
__________________
BCD536HP, BCD436HP, BCD996P2, BCD996XT, BCD396XT, BC780XLT, HomePatrol HP-2, HomePatrol HP-1 & HP-1 Extreme, Motorola XTL5000, XTS5000, XTS3000, Kenwood NX-800, NX-700H, TK-8180, TK-7180, Icom R7000
Reply With Quote
  #11 (permalink)  
Old 09-12-2018, 2:55 PM
UPMan's Avatar
Uniden Representative
  Premium Subscriber
Premium Subscriber
Amateur Radio Operator
Amateur Radio
 
Join Date: Apr 2004
Location: Arlington, TX
Posts: 12,575
Default

A database update could not cause what you are showing. Neither could a firmware update. However, it might be a function of the display brightness being turned way up. I'd try adjusting that.
__________________
Uniden Product Ninja
Who is UpMan and why doesn't he answer my email/phone call?
Personal Blog
For better help, tell us specifically what you are trying to scan.
Reply With Quote
  #12 (permalink)  
Old 09-12-2018, 3:29 PM
Member
  Premium Subscriber
Premium Subscriber
Amateur Radio Operator
Amateur Radio
 
Join Date: Sep 2006
Location: Whittier, CA
Posts: 33
Default

Quote:
Originally Posted by UPMan View Post
A database update could not cause what you are showing. Neither could a firmware update. However, it might be a function of the display brightness being turned way up. I'd try adjusting that.
Thank you for your suggestion, Paul, but the line remains on the screen at all backlight levels. I even tried rebooting the HP-2 at different brightness levels, with no luck.
__________________
BCD536HP, BCD436HP, BCD996P2, BCD996XT, BCD396XT, BC780XLT, HomePatrol HP-2, HomePatrol HP-1 & HP-1 Extreme, Motorola XTL5000, XTS5000, XTS3000, Kenwood NX-800, NX-700H, TK-8180, TK-7180, Icom R7000
Reply With Quote
  #13 (permalink)  
Old 09-12-2018, 7:41 PM
Member
   
Join Date: Sep 2006
Location: Stockholm, Sweden
Posts: 1,837
Default

Seems like you have the same problem as Finnesotan got but his whole display went white, the ribbon cable from the display has some sort of connection problem and need to be re-seated.

If you look at the texts at the bottom they are not in the middle of its dark grey rectangle. The last line or two at the bottom are not getting drawn with dark pixels. That horizontal control lines have probably no connection to the graphics cpu.

/Ubbe
__________________
TRX-2 BCD536 HP1 BCT15 BC246 BC346 BR330 UBC3500 Pro2006 Pro2042 Optocom OS545 Scout PCR1000 ICR2500 IC75 DX394 AR8200 IC-R2 IC-R10 UBC780 MD380 CS580 CS750 Pro96 Perseus ADCR25 AcecoSC1plus RTL-SDR
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 8:05 PM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2015 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions