The RadioReference.com Forums

The RadioReference.com Forums (http://forums.radioreference.com/)
-   Uniden Thread Archives (http://forums.radioreference.com/uniden-thread-archives/)
-   -   [HELP] USB to SERIAL Adapter BC296D (http://forums.radioreference.com/uniden-thread-archives/251295-help-usb-serial-adapter-bc296d.html)

gonzalu 10-15-2012 2:34 PM

[HELP] USB to SERIAL Adapter BC296D
 
Hello all,

Thank you for the great resource of this community. I seek help in trying to identfy a problem I am having with the BC296D and a USB to Serial adapter. Nothing seems to work no matter what I have tried.

First, some details:

Uniden Bearcat BC296D
Windows 7 Ultimate x64
QVS USB to Serial Adapter (Microenter)
Prolific PL-2303HDX
IOGEar USB to Serial Adapter [GUC232A which is actually a rebadged ATEN unit] (Microcenter)
Prolific PL-2303HD

Unit works perfectly on an old laptop running Windows XP and another running Windows 7 x64. Both have native Serial Ports.

I have the very latest drivers for Windows 7 x64 for both adapters (both use same chipset) from Prolific. No errors on the Device Manager. I was even able to update the firmware on the scanner as well as the re-banding update.

No matter what I have tried, the scanner software always returns an error that it cannot communicate wit the scanner. There is a momentary connection sometimes where I will get the first screen on the scanner but it eventually fails within 5 seconds.

Tried all three flow control options (XON/XOFF, HARDWARE, OFF) and all supported baud rates from 9600 to 57000... Careful to match all three always (Scanner, Software and Driver)

Thank you for your help in troubleshooting this issue. Have no other x64 USB Only computers to try it out on for now :-(

rbm 10-15-2012 5:51 PM

1 Attachment(s)
You may want to refer to my earlier posts about this problem.
I use 21 USB/serial adapters on 9 computers. (BCD396x, BCD996x, BCT15x)
This is what works for me.
Be aware though that there are some adapters that just won't work no matter what.

http://forums.radioreference.com/1653628-post86.html
http://forums.radioreference.com/1745109-post97.html
And
http://forums.radioreference.com/1745343-post5.html

Here's what works for me on Win7 64bit

Rich

This is copied from one of my posts back in April 2012.
Windows update included a Prolific driver update yesterday.

I didn't have any problems because I have my Windows Update setting as in the second image.
This lets me choose which updates to install and allows me to 'hide' the ones I don't want.

For anyone who experiences this problem, you can do the following. (After changing your Windows Update setting)
Go to 'Programs and Features'
Scroll down to PL-2303 USB-to-Serial
Right click on the one dated 4/25/2012 and UNINSTALL it.

Then, you'll have to install the older driver again.
If windows update offers to install a later Prolific driver, unless you need it for some other reason, hide it. (You can un-hide it later if you change your mind.)

ka3jjz 10-15-2012 5:54 PM

Keep in mind that I believe the USB-1 is not certified to work with the 296D. It might, might not.

Mike

gonzalu 10-15-2012 7:33 PM

Rich, Mike, THANK YOU for your help.

Mike, I am using the standard serial cable that came with my Uniden BC296D which has a funny luking mini-usb-like connector on the radio end. Is that a USB-1 cable? Works fine on a regular serial port

Anyway, here is the screenshot of what my computer looks liek right now before I start to play around with the older drivers...

I tried to install the VISTA drivers linked at SixPot website and they are not installing or something. They do not apply to the serial adapter which sits in the device manager with an exclamation point. If I re-install the cable, Windows gain installs the last driver from the driver repository (aaggghhhrrr!!!!) even if I uninstall it. (is there a way to COMPLETELY REMOVE ANY SHADOW OF ANY DRIVER?)

http://pictures.mannyphoto.com/photo.../i-dkSGmh7.jpg

I will post more pics after I re-boot. I also tried the 115K baud setting but that did not make a difference. I am wondering, do I just leave the Scan software setup at 56K and also the radio at 56K?

Thanks

gonzalu 10-15-2012 8:15 PM

This is very frustrating. I was finally able to select the drivers manually from a list offered when updating drivers. Tried three different versions of the driver with the same results :-( I have a feeling there is something corrupt with my config or drivers somewhere...

rbm 10-16-2012 12:10 AM

If your adapter does not have a 'real' Prolific chip, it will not work with drivers released over the last year or so.

Prolific added some code to their drivers to prevent non-Prolific chips from working.
If your chip is a true Prolific chip, disregard the following.

Prolific used to explain it on their web site. I just checked and that's gone from there now.

This web page below will explain it somewhat.

Essentially, if you have a non-Prolific chip, the latest drivers will NOT work.
This mentions 'Code 10' errors, but that's not true in all cases.
Family Software Drag Racing - Newsletter#37, Prolific PL-2303 Driver Solution for Code 10

You can go here and search down for 'Code 10' to get the 2008 driver.
USB to Serial Adapter (RS232) -Windows 7 - USB A Male to DB9 Male - Download Windows 7 Driver Here - USBFireWire.com - 877-522-3779

By the way, you can't just select a new driver, you actually have to DELETE the one you don't want. You may even have more than one.
If there are drivers to delete, this post may help walk you through deleting unwanted Prolific drivers.
http://forums.radioreference.com/1745109-post97.html

Rich

Yes, match the speed of the device and the com port. Once you get it working, you can increase the speed to the max or until you start seeing errors.

ka3jjz 10-16-2012 4:07 AM

Another thing to keep in mind is to match your drivers with your OS. There have been lots of reports of folks using 64 bit Win7 having trouble finding drivers that work.

Mike

gonzalu 10-16-2012 7:29 AM

Thanks guys.. once again, it feels good just to be able to talk about this with someone who knows :) I was trying to get help from IOGEAR and QVS and even ProlificUSA with little positive results

Rich, I am not sure if the Code 10 error is what I am getting. But it is not saying Code 10 in the error i get which is:

http://pictures.mannyphoto.com/photo.../i-dkSGmh7.jpg

is that a Code 10 error as referenced?

Thanks

gonzalu 10-16-2012 7:31 AM

Oh one more thing... mine seems to be a legit PL-2303 HDX which is the latest from Prolific and as per their chip identifier utility, shows it to be legitimate. Unless the counterfeit is that good :tongue:

gonzalu 10-16-2012 7:35 AM

Sorry, HXC :P

http://pictures.mannyphoto.com/photo.../i-gtQrTR7.jpg

gonzalu 10-16-2012 8:34 AM

OK so I did a lot of cleanup. Completely removed any traces of the drivers. Used a DriverStore cleanup utility from Microsoft (pnputil.exe) and also manually and forcibly removed all traces of it from the driverstore filerepository (just in case)

Tried the Prolific cleanup tool as well

Rebooted and installed 3.3.2.102 as suggested

Still get the same exact error code. I tried both the IOGEAR and the QVS cables.. .same error from the Scanner Software...

:(

gonzalu 10-16-2012 11:08 AM

I brought the cable and radio to work to try it on a different workstation. Plugged in the cable to a vanilla Windows 7 Ultimate x86 (32 bit) and the system immediately installed the latest drivers from Windows. 3.4.36.247 dated 7/26/2012 signed by MS and labeled as from Prolific... ugh. Same results. Radio software immediately says there is a problem with the radio and to check the remote setting...

So let me try and remove those and install the older 3.3.2.102 as suggested. BRB

rbm 10-16-2012 11:15 AM

It looks like you've done everything right as far as the drivers go.
Since it works with your other computers, you may be fighting a losing battle on Win7.
I have Win7 on a few of my computers and for as long as that's been out, it still has a lot of 'quirks'.

Does the connector at the scanner feel loose?
It shouldn't come out easily.
Some cables have a 'hood' that can slip down and that can keep the connector from seating fully.
Rich

By the way, I didn't ask this before but............... Did you set 'PC Control' on in the scanner?
(I have to assume so because it works with the other computers.)

gonzalu 10-16-2012 12:24 PM

Rich, and Mike, your help is really appreciated... thanks for your generous support. I have a feeling too it is a losing battle... I am NOT getting a Code 10 but mostly there seems to be an initial connection and then it fails. I do get the first screen of whatever is on the radio. The IOGEAR connector has a light indicating activity on the serial port and it comes on for a moment and then goes dark. I believe the problem is on the radio side :-(

Am going to try other radios or devices on the usb-serial cable to prove my theory but it has become harder and harder to find Serial devices in my shack lately :tongue:

And yes, indeed I have set the radio to each of the supported baud rates from 2400 to 57000 baud with same results. Interestingly, like I said earlier, I was successful in updating the firmware on the radio via this same cable and with the latest drivers... totally weird.

On my WinTel box, I have an proper DB-9 serial but my main working PC is actually a MacPro running Windows 7 and it just doesn't have a serial port ;-( and I am out of expansion slots where I could add one. I think I need to get a radio-specific workstation for this sort of thing.

I can;t wait until Uniden starts to make Wi-Fi radios where they connect to the wi-fi and we use a web interface to get to the radio control :) I can dream...

Arizona_Scanner 10-16-2012 5:25 PM

Or how about the "bizarre" concept of using a mini-usb at the radio completely eliminating the dreaded serial connection? Take a look at the PSR-800, which uses this connection. It means that a $1 cable off ebay is all you need to connect anywhere, charge anywhere, in any cigarette lighter adapter usb charger, etc. I LOVE my 396xt, and would say one of my few criticisms is the weird little serial connector.

I have had weird things happen on my home desktop with a REAL prolific adapter, and it got so frustrating I ended up having to do a system restore to a previous time to get the thing working. It was quite frustrating. I also hate how it randomly switches com ports from time to time.

RonnieUSA 10-16-2012 5:49 PM

The link was for the same driver. Sorry.

gonzalu 10-17-2012 4:20 PM

I just bought a new BC125AT just because of USB so I can charge it forever in my car with a simple USB... or when I am away from other power sources via a simple 10,000 mAh battery pack or even solar. While it does show up as a COM port on the PC, at least it works. Love the large display as well.

I have given Uniden the idea that they should consider a black box scanner where it has Wi-Fi and it connects to a network 9or ad-hoc) and allows the full control interface to be on a web server on the device. We connect to it from an iPhoen or iPad and get as rich of an experience as we could on a large touch screen. Kind of like a Homepatrol on steroids... that would be so sweet! I can get an iPod Touch these days for $50 in good condition.
And enough with 16 character alpha tags... I want to be able to put big descriptions... perhaps 256 chars is called for ?
etc. etc. I can dream...

acourpet 10-18-2012 5:05 PM

Not sure if the following might help but you might want to give it a try. I had problems trying to connect my Uniden BC796D to Uniden's scanner software. I spent several days trying different cable configurations, baud rates, etc. but I kept getting the same error message as you did. I downloaded ARC250 demo and that communicated with no problem, go figure. Somewhere along the many years of computer torture I rememembered that sometimes switching a com port might get things to work. So even though I had been using com 14 which did work for the ARC250 I found that that com #2 was free. I am using Vista on my laptop, so I went into com port properties advanced for com 14 and changed it to com 2. No luck,BUT I rebotted the computer and I almost fainted as I NO longer received the dreaded message unable to connect. Now on com port 2 I can connect to Uniden's Bearcat's Trunk Tracker IV and ARS's 250. Yeppie

gonzalu 10-18-2012 8:34 PM

Well that turned out to be a good idea. So I downloaded a demo version of ScanControl and tried your suggestion.

Plugged in the last cable I bought which is a QVS model using Prolific PL2303 chipset and the latest drivers from Prolific. I have the COM port set to COM2 and the Baud rate to 9600. Set the radio to 9600 Baud as well.

Start ScanControl
At first it failed... I said, oh well, that's that... But I figured ok, let me keep playing.
Changed the COM port to COM1. Fire up ScanControl again and BINGO!! Connection!!!!

Here is the funny part. The software scans all ports and speeds until it finds something. It found the radio on COM2 ???? Yup, COM2

I see that the port properties on Device Manager are indeed showing COM1 but ScanControl still finds it on COM2.

I start the Uniden software and force it to COM2 and it still does not work. Tried a bunch of different ports, NADA.

So back to ScanControl and it works again. Do an download and an upload. Works...

I now decide let's try Control. It fails with a retry count exceeded. I decide to increase the speed to 57000 baud and try again. This time CONTROL works too... so what the heck is going on? Seems the drivers work and the cable and ports work. But there is something funky with the COM assignment and wit the Uniden native software.

Thanks for the tip. At least I am a little closer :)

What's considered the best software for the BC296D? I have a license for a VERY OLD version of ScanStar and I have a TON of config and freq files for it for my older radios (RadioShack 2042, Icom PCR-1000. AOR8000) and don't know if I can upgrade or what. I liked the program. But that was long ago...

acourpet 10-18-2012 9:17 PM

That is interesting. Did you rebot after you changed the com port. Mine didn't take until I reboted. My laptop has 2 USB connections and a port where it can take a serial port express card. I was so frustrated in not getting Uniden's software to work I bought the serial port express card to see if that would work. I mean that was a 9 pin from the computer to the 9 pin in back of the scanner. Well that didn't work so that's when I decided to play with the com port settings. I too had 1 and 2 open. That's when I forced changed the 14 to the 2 and everything started to work after the rebot. I think I have it on 38400 if memory serves me right. Well good luck. Now if I could only get this rebanding/trunking stuff figured out.


All times are GMT -5. The time now is 10:54 PM.

Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger