RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Site Administration Forums > Broadcastify/Live Audio Administration

Broadcastify/Live Audio Administration - Administration topics for live audio broadcasting on Broadcastify.com. This forum is for feed providers to get support. Other audio questions go here: Streaming /Broadcasting / Audio Recording forum

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #41 (permalink)  
Old 04-04-2017, 7:12 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 746
Default

Quote:
Originally Posted by JACK26 View Post
Sorry for all the posts but this issue has been very frustrating. There is absolutely no comprehensive instruction on the internet on how to make an RPi with no external sound card to feed a USB SDR dongle's audio to Broadcastify. Nothing I've found online works so far.
I agree, Jack. You see my post from 1-1/2 yrs ago above. Don't misinterpret my lack of posting since then. I wasn't successful, i gave up.
Reply With Quote
Sponsored links
  #42 (permalink)  
Old 04-04-2017, 7:23 PM
blantonl's Avatar
Founder and CEO
  RadioReference Database Admininstrator
Database Admin
Audio Feed Provider
Audio Feed Provider
 
Join Date: Dec 2000
Location: San Antonio, TX
Posts: 8,826
Default

Folks, I haven't tested my instructions with a RPi3 - this was all done with a RPi2 using the image that I provided in the Wiki link.

I'm planning on getting back to developing some more advanced feed appliances for Broadcastify on the RSPi platform... I can only do so much at a time.

I started this as a community effort and a few folks chipped in some good feedback on the Wiki article.
__________________
Lindsay C. Blanton III
CEO - RadioReference.com / Broadcastify
Facebook: RadioReference | Broadcastify | Twitter: @RadioReference
Reply With Quote
  #43 (permalink)  
Old 04-05-2017, 7:03 AM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 746
Default

Thanks for your interest in this, Lindsay. We appreciate it.

I just don't get it. jack26's posts got me to plug the dongle into the pi3 running Jessie again. When I start rtl_fm running the local FM broadcast station it will run fine with perfect audio all day long.

rtl_fm -M wbfm -f 98.3M -s 260k -r 48k -g 50 -o 1 -|aplay -r 48k -f S16_LE -c 1 -q -V mono -Dsysdefault:CARD=ALSA

When I run the same thing but with the local FD frequency I get underuns and no intelligible audio. Only changes are to the frequency, wbfm to fm, and adding the squelch.

rtl_fm -M fm -f 460.400M -s 260k -r 48k -p 54 -g 50 -l 70 -o 1 -|aplay -r 48k -f S16_LE -c 1 -q -V mono -Dsysdefault:CARD=ALSA

Where I live there isn't a strong enough NOAA weather station to reliably test with.
Attached Images
 

Last edited by DC31; 04-05-2017 at 7:34 AM..
Reply With Quote
  #44 (permalink)  
Old 04-07-2017, 8:34 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 64
Default Thanks for Reviewing this issue

Thanks for your support DC31.
The start of this thread looked promising as the founder was able to make it work on 10+ Rpi's and yet after 3 months still no success.

To clarify, I have not been able to use the Author's instructions at all to successfully transmit local FM to Broadcastify with just an Raspberry pi and a SDR dongle. it is not subtle problem.

Last edited by JACK26; 04-07-2017 at 8:40 AM..
Reply With Quote
  #45 (permalink)  
Old 04-07-2017, 8:58 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 64
Default

To clarify, I am successfully feeding an FM channel to broadcastify with a windows 8 based mini computer. I am trying to transfer this to a low cost Pi-3 and so far its' not working but I think I'm really close.
Reply With Quote
Sponsored links
  #46 (permalink)  
Old 04-09-2017, 12:29 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 64
Default

I think I'm closing in on the problem. It has to do with the squelch. This is the command line I'm trying to use:
sudo /usr/local/bin/rtl_fm -d 0 -M fm -f 482.8625M -p 0 -l 55 -g 43 -t 5 -E pad -s 12k

If I set the squelch param (-l 55) to -l 0 (no squelch) it seems to stay logged on and feeding ot broadcastify. So it seems there is something wrong with the "-E pad" parameter in that it's not padding the dead air with 0's.

This doesn't work:

sudo /usr/local/bin/rtl_fm -d 0 -M fm -f 482.8625M -p 0 -l 60 -g 40 -t 5 -E pad -s 12k | \
/usr/bin/lame -r -s 12 --resample 22.05 -m m -b 16 --cbr --lowpass 4 - - | \
/usr/bin/ezstream -q -c /etc/ezstream_bcfy.xml

If I change the -l parameter from 60 to 0 (no squelch) it feeds and successfully stays logged on to Broadcastify.

Thanks for any suggestions.
Reply With Quote
  #47 (permalink)  
Old 04-09-2017, 12:49 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 64
Default

It seems like there is something wrong with the rtl_fm build in that the -E pad parameter is not working. Another weird thing is that the frequency indicated when the code starts running is offset upwards from the -f parameter in the command line. This is the feedback I see:

Using device 0: Generic RTL2832U OEM
Found Rafael Micro R820T tuner
ezstream: Connected to [url]http://audio1.broadcastify.com:80/********/url]
ezstream: Streaming from standard input
Tuner gain set to 40.20 dB.
Tuned to 483114500 Hz.
Oversampling input by: 84x.
Oversampling output by: 1x.
Buffer size: 8.13ms
Exact sample rate is: 1008000.009613 Hz
Sampling at 1008000 S/s.
Output at 12000 Hz.

The astrix's above is the correct mount from my feeder page.
Reply With Quote
  #48 (permalink)  
Old 04-10-2017, 12:16 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 64
Default

Update: I found this thread with a solution to the padding 0's problem. The only problem I have is that I don't know how to apply the patch since I'm new to coding with linux. How do you apply this patch? I posted the same question on the author's thread but it's a dated thread. Any help with this would be appreciated.

rtl-sdr.com • View topic - rtl_fm squelch and mp3 encoding
Reply With Quote
  #49 (permalink)  
Old 04-10-2017, 4:57 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 64
Default

Update, the original author of this patch posted a reply for possible solutions.
My guess on why this has never been resolved is because the instructions for Icecast using an external USB sound stick works and is only about 10USD or so. My thing is that the external sound stick is not necessary and actually degrades the audio if you go that long route.

PS: Just so there is no misunderstanding, bean's solution is for rtl-fm to pad dead air with 0
null characters to keep the connection alive. So far this is not working with the releases originally quoted in this thread.

Last edited by JACK26; 04-10-2017 at 5:14 AM..
Reply With Quote
Sponsored links
  #50 (permalink)  
Old 04-10-2017, 5:33 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 64
Default

To clarify again, bean's suggestions are possible solutions to why the original posts in this thread are not working
Reply With Quote
  #51 (permalink)  
Old 04-14-2017, 5:33 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 64
Default

Follow up... This is not the fault of the original RB founders/authors that rtl-fm squelch is not working. It is a project under development and hopefully will be resolved by the community. No offense intended with any of my previous posts.

Follow up link to beans: http://www.rtl-sdr.com/forum/viewtop...t=141&start=10

Last edited by JACK26; 04-14-2017 at 5:43 AM..
Reply With Quote
  #52 (permalink)  
Old 04-16-2017, 11:43 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 64
Smile rtl-fm padded zero problem resloved

Finally got this working. For some reason the keenerd fork is not working. When squelch is activated the time counter on the public feed stops incrementing. and eventually logs the feeder off the Broadcastify server. This is because the rtl-fm function is not padding zeros to the broadcast,

I have no idea why this is happening now or if it's related to rpi3 or something changed on the keenerd fork.

To make this work for me I used the fork here:
https://github.com/osmocom/rtl-sdr

Works great but it takes a lot of tweaking between the -l squelch setting and the -g gain settings. I used SDR# on a windows 8 computer to figure out starting parameters. If the gain is too high, it will sound like too much squelch and cutting the live audio. In my case the rtl-fm parameters ended up at -l 75 -g 15 because the signal I'm feeding is really strong.

If you are having the same problems, the solution for me was to replace:

git clone https://github.com/keenerd/rtl-sdr/

with

sudo git clone https://github.com/osmocom/rtl-sdr/

Also, run all the original terminal commands as a sudo user (precede all commands with sudo),.
IF you've already installed rtl-sdr from keenerd you should uninstall that one first and do all that with the sdr stick unplugged.

The part in the original instructions where you direct stream output to a log file should only be used for troubleshooting because it will completely fill up the sd card with the stream if the connection is lost and eventually crashes the rpi.

/usr/bin/ezstream -c /etc/ezstream_bcfy2.xml > /var/log/bcfy2.log 2>&1 &

The last line in the startup command sequence should be this::

/usr/bin/ezstream -c /etc/ezstream_bcfy2.xml

The ezstrream filename may vary slightly but the path should be the same.

Referenced webpage:
Raspberry Pi RTL-SDR Broadcastify - The RadioReference Wiki



Good luck and let me know if this works for you.

Last edited by JACK26; 04-16-2017 at 1:40 PM.. Reason: Refinements
Reply With Quote
  #53 (permalink)  
Old 04-16-2017, 2:27 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 64
Default

One other thing, the original webpage was focused on feeding live AM ATC traffic and included instructions for narrow band fm (the majority of the feeders on Broadcastify). My solution is to use the same webpage's instructions (with modifications above) for feeding narrow band fm. I don't know if the osmocom branch would work for feeding AM ATC radio traffic.
Reply With Quote
  #54 (permalink)  
Old 04-17-2017, 5:17 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 64
Default

Surprised no one has responded to this thread yet as this solution is huge.. No more having to use a 300+IUSD radio scanner and external USB sound capture stick to feed nfm BroadCastify.with a raspberry pi. This solution only requires a compatible SDR USB stick and a sufficiently high local signal.

I've been googling solutions for weeks without success until I finally figured out that the keenerd fork does not work for rt;-fm narrow bandl.

Since this is supposed to be a "community effort" is there a way for qualified members to edit the original wiki instructions here?

Raspberry Pi RTL-SDR Broadcastify - The RadioReference Wiki

Last edited by JACK26; 04-17-2017 at 5:30 AM..
Reply With Quote
  #55 (permalink)  
Old 04-17-2017, 6:06 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 64
Default

Happy Easter everyone

Last edited by JACK26; 04-17-2017 at 6:55 AM..
Reply With Quote
Sponsored links
  #56 (permalink)  
Old 04-17-2017, 8:55 AM
blantonl's Avatar
Founder and CEO
  RadioReference Database Admininstrator
Database Admin
Audio Feed Provider
Audio Feed Provider
 
Join Date: Dec 2000
Location: San Antonio, TX
Posts: 8,826
Default

I went ahead and updated the wiki with the latest rtl url.

I'll get to work shortly on updating the downloadable image with all the latest code.

Also, have a look at rtl_airband's latest releases, which support NFM scanning.
__________________
Lindsay C. Blanton III
CEO - RadioReference.com / Broadcastify
Facebook: RadioReference | Broadcastify | Twitter: @RadioReference
Reply With Quote
  #57 (permalink)  
Old 04-17-2017, 7:25 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 746
Default

Still no joy here...
Reply With Quote
  #58 (permalink)  
Old 04-18-2017, 12:44 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 64
Default

Thanks for following up on that Lindsay. Will check out the ATC channels when I get a chance but not sure I will be able to receive the local ATC signals without an 88-108 FM trap in my area because they are using frequencies slightly higher than that. Is it ok to feed frequencies that are not assigned for experimenting or do you have sandbox feed I can use?

One thing I haven't figured out yet is how to set the bandwidth of the usb sdr stick. For tuning a narrow band FM signal the bw only needs to be about 250 KS/s. rtl-fm is setting it to about 1MS/s. A smaller bw would probably work better especially on earlier versions of rpi's.

DC31 did you completely uninstall the rtl-sdr from the keenerd fork? I went as far as deleting the related files and directories (all with the rpi booted up without the sdr stick plugged in).
If that doesn't work, you might want to try a complete re-install on a fresh sd card and make sure all commands are done as a sudo user.

My final startup sequence looks like this:

sudo /usr/local/bin/rtl_fm -d 0 -M fm -f 482.862M -p 0 -l 75 -g 15 -t 5 -E pad -s 12k | \
/usr/bin/lame -r -s 12 --resample 22.05 -m m -b 16 --cbr --lowpass 4 - - | \
/usr/bin/ezstream -q -c /etc/ezstream_bcfy.xml

If you set the rtl_fm -l parameter to 0 and with sufficient audible static, you should be able to connect with either version of rtl-sdr. If you're not staying connected with 0 squelch then there is some other problem.

This is the feedback I see in the terminal window. 'mymount' is the actual mount from broadcastify without the extra '/'.

Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
Found Rafael Micro R820T tuner
ezstream: Connected to http://audio1.broadcastify.com:80/mymount
ezstream: Streaming from standard input
Tuner gain set to 14.40 dB.
Tuned to 483114000 Hz.
Oversampling input by: 84x.
Oversampling output by: 1x.
Buffer size: 8.13ms
Exact sample rate is: 1008000.009613 Hz
Sampling at 1008000 S/s.
Output at 12000 Hz.

ps: the offset in the tuned frequency indicated in the feedback vs the rtl-fm command parameter is intentional and is explained by the original coder in the docs and works fine. i.e. Use the actual frequency you are receiving and don't worry about the offset indicated in the feedback.

Last edited by JACK26; 04-18-2017 at 1:48 AM..
Reply With Quote
  #59 (permalink)  
Old 04-18-2017, 2:45 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2016
Location: CA
Posts: 64
Default

Lindsay, one other suggestion, you should delete the part of the example startup sequence from the wiki that logs the stream to a file if connection is lost. It is not helpful and just floods the sd card with the stream if the connection is lost. also the added sudo and '\' at the end of the first 2 lines works for me.
ie change

/usr/local/bin/rtl_fm -d 0 -M fm -f 461.4M -p 69 -l 65 -g 50 -t 2 -E pad -s 12k |
/usr/bin/lame -r -s 12 --resample 22.05 -m m -b 16 --cbr --lowpass 4 - - |
/usr/bin/ezstream -c /etc/ezstream_bcfy.xml > /var/log/bcfy2.log 2>&1 &

to:

sudo /usr/local/bin/rtl_fm -d 0 -M fm -f 461.4M -p 69 -l 65 -g 50 -t 2 -E pad -s 12k | \
/usr/bin/lame -r -s 12 --resample 22.05 -m m -b 16 --cbr --lowpass 4 - - | \
/usr/bin/ezstream -c /etc/ezstream_bcfy.xml

Regards

PS this is the startup sequence that works for my specific hardware:

sudo /usr/local/bin/rtl_fm -d 0 -M fm -f 482.862M -p 0 -l 75 -g 15 -t 5 -E pad -s 12k | \
/usr/bin/lame -r -s 12 --resample 22.05 -m m -b 16 --cbr --lowpass 4 - - | \
/usr/bin/ezstream -q -c /etc/ezstream_bcfy.xml

Using an rpi 3 with jessie pixel installed. The load on the cpu is only around 5 percent and the operating temp is around 56 C with a single USB sdr stick.

Last edited by JACK26; 04-18-2017 at 4:24 AM..
Reply With Quote
  #60 (permalink)  
Old 04-18-2017, 6:47 AM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 746
Default

[QUOTE=JACK26;2752256]

DC31 did you completely uninstall the rtl-sdr from the keenerd fork? I went as far as deleting the related files and directories (all with the rpi booted up without the sdr stick plugged in).
If that doesn't work, you might want to try a complete re-install on a fresh sd card and make sure all commands are done as a sudo user.

Yes, I started with a freshly flashed SD card. I know that I stumbled a couple times during the set up process so may have inadvertently screwed things up. I will start over again soon and see if I can get through it without messing up.

Thanks for your efforts on this.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 8:43 PM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2015 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions