RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Commercial, Professional Radio and Personal Radio > Budget and Entry Level Transceivers


Budget and Entry Level Transceivers - For discussion of budget or entry level radios such as Baofeng, Wouxun, Puxing and other radio communications designated as commercial but not targeted for Amateur or GMRS. Also included are MURS and ISM 900MHz designed radios.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 05-19-2018, 11:31 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Jun 2016
Location: Dallas-Fort Worth, Texas
Posts: 169
Default MD-2017 White screen

I have been having an issue with my MD 2017 where when I turn it on all I get is a white screen. The white screen never goes away. My display is ALWAYS a white screen only. I also still cannot connect to my computer. Havenít been able to connect after the first time I was successful the first day I had it. (Christmas Day) any clue what could be up/possible fixes?
__________________
BCD396XT // BCD996XT // BCD436HP + DMR Upgrade + EDACS ProVoice Upgrade + NXDN Upgrade + ProScan
Baofeng UV-82WP // TYT MD-2017
Comet DS150S 25-1500 MHz Discone + Comet HS-05 M/J-SMA/P 0.5m
Reply With Quote
Sponsored links
  #2 (permalink)  
Old 05-19-2018, 2:03 PM
jimvm's Avatar
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Feb 2005
Location: Olivehurst, California
Posts: 214
Default

Did you buy the radio from 2wayradios?
They are going to replace my MD-9600 that had same problem.

jimvm
Reply With Quote
  #3 (permalink)  
Old 05-19-2018, 2:34 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Jun 2016
Location: Dallas-Fort Worth, Texas
Posts: 169
Default

Quote:
Originally Posted by jimvm View Post
Did you buy the radio from 2wayradios?

They are going to replace my MD-9600 that had same problem.



jimvm


I received it for Christmas. I believe it was purchased from Amazon.


Sent from my iPhone using Tapatalk
__________________
BCD396XT // BCD996XT // BCD436HP + DMR Upgrade + EDACS ProVoice Upgrade + NXDN Upgrade + ProScan
Baofeng UV-82WP // TYT MD-2017
Comet DS150S 25-1500 MHz Discone + Comet HS-05 M/J-SMA/P 0.5m
Reply With Quote
  #4 (permalink)  
Old 05-19-2018, 3:50 PM
JustLou's Avatar
Member
   
Join Date: Jan 2011
Location: NY/NJ
Posts: 469
Default

This is a common issue with this radio, the MD380, the GD77 and similar radios from China. The fix is to open the radio and reseat the ribbon cable connected to the screen and main board.
Reply With Quote
  #5 (permalink)  
Old 05-21-2018, 7:14 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Jun 2016
Location: Dallas-Fort Worth, Texas
Posts: 169
Default

Does anyone know how to reset the radio itself? Maybe a combination of buttons pressed and other actions simultaneously? I'd rather try a hard reset/restart before opening it.
__________________
BCD396XT // BCD996XT // BCD436HP + DMR Upgrade + EDACS ProVoice Upgrade + NXDN Upgrade + ProScan
Baofeng UV-82WP // TYT MD-2017
Comet DS150S 25-1500 MHz Discone + Comet HS-05 M/J-SMA/P 0.5m
Reply With Quote
Sponsored links
  #6 (permalink)  
Old 05-21-2018, 9:52 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: May 2014
Posts: 177
Default

Quote:
Originally Posted by chaseboyer View Post
Does anyone know how to reset the radio itself? Maybe a combination of buttons pressed and other actions simultaneously? I'd rather try a hard reset/restart before opening it.

Re-SEAT the cable...not Re-SET. The cable inside the radio may have come loose. No button pressing will fix a loose connection. If this happened because of a firmware upgrade gone bad, then you can try to restore it to the previous firmware.
Reply With Quote
  #7 (permalink)  
Old 05-22-2018, 1:46 AM
teufler's Avatar
Member
  Premium Subscriber
Premium Subscriber
Amateur Radio Operator
Amateur Radio
 
Join Date: Dec 2002
Location: ST PETERS, MISSOURI
Posts: 2,343
Default

you might check, did you install firmware that is not for your radio. GPS for a gps radio and non GPS for the none gps model.., I did this and I had put the wrong firmware for the model I had.
__________________
WD0GSYDMR ID 3129226 AND 3129304
BC-396XT,780XLT,TENTEC PARAGON, TYT-2017, MD-390, DM-5R+, ANYTONE 5888,VX10, VX7, VX3,TERMN-8R, F8-HP, GT3, UV-5, UV-3R, WOUXUN UV-8D,JUENTAI UV8DR,
Reply With Quote
  #8 (permalink)  
Old 05-26-2018, 1:24 PM
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Apr 2009
Location: FOE & PDX
Posts: 239
Default

I had this same issue. Courtesy of this post, youtube and some other research I opened up the radio, re-seated the screen ribbon and this resolved the issue for me.
Reply With Quote
  #9 (permalink)  
Old 06-26-2018, 2:38 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Jun 2016
Location: Dallas-Fort Worth, Texas
Posts: 169
Default

How do you get the silver piece off of the radio to get to the internals? I removed the two screws under the battery but no luck removing


Sent from my iPhone using Tapatalk
__________________
BCD396XT // BCD996XT // BCD436HP + DMR Upgrade + EDACS ProVoice Upgrade + NXDN Upgrade + ProScan
Baofeng UV-82WP // TYT MD-2017
Comet DS150S 25-1500 MHz Discone + Comet HS-05 M/J-SMA/P 0.5m
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:25 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2015 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions