RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Commercial, Professional Radio and Personal Radio > ICOM Land Mobile Radio


ICOM Land Mobile Radio - Discussion forum for ICOM land mobile radio equipment such as the IC-F series radios. Please do not post amateur radio topics here.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 07-11-2017, 5:41 PM
Newbie
   
Join Date: Apr 2015
Location: Virginia City, NV
Posts: 4
Default ICOM F521 squelch troubles

Hello, I recently purchased an ICOM F521 from ebay. I have programming software and the cable, and was able to program the radio the way I wanted, however, I ran into a problem when I turned the radio on to use it. All of the channels i programmed have squelch issues, as in when nobody is transmitting all i hear is static. How do I correct this? What is the proper squelch setting? The range value it gives in the program screen is 0 - 250. Thank you!
Reply With Quote
Sponsored links
  #2 (permalink)  
Old 07-11-2017, 7:55 PM
Member
   
Join Date: Mar 2010
Posts: 757
Default

Can you get it to stop when you jack the squelch up? Even all the way up to 250?

Is this radio in a vehicle or used as a base? It could be picking up garbage in a vehicle, exp newer vehicles. RX PL or DPL can mask the problem as well.
Reply With Quote
  #3 (permalink)  
Old 07-11-2017, 8:30 PM
Newbie
   
Join Date: Apr 2015
Location: Virginia City, NV
Posts: 4
Default

Quote:
Originally Posted by 12dbsinad View Post
Can you get it to stop when you jack the squelch up? Even all the way up to 250?

Is this radio in a vehicle or used as a base? It could be picking up garbage in a vehicle, exp newer vehicles. RX PL or DPL can mask the problem as well.
When I set the squelch up to 200 it stops, but im not sure if i will be able to receive. The radio will be vehicle mounted, so far ive only tested the radio at my desk, and these were the results i got.
Reply With Quote
  #4 (permalink)  
Old 07-11-2017, 8:48 PM
Member
   
Join Date: Mar 2010
Posts: 757
Default

Quote:
Originally Posted by JMBissen View Post
When I set the squelch up to 200 it stops, but im not sure if i will be able to receive. The radio will be vehicle mounted, so far ive only tested the radio at my desk, and these were the results i got.
Do you have the unit hooked to a antenna? or does it do it with nothing connected and just powered on?
Reply With Quote
  #5 (permalink)  
Old 07-11-2017, 9:09 PM
Newbie
   
Join Date: Apr 2015
Location: Virginia City, NV
Posts: 4
Default

I have not hooked the unit up to an antenna yet, so far I have only turned it on at my desk after programming and adjusting it.
Reply With Quote
Sponsored links
  #6 (permalink)  
Old 07-11-2017, 9:22 PM
Member
   
Join Date: Mar 2010
Posts: 757
Default

Quote:
Originally Posted by JMBissen View Post
I have not hooked the unit up to an antenna yet, so far I have only turned it on at my desk after programming and adjusting it.
I'd say there is an issue with the radio if it is doing it not connected to the outside world, as much as I hate to say it. I am betting it is either a bad ceramic filter, which is common and will make the radio do strange things, or somebody got into the adjust software and really screwed things up.

If you have a way of connecting the radio to an antenna to actually receive something, try that. You may find it doesn't even pick up anything. That would be an indication of a bad filter.
Reply With Quote
  #7 (permalink)  
Old 07-11-2017, 9:32 PM
Newbie
   
Join Date: Apr 2015
Location: Virginia City, NV
Posts: 4
Default

Thank you, when I get back to the vehicle I'm putting it in I will try it that way. I appreciate your help
Reply With Quote
  #8 (permalink)  
Old 07-15-2017, 4:22 PM
Member
   
Join Date: Dec 2016
Posts: 44
Default

If your sitting at a desk is their a computer or electronics close by? I cannot use my portable in my office by the computer or my electric golf card without it tripping like u

Sent from my SM-G903W using Tapatalk
Reply With Quote
  #9 (permalink)  
Old 07-20-2017, 9:10 PM
Member
   
Join Date: Sep 2002
Location: Florida, where you wish you were!
Posts: 2,551
Default

As I recall, a squelch setting of 80 was what I programmed by default into those radios, and adjusted as need be. I rarely turned it up over 120.

But, in my experience with Icom mobile radios, their receivers are not very noise resistant. Real world selectivity never impressed me. It seems to me that Icom sacrificed selectivity and resistance to interference in order to get raw sensitivity.

I used to program literally hundreds of 521s but it has been a few years.
__________________
No, I will not program your radio for you. No, I will not give you any software. Don't ask unless you want a rude answer.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 5:05 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2015 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions