RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Computer Aided Monitoring and Programming > Software Defined Radio


Software Defined Radio - A forum for general discussion of software defined radio (SDR) receiver equipment.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1321 (permalink)  
Old 10-17-2017, 7:15 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Mar 2007
Location: Talbot Co, MD
Posts: 609
Default

Quote:
Originally Posted by rylvir View Post
Just reinstalled OP25 after a years hiatus, currently using boatbod branch on Linux Mint 18.2. So rx.py is new to me, and thanks to this thread I have it up and running! No errors, great sounding audio on a local Phase 1 system. Resources are quite a bit lighter on these new versions, and I really like the audio. Is there any new tricks to pipe the audio from OP25 > darkice > Broadcastify? I used to use pavucontrol, and just direct all audio over to darkice with success, but that isn't working anymore.

Linux Mint 18.2
The pulse audio method should still work for darkice, but I recall you need to go in to the pulse audio mixer when darkice is running and put a check in a box to make the monitoring work correctly.

Personally I use straight alsa with an aloop (loopback) device defined in /etc/asound.conf. That way other system sounds don't inadvertently get picked up and mixed in with your broadcastify stream. PM me if you want a copy of the config file.
Reply With Quote
Sponsored links
  #1322 (permalink)  
Old 10-19-2017, 8:02 AM
Member
   
Join Date: Nov 2014
Posts: 20
Default

Quote:
Originally Posted by royldean View Post
Awesome. I will try this afternoon. Assuming all other instructions the same (this is a huge thread so I may have missed this somewhere else)?

Thanks!
I have found that boatbod's install script works great as well. (It's in the root of his github after cloning it)
Reply With Quote
  #1323 (permalink)  
Old 10-19-2017, 12:13 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Mar 2007
Location: Talbot Co, MD
Posts: 609
Default

Quote:
Originally Posted by telvana View Post
I have found that boatbod's install script works great as well. (It's in the root of his github after cloning it)
The credit for that install script goes to Max.
------------------
For anyone interested, I have merged the latest changes to the osmocom max branch into my op25 github fork and added the ability to dynamically turn on and off the various plots (fft, constellation, symbol & datascope). These are controlled from the terminal window by pressing the 1, 2, 3 & 4 keys.

1 = fft
2 = constellation
3 = symbol
4 = datascope

Presently it is only possible to enable one plot at a time. Once I figure out how to track and untangle the gnuradio inter-block connections, I will see about making them operate simultaneously.


Graham

Last edited by boatbod; 10-19-2017 at 12:31 PM..
Reply With Quote
  #1324 (permalink)  
Old 10-19-2017, 5:43 PM
Member
   
Join Date: Oct 2010
Location: Kansas City, MO
Posts: 36
Default

Hello, I have been playing with the older version of OP25 (scope.sh) and was going to try out the max branch version. I am setting up a new box with 16.04 and running into "E: You must put some 'source' URIs in your sources.list" error when running "apt-get build-dep gnuradio". Is Ubuntu 14 still the only way to go, or is 16 usable?

I did use the thread search and found a reference to this error and I didn't understand adcockfred's response. 2-5 clone command.
Reply With Quote
  #1325 (permalink)  
Old 10-20-2017, 12:38 AM
Member
   
Join Date: Oct 2010
Location: Kansas City, MO
Posts: 36
Default

EDIT: Finally realized I was in the wrong directory LOL.
Reply With Quote
Sponsored links
  #1326 (permalink)  
Old 10-20-2017, 7:17 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Mar 2007
Location: Talbot Co, MD
Posts: 609
Default

Quote:
Originally Posted by tecc1229 View Post
Hello, I have been playing with the older version of OP25 (scope.sh) and was going to try out the max branch version. I am setting up a new box with 16.04 and running into "E: You must put some 'source' URIs in your sources.list" error when running "apt-get build-dep gnuradio". Is Ubuntu 14 still the only way to go, or is 16 usable?

I did use the thread search and found a reference to this error and I didn't understand adcockfred's response. 2-5 clone command.
The max branch and my fork both work fine on Ubuntu 16 as well as Raspbian Jessie/Stretch etc.
Reply With Quote
  #1327 (permalink)  
Old 10-20-2017, 9:48 AM
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Jan 2016
Location: Schwenksville, PA
Posts: 213
Default

So now that boatbod has single handedly got op25 running on my ubuntu box, I have a general follow up question. Can I force op25 into only monitoring certain talkgroups? Also, is there a way to force it to give priority to certain talkgroups? I realize this may be a stretch with a single rtl-sdr (how is it supposed to re-tune based on a control channel if it is currently monitoring a transmission that forced a re-tune beyond the range of the control channel, correct)?
Reply With Quote
  #1328 (permalink)  
Old 10-20-2017, 12:20 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Mar 2007
Location: Talbot Co, MD
Posts: 609
Default

Quote:
Originally Posted by royldean View Post
So now that boatbod has single handedly got op25 running on my ubuntu box, I have a general follow up question. Can I force op25 into only monitoring certain talkgroups? Also, is there a way to force it to give priority to certain talkgroups? I realize this may be a stretch with a single rtl-sdr (how is it supposed to re-tune based on a control channel if it is currently monitoring a transmission that forced a re-tune beyond the range of the control channel, correct)?
Monitoring "only" specified TGIDs is easy. Populate a file containing numeric TGIDs (one per line) and save this as "tgid.wlist" (or whatever name you want), then add the filename to the appropriate position in your trunk.tsv config file.

e.g. "talbot-leo.wlist" as seen in my config fie.
Code:
"Sysname"	"Control Channel List"	"Offset"	"NAC"	"Modulation"	"TGID Tags File"	"Whitelist"	"Blacklist"	"Center Frequency"
"FiRST-TALB"	"773.843750"	"0"	"0x4a6"	"CQPSK"	"first.tsv"	"talbot-leo.wlist"	"first.blist"	"773.84375"
Reply With Quote
  #1329 (permalink)  
Old 10-20-2017, 1:05 PM
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Jan 2016
Location: Schwenksville, PA
Posts: 213
Default

does the addition of that .wlist EXCLUDE those tgid's? Because I just restarted with a new list and now I'm hearing only from tg's that I don't want to hear.

[edit] Doh! missed a column and added it to "blacklist"!!!

Last edited by royldean; 10-20-2017 at 1:09 PM..
Reply With Quote
  #1330 (permalink)  
Old 10-20-2017, 3:24 PM
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Jan 2016
Location: Schwenksville, PA
Posts: 213
Default

is there a command line argument that increases audio volume? I have to crank my volume all the way up to hear.
Reply With Quote
  #1331 (permalink)  
Old 10-20-2017, 3:45 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Jun 2010
Location: Hesperia California
Posts: 141
Default

If you are running 14.04 there is a check box to increase volume more than 100% under settings in Ubuntu 14.04
Reply With Quote
  #1332 (permalink)  
Old 10-20-2017, 7:14 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Mar 2007
Location: Talbot Co, MD
Posts: 609
Default

Quote:
Originally Posted by royldean View Post
is there a command line argument that increases audio volume? I have to crank my volume all the way up to hear.
You can run "alsamixer" on the command line and that lets you adjust levels.
Reply With Quote
  #1333 (permalink)  
Old 10-20-2017, 9:19 PM
Member
   
Join Date: Nov 2014
Posts: 20
Default

Quote:
Originally Posted by boatbod View Post
The credit for that install script goes to Max.
------------------
Sorry, I hadn't noticed it until I cloned your github so I figured it was yours. My apologies.
Reply With Quote
  #1334 (permalink)  
Old 10-21-2017, 7:53 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Jun 2010
Location: Hesperia California
Posts: 141
Default

Trying to run cmake ../ comand and get this error any ideas


-- The CXX compiler identification is unknown
-- The C compiler identification is GNU 5.4.0
CMake Error at CMakeLists.txt:2 (project):
No CMAKE_CXX_COMPILER could be found.

Tell CMake where to find the compiler by setting either the environment
variable "CXX" or the CMake cache entry CMAKE_CXX_COMPILER to the full path
to the compiler, or to the compiler name if it is in the PATH.


-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Configuring incomplete, errors occurred!
See also "/home/aaron/op25/build/CMakeFiles/CMakeOutput.log".
See also "/home/aaron/op25/build/CMakeFiles/CMakeError.log".
Reply With Quote
  #1335 (permalink)  
Old 10-21-2017, 8:37 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Mar 2007
Location: Talbot Co, MD
Posts: 609
Default

Quote:
Originally Posted by ansul1001 View Post
Trying to run cmake ../ comand and get this error any ideas


-- The CXX compiler identification is unknown
-- The C compiler identification is GNU 5.4.0
CMake Error at CMakeLists.txt:2 (project):
No CMAKE_CXX_COMPILER could be found.

Tell CMake where to find the compiler by setting either the environment
variable "CXX" or the CMake cache entry CMAKE_CXX_COMPILER to the full path
to the compiler, or to the compiler name if it is in the PATH.


-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Configuring incomplete, errors occurred!
See also "/home/aaron/op25/build/CMakeFiles/CMakeOutput.log".
See also "/home/aaron/op25/build/CMakeFiles/CMakeError.log".
Unmet dependency; in this case you probably don't have a fully installed build-essential package.

sudo apt-get install build-essential
Reply With Quote
  #1336 (permalink)  
Old 10-21-2017, 11:00 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Jun 2010
Location: Hesperia California
Posts: 141
Default

Now i get this when trying to run osmocom_fft



linux; GNU C++ version 5.3.1 20151219; Boost_105800; UHD_003.009.002-0-unknown

Traceback (most recent call last):
File "/usr/bin/osmocom_fft", line 34, in <module>
from gnuradio import blocks
File "/usr/lib/python2.7/dist-packages/gnuradio/blocks/__init__.py", line 34, in <module>
from stream_to_vector_decimator import *
File "/usr/lib/python2.7/dist-packages/gnuradio/blocks/stream_to_vector_decimator.py", line 23, in <module>
from gnuradio import gr
File "/usr/lib/python2.7/dist-packages/gnuradio/gr/__init__.py", line 44, in <module>
from top_block import *
File "/usr/lib/python2.7/dist-packages/gnuradio/gr/top_block.py", line 30, in <module>
from hier_block2 import hier_block2
File "/usr/lib/python2.7/dist-packages/gnuradio/gr/hier_block2.py", line 25, in <module>
import pmt
File "/usr/lib/python2.7/dist-packages/pmt/__init__.py", line 58, in <module>
from pmt_to_python import pmt_to_python as to_python
File "/usr/lib/python2.7/dist-packages/pmt/pmt_to_python.py", line 22, in <module>
import numpy
ImportError: No module named numpy
Reply With Quote
  #1337 (permalink)  
Old 10-22-2017, 7:52 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Mar 2007
Location: Talbot Co, MD
Posts: 609
Default

Quote:
Originally Posted by ansul1001 View Post
Now i get this when trying to run osmocom_fft



linux; GNU C++ version 5.3.1 20151219; Boost_105800; UHD_003.009.002-0-unknown

Traceback (most recent call last):
File "/usr/bin/osmocom_fft", line 34, in <module>
from gnuradio import blocks
File "/usr/lib/python2.7/dist-packages/gnuradio/blocks/__init__.py", line 34, in <module>
from stream_to_vector_decimator import *
File "/usr/lib/python2.7/dist-packages/gnuradio/blocks/stream_to_vector_decimator.py", line 23, in <module>
from gnuradio import gr
File "/usr/lib/python2.7/dist-packages/gnuradio/gr/__init__.py", line 44, in <module>
from top_block import *
File "/usr/lib/python2.7/dist-packages/gnuradio/gr/top_block.py", line 30, in <module>
from hier_block2 import hier_block2
File "/usr/lib/python2.7/dist-packages/gnuradio/gr/hier_block2.py", line 25, in <module>
import pmt
File "/usr/lib/python2.7/dist-packages/pmt/__init__.py", line 58, in <module>
from pmt_to_python import pmt_to_python as to_python
File "/usr/lib/python2.7/dist-packages/pmt/pmt_to_python.py", line 22, in <module>
import numpy
ImportError: No module named numpy
Python install is broken.
What happened? Thought you had op25 successfully built/running and just needed to get the tuning dialed in?
Reply With Quote
  #1338 (permalink)  
Old 10-22-2017, 10:46 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Jun 2010
Location: Hesperia California
Posts: 141
Default

Have it running on my computer Installing op25 on a laptop running mint 18.2 trying to get it to work kind of dificult
Reply With Quote
  #1339 (permalink)  
Old 10-22-2017, 1:14 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Mar 2007
Location: Talbot Co, MD
Posts: 609
Default

Quote:
Originally Posted by ansul1001 View Post
Have it running on my computer Installing op25 on a laptop running mint 18.2 trying to get it to work kind of dificult
I don't recall having that much of an issue when I installed Mint, but that was a while ago...

Try this:
sudo apt-get install python2.7-dev
or maybe this:
sudo apt-get install python2.7

If it fails you can always do this to fix the numpy error, but I wonder what else is missing.
sudo apt-get install python-numpy
Reply With Quote
  #1340 (permalink)  
Old 10-22-2017, 1:24 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Mar 2007
Location: Talbot Co, MD
Posts: 609
Default New gnuplot mode

Another day, another update This time I have something that I hope will help with dialing in the fine tuning; it's a new plot mode showing the output of the mixer - in other words just the portion of the signal that is going to be used by the c4fm/cqpsk demodulator.

When tuning is adjusted correctly, you should see a nicely symmetrical upside-down "U" centered perfectly at zero. If tuning is off, the envelope will be shifted to one side or the other and will look distorted. Adjust ppm correction and/or fine-tune to make it look good, then use these values in your rx.py command line parameters.

Mixer plot can be initiated either by pressing "5" from the terminal screen, or using the command line parameter "-P mixer".

The code for this change has been committed to my github. Perform a "git pull" to get the changes if you have already cloned the repo.

NOTE: first screen shot shows good tuning, second shows tuning significantly offset
Attached Images
  

Last edited by boatbod; 10-22-2017 at 1:30 PM..
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:02 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2015 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions