RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Computer Aided Monitoring and Programming > Streaming / Broadcasting / Audio Recording


Streaming / Broadcasting / Audio Recording - Interested in putting your scanner online for others to hear? Want to listen to other radios on the internet. This forum is here for you to discuss these topics related to streaming scanners online.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #21 (permalink)  
Old 06-13-2009, 7:58 AM
NYRHKY94's Avatar
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Mar 2006
Location: Brunswick County, NC
Posts: 1,309
Default Web Server - ScanCast Configuration Help

Hi Guys:

Any chance somebody could post a quick set of instructions for proper configuration of the new Web Server - ScanCast feature in v2.9.0? Screen shots of both tabs that are configured and working would be awesome.

Thanks in advance!

Mike
__________________
BCD536HP/BCD436HP/BCD996P2/BCD325P2/BCD996XT/BCT15X/PRO-197/PSR-600
Reply With Quote
Sponsored links
  #22 (permalink)  
Old 06-13-2009, 11:43 AM
ProScan's Avatar
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Jul 2006
Location: Ontario, Calif.
Posts: 2,823
Default

Mike,

I see that Alex replayed to your questions on my board about the setup?

Not sure how far you got with the Web Server or ScanCast.

Web Server Setup
First - Check the audio settings located in the audio control tab.

Second - Go to the Web Server tab and choose any port number, Web Page title, etc. and click on "Start". Look for the red light to illuminate.

Third - Use Internet Explorer, put the ip address / port number in the URL address box. Example: 192.168.1.2:5000 You should see the Web Server in the browser.

ScanCast:
IceCast2 or the Shoutcast server software need to be downloaded unless you are streaming to ScanAmerica
Streaming to ScanAmerica needs to be setup with Gordon.
For streaming to ScanAmerica, Choose IceCast2 server type in the ScanCast setup area.

Note: Fixed bug today with other browsers(firefox,etc.) not working with the live stream and fixed another bug if the web server is password protected then the live stream didn't work.

Quote:
Originally Posted by NYRHKY94 View Post
Hi Guys:

Any chance somebody could post a quick set of instructions for proper configuration of the new Web Server - ScanCast feature in v2.9.0? Screen shots of both tabs that are configured and working would be awesome.

Thanks in advance!

Mike
__________________
Most Popular & Feature-Rich Scanner Software For The Uniden's
ProScan - RadioFeed Home Page
bob@proscan.org

Last edited by ProScan; 06-13-2009 at 11:45 AM..
Reply With Quote
  #23 (permalink)  
Old 06-13-2009, 12:05 PM
ffemtrfc1's Avatar
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Apr 2006
Location: Eastern Shore, Maryland
Posts: 40
Default

I am having issues installing the 2.9.0 version...What am I doing wrong? I'm currently running 2.1.0 version that is licensed and registered to me...I'm getting error messages when trying to DL about lame.enc...HELP!
Reply With Quote
  #24 (permalink)  
Old 06-13-2009, 12:26 PM
ProScan's Avatar
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Jul 2006
Location: Ontario, Calif.
Posts: 2,823
Default

After the file is downloaded. Extract all the files to an EXISTING ProScan folder and it should run.

I suspect you tried to run the .exe within the zip or you created a new folder.

Quote:
Originally Posted by ffemtrfc1 View Post
I am having issues installing the 2.9.0 version...What am I doing wrong? I'm currently running 2.1.0 version that is licensed and registered to me...I'm getting error messages when trying to DL about lame.enc...HELP!
__________________
Most Popular & Feature-Rich Scanner Software For The Uniden's
ProScan - RadioFeed Home Page
bob@proscan.org
Reply With Quote
  #25 (permalink)  
Old 06-13-2009, 1:11 PM
NYRHKY94's Avatar
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Mar 2006
Location: Brunswick County, NC
Posts: 1,309
Default

Hi Bob:

I have the web server up & running now and can acces it via a web browser on my PC and play the stream (nice!). That part is all set for me. When I tried to do the same thing however on my Blackberry Storm (bring the server up on the BB browser), I receive the following error when I click on Listen Live:

"Invalid address: http//75.23.187.93:5700\stream.m3u"

It appears to be showing the wrong "syntax" for the last part of the stream url, i.e. should be /stream.m3u. Any thoughts on this one?
__________________
BCD536HP/BCD436HP/BCD996P2/BCD325P2/BCD996XT/BCT15X/PRO-197/PSR-600
Reply With Quote
Sponsored links
  #26 (permalink)  
Old 06-13-2009, 4:00 PM
ProScan's Avatar
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Jul 2006
Location: Ontario, Calif.
Posts: 2,823
Default

Quote:
Originally Posted by NYRHKY94 View Post
Hi Bob:

I have the web server up & running now and can acces it via a web browser on my PC and play the stream (nice!). That part is all set for me. When I tried to do the same thing however on my Blackberry Storm (bring the server up on the BB browser), I receive the following error when I click on Listen Live:

"Invalid address: http//75.23.187.93:5700\stream.m3u"

It appears to be showing the wrong "syntax" for the last part of the stream url, i.e. should be /stream.m3u. Any thoughts on this one?
The problem is fixed. I had a backslash instead of a fowardslash in the URL before stream. \stream should of been /stream.

I'm planning on officially releasing version 2.9.1 Sunday however if you want an earlier release of 2.9.1.

Here is the un-official file. This file requires 2.9.0 to be installed.
http://proscan.org/ProScan.zip

Unzip and copy the .exe over the original .exe
__________________
Most Popular & Feature-Rich Scanner Software For The Uniden's
ProScan - RadioFeed Home Page
bob@proscan.org
Reply With Quote
  #27 (permalink)  
Old 06-13-2009, 7:17 PM
NYRHKY94's Avatar
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Mar 2006
Location: Brunswick County, NC
Posts: 1,309
Default

Hey Bob:

Thanks for supplying the new .exe for testing. I downloaded it and copied over the existing .exe and unfortunately, I'm still getting the same result when clicking on Listen Live on my Blackberry Storm web browser. I still get an error stating that the address is invaild and it still has the incorrect \stream.m3u syntax.

Not sure what could be wrong at this point?
__________________
BCD536HP/BCD436HP/BCD996P2/BCD325P2/BCD996XT/BCT15X/PRO-197/PSR-600

Last edited by NYRHKY94; 06-13-2009 at 7:21 PM..
Reply With Quote
  #28 (permalink)  
Old 06-13-2009, 8:37 PM
NYRHKY94's Avatar
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Mar 2006
Location: Brunswick County, NC
Posts: 1,309
Default

Bob:

All set now! The new .exe did fix the issue. I needed to clear my browser cache & history. Once that was done, the Listen Live link worked as expected.

Thanks for all the hard work on this today!

Mike
__________________
BCD536HP/BCD436HP/BCD996P2/BCD325P2/BCD996XT/BCT15X/PRO-197/PSR-600
Reply With Quote
  #29 (permalink)  
Old 06-13-2009, 10:30 PM
ProScan's Avatar
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Jul 2006
Location: Ontario, Calif.
Posts: 2,823
Default IMPORTANT - Web Server - Turn Off Serve Folders & Files

It was just reported to me and verified that running Web Server and "Serve Folders & Files" is turned on can expose the whole hard drive directory system.

Please turn off "Serve Folders & Files"
__________________
Most Popular & Feature-Rich Scanner Software For The Uniden's
ProScan - RadioFeed Home Page
bob@proscan.org
Reply With Quote
  #30 (permalink)  
Old 06-13-2009, 10:57 PM
mancow's Avatar
Member
  RadioReference Database Admininstrator
Database Admin
 
Join Date: Feb 2003
Location: N.E. Kansas
Posts: 5,521
Default

I am having problems with the choppy audio issue. The only way to get it to work is to use an old version I had on hand (1.7) as the server application.

Any ideas?
Reply With Quote
  #31 (permalink)  
Old 06-14-2009, 12:07 AM
ProScan's Avatar
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Jul 2006
Location: Ontario, Calif.
Posts: 2,823
Default

Your talking about Remote Scanner Over IP which I'll put the method from 2.0 back in. That's entirely different then the Web Server and ScanCast.

Quote:
Originally Posted by mancow View Post
I am having problems with the choppy audio issue. The only way to get it to work is to use an old version I had on hand (1.7) as the server application.

Any ideas?
__________________
Most Popular & Feature-Rich Scanner Software For The Uniden's
ProScan - RadioFeed Home Page
bob@proscan.org

Last edited by ProScan; 06-14-2009 at 1:07 AM..
Reply With Quote
  #32 (permalink)  
Old 06-14-2009, 7:49 AM
Member
  Premium Subscriber
Premium Subscriber
Amateur Radio Operator
Amateur Radio
 
Join Date: Dec 2002
Posts: 778
Default

I've got this working now with Scanamerica along with text tags. Thanks for a great update. Now I can go back to running Proscan and sending the feed to Scanamerica. I missed not being able to control the radio when I was at work.
Reply With Quote
  #33 (permalink)  
Old 06-14-2009, 11:20 AM
Member
  Premium Subscriber
Premium Subscriber
Amateur Radio Operator
Amateur Radio
 
Join Date: Dec 2002
Posts: 778
Default

I think I spoke too soon. I'm having problems with the Icecast feed to Scanamerica stopping. It's happened twice today, when I go into Proscan it shows as still running however I have to stop and restart to get the feed up again. Any thoughts?
Reply With Quote
  #34 (permalink)  
Old 06-14-2009, 11:53 AM
ProScan's Avatar
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Jul 2006
Location: Ontario, Calif.
Posts: 2,823
Default

Quote:
Originally Posted by kg4pbd View Post
I think I spoke too soon. I'm having problems with the Icecast feed to Scanamerica stopping. It's happened twice today, when I go into Proscan it shows as still running however I have to stop and restart to get the feed up again. Any thoughts?
I have to run some test to see if I can duplicate to problem and come up with a solution.
__________________
Most Popular & Feature-Rich Scanner Software For The Uniden's
ProScan - RadioFeed Home Page
bob@proscan.org
Reply With Quote
  #35 (permalink)  
Old 06-14-2009, 1:22 PM
Member
  Premium Subscriber
Premium Subscriber
Amateur Radio Operator
Amateur Radio
 
Join Date: Dec 2002
Posts: 778
Default

Thanks Bob, and ignore my last post over on the Scanamerica forum. I thought I had posted this issue there and when I didn't see it there.....I posted it again. Sorry about that.
Reply With Quote
  #36 (permalink)  
Old 06-14-2009, 2:35 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2003
Location: Earth Sector 001
Posts: 819
Default

Now is this the ultimate control/record and broadcast app.

I've been using Arc250 for my control and record and the monitor app for my tags for years. Now I got a all in one solution.

Stupid question. Can you import from rr.com database into proscan?


Also with the alpha tags. Can you omit the bank tag. I rather just the text tag or TG Name and not the bank tag.

Last edited by webstar22; 06-14-2009 at 2:38 PM..
Reply With Quote
  #37 (permalink)  
Old 06-14-2009, 3:05 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2003
Location: Earth Sector 001
Posts: 819
Default

Icecast auto reconnect. We just had a good t-storm go through my area and my DSL gets a little flakey during storm and I noticed ProScan wouldn't reconnect after it got disconnected until I manually did it. Anyway to get a auto reconnect build in?
Reply With Quote
  #38 (permalink)  
Old 06-14-2009, 4:14 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Dec 2003
Location: Earth Sector 001
Posts: 819
Default

Quote:
Originally Posted by kg4pbd View Post
I think I spoke too soon. I'm having problems with the Icecast feed to Scanamerica stopping. It's happened twice today, when I go into Proscan it shows as still running however I have to stop and restart to get the feed up again. Any thoughts?

I had this same thing happen with the incidentbroadcast icecast server a couple of mins ago.
Reply With Quote
  #39 (permalink)  
Old 06-15-2009, 11:03 AM
Member
  Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Feb 2008
Location: Somerville, NJ
Posts: 345
Default

Quote:
Originally Posted by ProScan View Post
100% Yes. Audio at input will stream and folders / files will be served.
Will ProScan ever have a GUI for GRE models like it does with the Unidens? i.e: Full support for a PSR-500 or 600? I wanna use ProScan, but I do not feel like buying a Uniden if I already have a GRE =P
Reply With Quote
  #40 (permalink)  
Old 06-15-2009, 3:54 PM
ProScan's Avatar
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Jul 2006
Location: Ontario, Calif.
Posts: 2,823
Default

Yes re-connect is high on my list

Quote:
Originally Posted by webstar22 View Post
Icecast auto reconnect. We just had a good t-storm go through my area and my DSL gets a little flakey during storm and I noticed ProScan wouldn't reconnect after it got disconnected until I manually did it. Anyway to get a auto reconnect build in?
__________________
Most Popular & Feature-Rich Scanner Software For The Uniden's
ProScan - RadioFeed Home Page
bob@proscan.org
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 12:20 PM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2015 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions