RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Computer Aided Monitoring and Programming > Streaming / Broadcasting / Audio Recording


Streaming / Broadcasting / Audio Recording - Interested in putting your scanner online for others to hear? Want to listen to other radios on the internet. This forum is here for you to discuss these topics related to streaming scanners online.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #41 (permalink)  
Old 08-01-2011, 11:07 PM
Member
   
Join Date: Aug 2006
Posts: 19
Default

I have tried both v41 and v42 and keep getting this error.

TwoToneDetect41.py:247: RuntimeWarning: divide by zero encountered in log10
Traceback (most recent call last):
File "<string>", line 476, in <module>
File "<string>", line 432, in start
File "<string>", line 247, in Atone1
OverflowError: cannot convert float infinity to integer

C:\TwoTone41>
Reply With Quote
Sponsored links
  #42 (permalink)  
Old 08-01-2011, 11:10 PM
Member
   
Join Date: Aug 2006
Posts: 19
Default

i've tried both v41 and v42 a keep getting the following error

TwoToneDetect41.py:247: RuntimeWarning: divide by zero encountered in log10
Traceback (most recent call last):
File "<string>", line 476, in <module>
File "<string>", line 432, in start
File "<string>", line 247, in Atone1
OverflowError: cannot convert float infinity to integer

C:\TwoTone41>
Reply With Quote
  #43 (permalink)  
Old 08-02-2011, 8:16 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Aug 2005
Posts: 1,058
Default

Quote:
Originally Posted by asmith136 View Post
i've tried both v41 and v42 a keep getting the following error

TwoToneDetect41.py:247: RuntimeWarning: divide by zero encountered in log10
Traceback (most recent call last):
File "<string>", line 476, in <module>
File "<string>", line 432, in start
File "<string>", line 247, in Atone1
OverflowError: cannot convert float infinity to integer

C:\TwoTone41>
Yep, that's the bug that I think I tried to quickly fix in v42. Even if v42 there's still a chance of still getting that error, but I'll fully address the problem in v43. It's an issue that will happen more on some sound cards than others.
Reply With Quote
  #44 (permalink)  
Old 08-02-2011, 9:02 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Aug 2005
Posts: 1,058
Default v43 Released

I just posted v43

Version 43 Release Notes:
- Math bug fix (infinity issue)
- Added GUI for config file editing

Let me know if this fixes the bug with v41 and v42.

Thanks,

Andy
Reply With Quote
  #45 (permalink)  
Old 08-03-2011, 1:26 AM
   
Join Date: Aug 2011
Posts: 1
Default No Email

In version 43 I don't seem to get any email. I worked great with version 40 but with version 43 I don't get any emails. I have checked and rechecked my user name and password.
Reply With Quote
Sponsored links
  #46 (permalink)  
Old 08-03-2011, 10:31 AM
Member
   
Join Date: Aug 2006
Posts: 19
Default

I've setup V43 and did some testing with my department tones and found that the tone detect is very wide. My first tone of 1450.0Hz gets detected from 1422.0Hz to 1477.0Hz. I setup the tone tolerance to 0% and still have the same problem.
Reply With Quote
  #47 (permalink)  
Old 08-03-2011, 11:24 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Aug 2005
Posts: 1,058
Default

Quote:
Originally Posted by asmith136 View Post
I've setup V43 and did some testing with my department tones and found that the tone detect is very wide. My first tone of 1450.0Hz gets detected from 1422.0Hz to 1477.0Hz. I setup the tone tolerance to 0% and still have the same problem.
You found a bug in the code that saves that parameter in the config file. I'll get it fixed in the next release. Until then, you can manually edit the config file to adjust the tolerance down.


Andy
Reply With Quote
  #48 (permalink)  
Old 08-03-2011, 12:05 PM
Member
   
Join Date: Aug 2006
Posts: 19
Default

I think I found another bug. I am using the same setting as v40 that worked fine in v43 I get this error
A Tone Found!
Checking for B Tone
Checking for B Tone
Tone Set Found!
Fire Department 1
????????????@vzwpix.com
delay timer
waiting for audio
recording audio
done writing WAV
LAME 3.98.4 32bits (www)
CPU features: MMX (ASM used), SSE (ASM used), SSE2
Using polyphase lowpass filter, transition band: 5379 Hz - 5513 Hz
Encoding ./audio/Fire_Department_1_2011-08-0311_58_18_796000.wav
to ./audio/Fire_Department_1_2011-08-0311_58_18_796000.mp3
Encoding as 11.025 kHz single-ch MPEG-2.5 Layer III (11x) 16 kbps qval=3
Frame | CPU time/estim | REAL time/estim | play/CPU | ETA
180/180 (100%)| 0:00/ 0:00| 0:00/ 0:00| 204.44x| 0:00
-------------------------------------------------------------------------------
kbps mono % long switch short %
16.0 100.0 96.7 2.2 1.1
ReplayGain: -6.8dB
done converting to MP3
Unhandled exception in thread started by <function alert at 0x014EE7F0>
Traceback (most recent call last):
File "<string>", line 241, in alert
File "<string>", line 150, in mail
File "E:\Python\build\pyi.win32\TwoToneDetect43\outPYZ1 .pyz/smtplib", line 604
, in login
smtplib.SMTPAuthenticationError: (535, '5.7.0 ...authentication rejected (2)')
Reply With Quote
  #49 (permalink)  
Old 08-03-2011, 12:14 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Aug 2005
Posts: 1,058
Default

Quote:
Originally Posted by asmith136 View Post
File "E:\Python\build\pyi.win32\TwoToneDetect43\outPYZ1 .pyz/smtplib", line 604
, in login
smtplib.SMTPAuthenticationError: (535, '5.7.0 ...authentication rejected (2)')
That means it couldn't log in to your SMTP server. Make sure your email settings (username, password, etc.) are correct. Note that when you enter your password in using the GUI it doesn't need to be encoded in base64, the program takes care of encoding it before writing it to the config file.

Andy
Reply With Quote
  #50 (permalink)  
Old 08-03-2011, 12:27 PM
Member
   
Join Date: Aug 2006
Posts: 19
Default

I got it. My error with the username
Reply With Quote
  #51 (permalink)  
Old 08-03-2011, 12:27 PM
Member
   
Join Date: Oct 2007
Posts: 5,230
Default

I'm having issues that I believe are related to the sound card I'm using. The program hangs or crashes whenever I try to select that sound card.

The sound card in question is a Creative Labs SB Live! Wave Device which relies on a background program devldr32.exe to function properly. I believe the conflict lies between TwoToneDetect and devldr32.exe.
Reply With Quote
  #52 (permalink)  
Old 08-03-2011, 3:24 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Aug 2009
Location: Chico, CA
Posts: 2
Default

One other thing to consider is that a number of fire agencies are trying to reduce overall radio traffic on impacted channels by cutting two-tone times in half. In our county, Cal-Fire has cut the normal 1 second by 3 second two-tone series to something like .5 seconds by 1.5 seconds. I've heard of other agencies following suit.

Mike
Reply With Quote
  #53 (permalink)  
Old 08-03-2011, 4:05 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Oct 2003
Location: Westminster, Ma
Posts: 104
Default

Is there a new py file for version 43? I copied the one from version 40 and can not get it to work.

I have the same error message about not being able to access the smtp server.
__________________
John
www.scannorthcounty.net
Reply With Quote
  #54 (permalink)  
Old 08-03-2011, 4:23 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Aug 2005
Posts: 1,058
Default

Quote:
Originally Posted by johnmac View Post
Is there a new py file for version 43? I copied the one from version 40 and can not get it to work.

I have the same error message about not being able to access the smtp server.
The .py file is the raw source code, it's not needed to run the program. I've just been including it in the package for those who want to look at the source. You've just reminded me that I forgot to include it with v43.

Have you tried a gmail account for sending? I think your issue may be ISP-specific, but I'm not positive. I have an idea for a fix, but it's lower on the list for now.

Andy
Reply With Quote
  #55 (permalink)  
Old 08-03-2011, 4:35 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Aug 2005
Posts: 1,058
Default

Quote:
Originally Posted by Buttescan View Post
One other thing to consider is that a number of fire agencies are trying to reduce overall radio traffic on impacted channels by cutting two-tone times in half. In our county, Cal-Fire has cut the normal 1 second by 3 second two-tone series to something like .5 seconds by 1.5 seconds. I've heard of other agencies following suit.

Mike
That's something that could be addressed, but for now the algorithm is just targeting the standard QuickCall2 timing. The program should still be able to detect the timing you describe. The algorithm "as is" needs to see the A tone for .4 seconds, and then the B tone for .4 seconds within 4 seconds of the A tone being detected.

Places that cut the tone times down do so with the tradeoff of decreased alerting reliability/range. If the transmitter coverage is good enough, that may not be an issue for them.

In software, the tradeoff of a quicker detection time is a smaller FFT size, which results in less frequency resolution and therefore a wider tone tolerance.

Andy
Reply With Quote
  #56 (permalink)  
Old 08-03-2011, 9:24 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Aug 2005
Posts: 1,058
Default v44 Released

I just posted v44, which is just bug fix related to saving the tone tolerance parameter to the config file.

Andy
Reply With Quote
  #57 (permalink)  
Old 08-03-2011, 9:44 PM
Member
   
Join Date: Aug 2006
Posts: 19
Default

did you ever get a to put a list together on what modules are needed to build an exe?
Reply With Quote
  #58 (permalink)  
Old 08-03-2011, 10:28 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Aug 2005
Posts: 1,058
Default

Quote:
Originally Posted by asmith136 View Post
did you ever get a to put a list together on what modules are needed to build an exe?
Here are the "extra" modules I've installed:

Tkinter (this is packaged with Python)
ttk (this is usually packaged with Tkinter on newer Python releases)
pyaudio
pyinstaller
numpy
scipy
iniparse

Here's the script I use to build the EXE using pyinstaller:

c:\Python27\Pyinstaller\Makespec.py --onefile --tk e:\python\TwoToneDetect44.py
c:\Python27\Pyinstaller\Build.py TwoToneDetect44.spec

I hope that helps...if you make any improvements you think are worth sharing and want to get set up as a developer on SourceForge, let me know.

Andy
Reply With Quote
  #59 (permalink)  
Old 08-04-2011, 11:37 AM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Oct 2003
Location: Westminster, Ma
Posts: 104
Default

[QUOTE=Have you tried a gmail account for sending? I think your issue may be ISP-specific, but I'm not positive. I have an idea for a fix, but it's lower on the list for now.

Andy[/QUOTE]

I have previously had version 40 running fine.No crashes or anything. I will do some more experimenting today. My ISP is Comcast. Also working fine on the old version, just need to reboot the computer every few days so it does not crash.Some of this may be a problem with my computer, as I can no longer get version 40 to load. The old version is running on a different computer.

John
__________________
John
www.scannorthcounty.net
Reply With Quote
  #60 (permalink)  
Old 08-04-2011, 12:33 PM
Member
   
Join Date: Aug 2006
Posts: 19
Default

I’m not looking to be a developer. I am just learning Python. This is something I always wanted to learn but never did. Your program makes it more interesting to learn. 1 of the things I would like to change is stereo record instead of mono but I can’t get the exe build I did to work. Is that something easy you can change and post?
Reply With Quote
Reply

Tags
twotonedetect

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 6:39 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2015 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions