RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Computer Aided Monitoring and Programming > Streaming / Broadcasting / Audio Recording


Streaming / Broadcasting / Audio Recording - Interested in putting your scanner online for others to hear? Want to listen to other radios on the internet. This forum is here for you to discuss these topics related to streaming scanners online.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #801 (permalink)  
Old 08-31-2012, 4:58 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 974
Default

The bcc option was added in v55. If you are running an older version of TTD you won't have it. See the release notes fior v55 in the readme file for additional information.
Reply With Quote
Sponsored links
  #802 (permalink)  
Old 09-01-2012, 9:40 PM
Member
   
Join Date: Jan 2007
Posts: 9
Default WAV support

I have a few guys that have the shiny fancy new iPhone which conveniently doesn't support .amr files. They are also on AT&T which won't allow .mp3's to be sent in an mms.. Is there any way you can add support for the .wav format to this version? I know it seems old fashion, but that's the only way it will work for them..
Reply With Quote
  #803 (permalink)  
Old 09-02-2012, 6:23 AM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 974
Default

I also have the shiny new version (4s). It works flawlessly with all amr and mp3 attachments. Your users who are having trouble may need to contact ATT to provision their acct properly.

iOS: Troubleshooting Messages
Reply With Quote
  #804 (permalink)  
Old 09-03-2012, 11:13 PM
Member
   
Join Date: Jan 2007
Posts: 9
Default

Quote:
Originally Posted by DC31 View Post
I also have the shiny new version (4s). It works flawlessly with all amr and mp3 attachments. Your users who are having trouble may need to contact ATT to provision their acct properly.

iOS: Troubleshooting Messages
I was misinformed by them apparently. I'll let them know to get everything set straight so I can finally make the switch over to 56. Thank you!
Reply With Quote
  #805 (permalink)  
Old 09-04-2012, 9:50 PM
iamhere300's Avatar
Member
  Amateur Radio Operator
Amateur Radio
 
Join Date: Jun 2004
Location: Chappell Hill TX
Posts: 1,292
Default

Quote:
Originally Posted by DC31 View Post
The bcc option was added in v55. If you are running an older version of TTD you won't have it. See the release notes fior v55 in the readme file for additional information.
Thanks. I went to 56, and there it was. Seems to work fine.

I guess I need to keep track of updates better!
Reply With Quote
Sponsored links
  #806 (permalink)  
Old 09-07-2012, 10:47 PM
Member
   
Join Date: Jan 2007
Posts: 9
Default

I guess you should be careful for what you ask for.. I'm not sure how or what is happening, but with my address under the "mp3_Emails" I am receiving a .wav file instead of an .mp3 file.. Any ideas?

EDIT: Never mind.. Created a second copy for another radio and forgot to drop in the ffmpeg in the folder.

Last edited by ziesenis; 09-07-2012 at 10:54 PM..
Reply With Quote
  #807 (permalink)  
Old 09-09-2012, 10:28 AM
dlnorth's Avatar
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Apr 2004
Posts: 79
Default Need for multiple sound cards?

I'm using my one and only sound card to run a live feed from my scanner. Will TTD require a 2nd sound card or a separate PC to run properly or can I use the sound card that is already being used for the live feed?

Thanks
Reply With Quote
  #808 (permalink)  
Old 09-09-2012, 11:51 AM
   
Join Date: Sep 2012
Posts: 1
Default Target Machine Actively Refused error

I have the latest software and the latest FFMPEG file. The software is able to find my tones and start recording but I get an error message, which I will post below. I am sending through gmail on port 587. Any suggetions? Thanks


A Tone Found! 17:45:01
Checking for B Tone 17:45:01
Checking for B Tone2 17:45:05
Tone Set Found! 17:45:05
Staunton Fire 17:45:05
6185304084@mms.att.net
;Email addresses to send AMR attachment to. Separate with commas
delay timer 17:45:05
waiting for audio 17:45:08
recording audio 17:45:09
done writing WAV 17:45:46
ffmpeg version N-43804-g780bf75 Copyright (c) 2000-2012 the FFmpeg developers
built on Aug 21 2012 21:11:37 with gcc 4.7.1 (GCC)
configuration: --enable-gpl --enable-version3 --disable-pthreads --enable-runt
ime-cpudetect --enable-avisynth --enable-bzlib --enable-frei0r --enable-libass -
-enable-libcelt --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-l
ibfreetype --enable-libgsm --enable-libmp3lame --enable-libnut --enable-libopenj
peg --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheo
ra --enable-libutvideo --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-li
bvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --ena
ble-zlib
libavutil 51. 70.100 / 51. 70.100
libavcodec 54. 54.100 / 54. 54.100
libavformat 54. 25.104 / 54. 25.104
libavdevice 54. 2.100 / 54. 2.100
libavfilter 3. 13.100 / 3. 13.100
libswscale 2. 1.101 / 2. 1.101
libswresample 0. 15.100 / 0. 15.100
libpostproc 52. 0.100 / 52. 0.100
[wav @ 01ebc400] max_analyze_duration 5000000 reached at 5015510
Guessed Channel Layout for Input Stream #0.0 : stereo
Input #0, wav, from './audio/Staunton_Fire_2012-09-0817_45_46_361000.wav':
Duration: 00:00:37.15, bitrate: 352 kb/s
Stream #0:0: Audio: pcm_s16le ([1][0][0][0] / 0x0001), 11025 Hz, stereo, s16
, 352 kb/s
Output #0, mp3, to './audio/Staunton_Fire_2012-09-0817_45_46_361000.mp3':
Metadata:
TSSE : Lavf54.25.104
Stream #0:0: Audio: mp3, 11025 Hz, stereo, s16, 32 kb/s
Stream mapping:
Stream #0:0 -> #0:0 (pcm_s16le -> libmp3lame)
Press [q] to stop, [?] for help
size= 146kB time=00:00:37.20 bitrate= 32.1kbits/s
video:0kB audio:146kB subtitle:0 global headers:0kB muxing overhead 0.162857%
done converting to MP3 17:45:47
Unhandled exception in thread started by <function alert at 0x030899B0>
Traceback (most recent call last):
File "<string>", line 482, in alert
File "<string>", line 316, in mail
File "D:\Python\build\pyi.win32\TwoToneDetect56_debug\o utPYZ1.pyz/smtplib", li
ne 242, in __init__
File "D:\Python\build\pyi.win32\TwoToneDetect56_debug\o utPYZ1.pyz/smtplib", li
ne 302, in connect
File "D:\Python\build\pyi.win32\TwoToneDetect56_debug\o utPYZ1.pyz/smtplib", li
ne 277, in _get_socket
File "D:\Python\build\pyi.win32\TwoToneDetect56_debug\o utPYZ1.pyz/socket", lin
e 571, in create_connection
socket.error: [Errno 10061] No connection could be made because the target machi
ne actively refused it
Reply With Quote
  #809 (permalink)  
Old 09-09-2012, 10:02 PM
MikeOxlong's Avatar
Forums Manager/Global DB Admin/Commie
  RadioReference Database Admininstrator
Database Admin
 
Join Date: Jun 2001
Location: Central Ontario
Posts: 10,228
Default

I'm having a problem every time I enable scanner control. I tend to miss pages entirely and sometimes I end up with a misidentified page.

Would it be possible to add a parameter that specifies the amount of time the scanner will sit on a channel looking at the audio before deciding it's not the A or long B tone and rescanning?

I'm hoping to be able to watch the scanner and program tomorrow during the test pages to determine what's happening.

I'm running v56 and just reenabled scanning control after reading this version contained some improvements to the scanner control routines.
__________________
Mike.

Sorry but I don't accept PM's. Please use email instead.
Reply With Quote
  #810 (permalink)  
Old 09-10-2012, 5:28 AM
krokus's Avatar
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Jun 2006
Location: Southeastern Michigan
Posts: 3,407
Default

Quote:
Originally Posted by dlnorth View Post
I'm using my one and only sound card to run a live feed from my scanner. Will TTD require a 2nd sound card or a separate PC to run properly or can I use the sound card that is already being used for the live feed?

Thanks
Using the program 'Virtual Audio Cable" should handle this patching for you.
__________________
Generic radio geek, in southeast Michigan.
PSR-500, TM-742, TM-V71,TH-78, HTX-420, IC-2AT, IC-2E (clone), Pro-39, BC-235XLT, TK-290, XTS-5000
Reply With Quote
  #811 (permalink)  
Old 09-10-2012, 11:15 AM
wizard of odd
  RadioReference Database Admininstrator
Database Admin
 
Join Date: May 2004
Location: Michigan
Posts: 564
Default

Quote:
Originally Posted by dlnorth View Post
I'm using my one and only sound card to run a live feed from my scanner. Will TTD require a 2nd sound card or a separate PC to run properly or can I use the sound card that is already being used for the live feed?

Thanks
I run a feed and TTD on the same sound card. Works fine.
Reply With Quote
  #812 (permalink)  
Old 09-10-2012, 11:19 PM
Member
  Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Dec 2006
Location: Coshocton, OH
Posts: 5
Default Auto Forward

I setup TTD for members of my department and now neighboring departments have asked me to send their pages out too. Wondering if anyone knows of a good way for me to send the pages to one email address, then the other department go to a website that they can manage their members and that auto forwards the page to their members. Does anyone know of good website that offers this service for preferably free? Trying to make it easier to manage the address list by make one person at each department responsible for updating their own addresses. Thanks for the great program!

Brent
Reply With Quote
  #813 (permalink)  
Old 09-11-2012, 10:18 PM
   
Join Date: Sep 2012
Posts: 1
Default Trouble

Maybe someone can help. I tried about 6 months ago the new python version. The issue is that the program always recognizes the tones and starts recording however at least half the time the file is all static both mp3 and amr. I know it is a clean signal and I also tried the latest version with the same problem. Now the original labview version works fine although does lockup at times.
Reply With Quote
  #814 (permalink)  
Old 09-13-2012, 12:55 PM
Member
   
Join Date: Feb 2010
Location: Port Orchard, WA
Posts: 73
Default Output Variables

Andy,
In Labview version you had a few output variables ([p] and [d]). Do you have a list of variables that are present in the most current version (56)?

Thanks!
Reply With Quote
  #815 (permalink)  
Old 09-14-2012, 10:07 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Aug 2005
Posts: 1,090
Default

Quote:
Originally Posted by bdelisa View Post
Maybe someone can help. I tried about 6 months ago the new python version. The issue is that the program always recognizes the tones and starts recording however at least half the time the file is all static both mp3 and amr. I know it is a clean signal and I also tried the latest version with the same problem. Now the original labview version works fine although does lockup at times.
I've had that problem with some built-in sound cards on Dell computers. I have not been able to get those things to work well. Using a different sound card solved the problem.

Andy
Reply With Quote
  #816 (permalink)  
Old 09-14-2012, 10:11 AM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Aug 2005
Posts: 1,090
Default

Quote:
Originally Posted by kenmaples View Post
Andy,
In Labview version you had a few output variables ([p] and [d]). Do you have a list of variables that are present in the most current version (56)?

Thanks!
I'd actually completely forgotten about that feature in the old version. There isn't currently anything like that in the Python versions. It could probably be done, any requests for specific info to make available?

Andy
Reply With Quote
  #817 (permalink)  
Old 09-14-2012, 11:21 AM
Member
   
Join Date: Feb 2010
Location: Port Orchard, WA
Posts: 73
Default

Quote:
Originally Posted by aaknitt View Post
I'd actually completely forgotten about that feature in the old version. There isn't currently anything like that in the Python versions. It could probably be done, any requests for specific info to make available?

Andy
I am playing with push notifications using an alert_command script. I think it would be nice to be able to pass the variables for Description and Alert Time (shows in the debug log as "Tone Set Found! %TIME% or %DESCRIPTION% %TIME%). It would also be nice to get the file path after the audio conversion was complete, understanding that it would not be available to use for alert_command, but potentially as a follow up for post_email_command.

I do have a current workaround to this as I can still grab current system time (only a few seconds off), and can create multiple copies of the script to identify the unit toned.

Thank you!
Reply With Quote
  #818 (permalink)  
Old 09-15-2012, 1:11 AM
BlueDevil's Avatar
Member
  Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: May 2010
Location: WA
Posts: 693
Default Double Pages

I am having an issues with the program sending out double pages for some sets of tones. It seems to be consistent to the same sets of tones. I have double checked the tones file and there is no duplication of addresses. Any suggestions?
Reply With Quote
  #819 (permalink)  
Old 09-17-2012, 2:50 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Aug 2005
Posts: 1,090
Default

Quote:
Originally Posted by brandonmckinney View Post
I am having an issues with the program sending out double pages for some sets of tones. It seems to be consistent to the same sets of tones. I have double checked the tones file and there is no duplication of addresses. Any suggestions?
What version of the program are you using and what are the settings in the tones.cfg file for the problematic tone sets?

Andy
Reply With Quote
  #820 (permalink)  
Old 09-18-2012, 12:19 AM
BlueDevil's Avatar
Member
  Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: May 2010
Location: WA
Posts: 693
Default

I figured out what happened. I had previously downloaded the program to work on another computer and event installed it in the start up menu. That particular computer runs a weather station and runs 24/7. I had exited the program and decided to run it on a different computer that got better radio reception. Well when the old computer restarted it launched the Two Tone Detect and I was receiving dual pages. Kinda embarrassing. Should have assumed user error! Thanks for the helps!

Brandn
__________________
Cheers,

Brandon
Reply With Quote
Reply

Tags
twotonedetect

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:59 PM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2015 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions