RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Computer Aided Monitoring and Programming > Streaming / Broadcasting / Audio Recording


Streaming / Broadcasting / Audio Recording - Interested in putting your scanner online for others to hear? Want to listen to other radios on the internet. This forum is here for you to discuss these topics related to streaming scanners online.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 11-29-2016, 7:43 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 828
Default Streaming with Raspberry Pi3 using Darkice/Darksnow

Since the Pi3 was introduced over a year ago, setting up a reliable audio streamer using it has been challenging. Most of the instructions were based on the previous versions of the Pi and the earlier Raspbian OS.

Darksnow is a graphical user interface (gui) for the darkice streaming program. Others had reported problems making it work on a RPi and likewise I couldn't get it working when I first tried using it. That was unfortunate as many people dislike working at the command line and using text editors that are not intuitive. The problem I discovered is that the package managers included with Raspbian retrieve the 0.6 version of Darksnow rather than the 0.7.1 version. The 0.6 version does not work.

The newest release of Rasbian Jessie (PIXEL) has many improvements including a much shinier desktop that is much more responsive. The most recent release is available at the downloads section of raspberrrypi.org.

Here are the steps to make it work:

Darkice/darksnow on Raspberry Pi3



Image an SD card with the most current version of Raspbian Jessie (the full version, not lite)



Insert card into pi3 with keyboard/mouse, usb sound card, ethernet, and hdmi monitor connected.



Turn on monitor to hdmi input and power up pi.



Click on raspberry in upper left of menu bar. Choose Preferences/Raspberry Pi Configuration. In the first tab, enable vnc. In the second tab, optionally change hostname to darksnow. In the localization tab, set all your local information. Close the configuration windows. You do not need to reboot at this time.



Open the chromium web browser. Navigate to darksnow.radiolivre.org. (A Portuguese language version opens by default. Click Nope in the translation box and a link to the English version is behind it.) In the download source section click 0.7.1 to start the download. This only takes a few seconds, then close the web browser.



Open a Terminal window using the Terminal icon in the menu bar. At the command prompt ($), make the following entries:



$ sudo apt-get update

(Takes about a minute)



$ sudo apt-get install gtk+2.0

(Takes about 5 min)

$ sudo apt-get install darkice



$ cd Downloads

$ tar -zxvf darksnow-0.7.1.tar.gz

$ cd darksnow-0.7.1

$ ./configure --prefix=/usr

$ make

$ sudo make install

$ sudo reboot



This will reboot your pi. After it reboots and returns to the Pixel desktop,open a Terminal window. At the prompt:



$ darksnow



This will launch a window where you enter your broadcastify information in the server tab. In the audio settings tab use:
mp3
constant
16
22050
0.1
16
1-mono
10
hw;1,0.

Then File/Save Configuration




Then start your stream using the start button at the bottom of the page.





If you want to use wifi it can be enabled from the icon in the upper right.



If you want to work headless and connect through VNC you can connect to the pi at darksnow.local::5900 from another computer on the same network as the pi. This assumes that you changed the hostname to darksnow near the beginning of these instructions.


Try this out and let us know if it works!
Attached Files
File Type: txt pi3_darksnow.txt (2.0 KB, 99 views)
Reply With Quote
Sponsored links
  #2 (permalink)  
Old 11-29-2016, 9:14 PM
ffryan76's Avatar
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Nov 2004
Location: South central, In
Posts: 159
Default

Thanks for all the info you post Jim. It is very helpful.

Sent from my SM-T550 using Tapatalk
Reply With Quote
  #3 (permalink)  
Old 12-03-2016, 3:59 PM
Member
   
Join Date: Mar 2010
Posts: 5
Default

I've stumped across this post as I too was stuck.
Thanks for the tips, I'll go and check it out now.....
Reply With Quote
  #4 (permalink)  
Old 12-27-2016, 11:30 PM
Member
  Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Sep 2009
Location: Lompoc, Santa Barbara County, CA
Posts: 14
Default RPi-3 Feed

Looking for help setting up the DarkSnow Server Options and Streaming Description tabs. Myold feed used ProScan.
Any hope of displaying MetaData (channel ID) tags?

Thank you!

Last edited by K7AZ; 12-27-2016 at 11:35 PM..
Reply With Quote
  #5 (permalink)  
Old 01-29-2017, 8:06 PM
Newbie
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Nov 2015
Location: Falmouth, Maine
Posts: 2
Default PI 3 Darksnow/Darkice working

Quote:
Originally Posted by DC31 View Post
Since the Pi3 was introduced over a year ago, setting up a reliable audio streamer using it has been challenging.
DC31, thanks for the input on the programming for the Pi3. All very helpful. I was able to get the noobs jessie build to work with your instructions above (and reading your other posts).

I had several problems with the audio input. I did change the sample rate to 44100 and had to adjust the capture level/scanner output.

Do you have any direction on getting alpha tags to work with darkice?
I tried adding auto start originally but it didn't work. Have you had success with a Pi3 darkice running on startup?

I'm running a BCT-15x with a Pi3 and I am using the GUI now but started with putty headless. It's going to be nice to shut my tower down without loosing the feed.
Reply With Quote
Sponsored links
  #6 (permalink)  
Old 01-29-2017, 9:01 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 828
Default

[QUOTE=Fillup502;2707437

Do you have any direction on getting alpha tags to work with darkice?
I tried adding auto start originally but it didn't work. Have you had success with a Pi3 darkice running on startup?

[/QUOTE]
I don't have any experience myself running alpha tags. I know that it can be done from the pi with a separate program. That program works only with one brand of scanners and right now i can't think which. The instructions for it are in these forums somewhere. If i find it I will edit this post.

I start my darkice feeds on boot using a line in the crontab file. However, i am not running the darksnow GUI. I am not sure how autostart would work with darksnow. I have found darkice to run very reliably on my pi's with the only interruptions due to power failure. With bcfy set up to text me when my feed goes down i think that the downtime in the rare instance of a power failure until i could restart darksnow manually would be tolerable.

Jim

Edit: uniden scanners. Here is the thread: http://forums.radioreference.com/str...ml#post1986345

Last edited by DC31; 01-29-2017 at 9:07 PM..
Reply With Quote
  #7 (permalink)  
Old 02-12-2017, 11:29 PM
Member
   
Join Date: Oct 2014
Location: NKY
Posts: 5
Default Audio Delay/Slowed Down.

This tutorial was a godsend, I almost gave up, because my Pi 3 wasn't holding a connection after reboot. I have this working and have copied the the directions to a T however, I have noticed upon playback through Broadcastify, the audio is extremely delayed and the audio has been extremely slowed down. It is as if you are playing a video at .25% of the normal speed and everything sounds super slowed down. Please help!
Reply With Quote
  #8 (permalink)  
Old 02-12-2017, 11:59 PM
Member
   
Join Date: Oct 2014
Location: NKY
Posts: 5
Default

Quote:
Originally Posted by boonebroadcaster View Post
This tutorial was a godsend, I almost gave up, because my Pi 3 wasn't holding a connection after reboot. I have this working and have copied the the directions to a T however, I have noticed upon playback through Broadcastify, the audio is extremely delayed and the audio has been extremely slowed down. It is as if you are playing a video at .25% of the normal speed and everything sounds super slowed down. Please help!
To add to this, I am using ICECAST 2, if I attempt to use ICECAST 1, I simply get errors and won't start the feed. I have completely redone the preferences and saved to a new file without any luck. The audio still sounds extremely slowed down. Thanks!
Reply With Quote
  #9 (permalink)  
Old 02-13-2017, 4:16 AM
Newbie
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Nov 2015
Location: Falmouth, Maine
Posts: 2
Default

Quote:
Originally Posted by boonebroadcaster View Post
To add to this, I am using ICECAST 2, if I attempt to use ICECAST 1, I simply get errors and won't start the feed. I have completely redone the preferences and saved to a new file without any luck. The audio still sounds extremely slowed down. Thanks!
You may want to try adjusting the sample rate to 44100. This worked for me. I am using ICECAST 2.

Last edited by Fillup502; 02-13-2017 at 4:26 AM..
Reply With Quote
  #10 (permalink)  
Old 02-13-2017, 8:40 AM
Member
   
Join Date: Oct 2014
Location: NKY
Posts: 5
Default

Thank you for your response. I have adjusted the sample rate to 44100 as I saw that it has fixed others in the past without any luck. I have also removed the keyboard/mouse usb dongle from the usb bus as I read that may cause the issue, still without any success. I am running this Pi headless and adjusting using VNC.
Reply With Quote
  #11 (permalink)  
Old 05-21-2017, 9:42 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2006
Location: Atlanta, Ga
Posts: 24
Default

Is this expected to work on a Pi2 and not a 3? I dont have my Gen 3 Pi's at the house. My audio is all buzzing off the stream. I had to connect it back to windows to keep the feed active.
Reply With Quote
  #12 (permalink)  
Old 05-22-2017, 6:43 AM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 828
Default

Quote:
Originally Posted by scary812 View Post
Is this expected to work on a Pi2 and not a 3? I dont have my Gen 3 Pi's at the house. My audio is all buzzing off the stream. I had to connect it back to windows to keep the feed active.
All testing was done on a pi3. As long as you are running Jessie with the PIXEL desktop on your pi2, i think it would work. It might slow down browser response, but i don't think would cause audio issues. Based on some of the other comments above you may need to experiment with sample rate and radio output volume.
Reply With Quote
  #13 (permalink)  
Old 06-08-2017, 8:32 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2006
Location: Atlanta, Ga
Posts: 24
Default

Quote:
Originally Posted by DC31 View Post
Since the Pi3 was introduced over a year ago, setting up a reliable audio streamer using it has been challenging. Most of the instructions were based on the previous versions of the Pi and the earlier Raspbian OS.

Darksnow is a graphical user interface (gui) for the darkice streaming program. Others had reported problems making it work on a RPi and likewise I couldn't get it working when I first tried using it. That was unfortunate as many people dislike working at the command line and using text editors that are not intuitive. The problem I discovered is that the package managers included with Raspbian retrieve the 0.6 version of Darksnow rather than the 0.7.1 version. The 0.6 version does not work.

The newest release of Rasbian Jessie (PIXEL) has many improvements including a much shinier desktop that is much more responsive. The most recent release is available at the downloads section of raspberrrypi.org.

Here are the steps to make it work:

Darkice/darksnow on Raspberry Pi3



Image an SD card with the most current version of Raspbian Jessie (the full version, not lite)



Insert card into pi3 with keyboard/mouse, usb sound card, ethernet, and hdmi monitor connected.



Turn on monitor to hdmi input and power up pi.



Click on raspberry in upper left of menu bar. Choose Preferences/Raspberry Pi Configuration. In the first tab, enable vnc. In the second tab, optionally change hostname to darksnow. In the localization tab, set all your local information. Close the configuration windows. You do not need to reboot at this time.



Open the chromium web browser. Navigate to darksnow.radiolivre.org. (A Portuguese language version opens by default. Click Nope in the translation box and a link to the English version is behind it.) In the download source section click 0.7.1 to start the download. This only takes a few seconds, then close the web browser.



Open a Terminal window using the Terminal icon in the menu bar. At the command prompt ($), make the following entries:



$ sudo apt-get update

(Takes about a minute)



$ sudo apt-get install gtk+2.0

(Takes about 5 min)

$ sudo apt-get install darkice



$ cd Downloads

$ tar -zxvf darksnow-0.7.1.tar.gz

$ cd darksnow-0.7.1

$ ./configure --prefix=/usr

$ make

$ sudo make install

$ sudo reboot



This will reboot your pi. After it reboots and returns to the Pixel desktop,open a Terminal window. At the prompt:



$ darksnow



This will launch a window where you enter your broadcastify information in the server tab. In the audio settings tab use:
mp3
constant
16
22050
0.1
16
1-mono
10
hw;1,0.

Then File/Save Configuration




Then start your stream using the start button at the bottom of the page.





If you want to use wifi it can be enabled from the icon in the upper right.



If you want to work headless and connect through VNC you can connect to the pi at darksnow.local::5900 from another computer on the same network as the pi. This assumes that you changed the hostname to darksnow near the beginning of these instructions.


Try this out and let us know if it works!

I still cannot get this to work. I re imaged the CD card.

The audio sucks and is slowed down, even after adjusting the sample rate.

Last edited by scary812; 06-08-2017 at 9:44 PM..
Reply With Quote
  #14 (permalink)  
Old 06-08-2017, 9:43 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2006
Location: Atlanta, Ga
Posts: 24
Angry

Quote:
Originally Posted by boonebroadcaster View Post
Thank you for your response. I have adjusted the sample rate to 44100 as I saw that it has fixed others in the past without any luck. I have also removed the keyboard/mouse usb dongle from the usb bus as I read that may cause the issue, still without any success. I am running this Pi headless and adjusting using VNC.
I did the same even reimaged and started over and no luck its just not working. have you been able to get this resolved?
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 7:20 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2015 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions