RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Computer Aided Monitoring and Programming > Streaming / Broadcasting / Audio Recording


Streaming / Broadcasting / Audio Recording - Interested in putting your scanner online for others to hear? Want to listen to other radios on the internet. This forum is here for you to discuss these topics related to streaming scanners online.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 09-13-2017, 7:07 PM
Member
  Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Jun 2014
Location: Huntsville
Posts: 10
Default Darkice on the Two Tone Detect RPi Image

Hey all,

I'm getting an error message after many times of trying to set up Darkice on the Raspberry Pi TTD image. I also do intend to use TTD along side Darkice for my stream. I had it up and going over the summer, but I took it down for some reason or another. There error message I was getting was-

DarkIce.cpp:1187: can't open connector [0]

Now, solutions to this problem have been posted all over the internet, like making my sound card Default, Pulse, pulsehw:1,0 , hw:1,0...etc.

I've done it all and I can't seem to get it to work. Any help would be appreciated. And in addition, I can change other settings and really get a mess going of the error messages.
Reply With Quote
Sponsored links
  #2 (permalink)  
Old 09-14-2017, 4:15 AM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 809
Default

Quote:
Originally Posted by K5DVT View Post
Hey all,

I'm getting an error message after many times of trying to set up Darkice on the Raspberry Pi TTD image. I also do intend to use TTD along side Darkice for my stream. I had it up and going over the summer, but I took it down for some reason or another. There error message I was getting was-

DarkIce.cpp:1187: can't open connector [0]

Now, solutions to this problem have been posted all over the internet, like making my sound card Default, Pulse, pulsehw:1,0 , hw:1,0...etc.

I've done it all and I can't seem to get it to work. Any help would be appreciated. And in addition, I can change other settings and really get a mess going of the error messages.
Not sure if this will help, but here is my darkice.cfg file from a pi running both TTD and darkice:

#this section describes general aspects of the live streaming session
[general]
duration = 0 # duration of encoding, in seconds. 0 means forever
bufferSecs = 5 # size of internal slip buffer, in seconds
reconnect = yes # reconnect to the server(s) if disconnected

# this section describes the audio input that will be streamed
[input]
device = pulse # OSS DSP soundcard device for the audio input
sampleRate = 11025 # sample rate in Hz. try 11025, 22050 or 44100
bitsPerSample = 16 # bits per sample. try 16
channel = 1 # channels. 1 = mono, 2 = stereo

# this section describes a streaming connection to an IceCast2 server
# there may be up to 8 of these sections, named [icecast2-0] ... [icecast2-7]
# these can be mixed with [icecast-x] and [shoutcast-x] sections
[icecast2-0]
bitrateMode = cbr # constant bit rate
bitrate = 16
format = mp3 # format of the stream: mp3
quality = .1 # quality of the stream sent to the server
lowpass = 2000 # low pass filter to save bandwidth
server = audio1.broadcastify.com # host name of the server
port = 80 # 8000 port of the IceCast2 server, usually 8000
password = 987654321 # source password to the IceCast2 server
mountPoint = 12345678 # mount point of this stream on the IceCast2 server
name = Fire # name of the stream
description = Fire Dispatch # description of the stream
url = RadioReference.com - Scanner Frequencies and Radio Frequency Reference # URL related to the stream
genre = Public Safety # genre of the stream
public = yes # advertise

A common mistake is to include the / preceding the mount point.

Since TTD requires pulseaudio, I think that you will need to use pulse as your device. Without TTD you can use hw: or plughw:
Reply With Quote
  #3 (permalink)  
Old 09-14-2017, 4:25 AM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 809
Default

Try device = pulse with the lower-case p.

I tried mine with Pulse and get the can't open connector error.
Reply With Quote
  #4 (permalink)  
Old 09-16-2017, 2:58 PM
Member
  Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Jun 2014
Location: Huntsville
Posts: 10
Default

Here's the error I get ( now that I got some time to work on it this weekend). I set everything up as according to the details from Broadcastify.

DarkIce 1.0 live audio streamer, Google Code Archive - Long-term storage for Google Code Project Hosting.
Copyright (c) 2000-2007, Tyrell Hungary, Tyrell Hungary Corporation
Copyright (c) 2008-2010, Akos Maroy and Rafael Diniz
This is free software, and you are welcome to redistribute it
under the terms of The GNU General Public License version 3 or
any later version.

Using config file: /etc/darkice.cfg
Using ALSA DSP input device: pulse
Using POSIX real-time scheduling, priority 98
ALSA lib pulse.c:243pulse_connect) PulseAudio: Unable to connect: Connection re fused

DarkIce: DarkIce.cpp:1187: can't open connector [0]
pi@twotonedetectv67 ~ $


I am getting TTD to work just fine, audio tone detection and everything. You can see i'm using the pulse device.
Reply With Quote
  #5 (permalink)  
Old 09-16-2017, 9:02 PM
Member
  Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Jun 2014
Location: Huntsville
Posts: 10
Default

I've reburned the OS on a SD card, set up TTD ( which is working just fine) but I still get the error. In a attached screen shot, I tried running it from inside VNC instead of SSHing into the pi, and got a different message, which maybe will reveal something.
Attached Images
 
Reply With Quote
Sponsored links
  #6 (permalink)  
Old 09-17-2017, 12:02 PM
Member
  Audio Feed Provider
Audio Feed Provider
Amateur Radio Operator
Amateur Radio
 
Join Date: Jun 2014
Location: Huntsville
Posts: 10
Default

Well, last night at 3:01am I received an email saying that the feed went back online. It rebooted at 2:58 or so, I think perhaps the issue here was Darkice was set up to start on startup. I'm confused to why it didn't just start up after I updated the config file :/
Reply With Quote
  #7 (permalink)  
Old 09-17-2017, 6:21 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 809
Default

I would say that apparently you have one of the pi images containing TTD/darkice that is set up to automatically reboot the pi at 3 am. Both are likely running in detached screens. Type screen -list at the command line prompt and you will probably see that both are running.

So, is it now running the way that you want?
Reply With Quote
  #8 (permalink)  
Old 09-19-2017, 10:13 PM
Member
  Premium Subscriber
Premium Subscriber
 
Join Date: Aug 2005
Posts: 1,052
Default

It's been quite awhile since I've messed with it, but I seem to remember needing to start TTD first, then darkice. It took me some trial and error to get everything to start up correctly automatically upon reboot. As DC31 mentioned, make sure you don't have multiple instances starting without realizing it.

Andy
__________________
Using TwoToneDetect? Show us where! Add yourself to the user map here or PM me with your location and I'll add you.

If you need help with TwoToneDetect please read this post first
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 5:34 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2015 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions