RadioReference on Facebook   RadioReference on Twitter   RadioReference Blog
 

Go Back   The RadioReference.com Forums > Computer Aided Monitoring and Programming > Streaming / Broadcasting / Audio Recording


Streaming / Broadcasting / Audio Recording - Interested in putting your scanner online for others to hear? Want to listen to other radios on the internet. This forum is here for you to discuss these topics related to streaming scanners online.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1 (permalink)  
Old 10-13-2018, 9:21 AM
Member
   
Join Date: Apr 2014
Posts: 15
Default issues v65c

This software use to work for us as a fire dept, but no longer does.

the software picks up the tones and creates a recording, but doesn't email it out.

I try to send a test email and i a message that says
<class smtplib.smtpauthenticationerror>....

can someone tell me what i am missing or what has changed for this to not work for us anymore?

Thanks
Mitch
Reply With Quote
Sponsored links
  #2 (permalink)  
Old 10-13-2018, 9:02 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2013
Location: Asheville NC
Posts: 136
Default

I'm assuming this is a Two Tone Detect issue?

But the error you are getting I believe is referring to your email settings. I would start by checking your settings for the email account you use to send the emails, username, password, port and ssl settings... post back with your results and we can go from there
Reply With Quote
  #3 (permalink)  
Old 10-16-2018, 8:01 PM
Member
   
Join Date: Apr 2014
Posts: 15
Default

Sorry for delay.

I wanted to capture some more info before i reposted in hopes this helps someone help me figure out my issue.

Yes this is two tone detect...

I took a video of a scan coming through..the computer recognized the tones and recorded an audio file and then after 30 seconds or so, i see the first cmd screen pop up. there is a bunch of info on the screen. the two spots that jump out are:

parser not found for codec pcm_duration 500000 reached at 5015510

mp3 @ 020c88e0 unsupported sample rate

then 20 more seconds and i get another cmd prompt show up.the two sections that jump out to me state:

[wav@ 01fb96ao] parser not found for codec pcm_s161d, packets or times may be invalid


[wav@ 01fb96ao] max_analyze_duration 5000000 reached at 5015510

PLEASE HELP ME!! thank in advance!
Reply With Quote
  #4 (permalink)  
Old 10-17-2018, 6:32 AM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2013
Location: Asheville NC
Posts: 136
Default

What operating system are you using, and did you check your email settings?? Have u you used the tone editor to send a test email? Let's make sure your actually getting emails first, then are any audio files being created and saved in the two tone detect folders?
Reply With Quote
  #5 (permalink)  
Old 10-17-2018, 4:54 PM
Member
   
Join Date: Apr 2014
Posts: 15
Default

This is on an old Windows XP computer. We had used it on this computer with version 65 for about a year, and we have had issues the last year with it.

I checked the config settings, which i believe are the email settings that you are referring to. I found an example of this info on the ttd website, and tried to copy what another user had and just filled my information in. I am not sure if this is all correct or not but i copied it below.
:
[Section1]
email_user = melrosefiredeptpage@gmail.com ;user id to log in to email account used for sending emails
email_pwd = XXXXXX ;password to log into email account used for sending emails encoded in base64
email_server = smtp.gmail.com ;SMTP server address of email provider
email_port = 587 ;port to access email server with
record_seconds = 30 ;number of seconds of audio to record after a valid tone set is found
record_delay = 6 ;number of seconds to wait after a tone set is found before starting to record
tone_tolerance = 0.02 ;tolerance of tone detection algorithm 1% = .01
input_device_index = 1 ;index of audio input device
output_device_index = 2 ;index of audio output device
audio_threshold = 54 ;threshold of audio squelch. audio signals below this level will be ignored
tone_offset = 0.0 ;tone offset in percentage. .01 = +1% tone offset, -.02 = -2% tone offset, etc.
mp3_bitrate = 32000 ;bit rate of mp3 encoder. Lower bitrate = smaller file size and lower audio quality
BCC = 1 ;1 = email addresses will be BCC'ed (hidden from other recipients). 0 = recipients will see other recipients
email_priority = 3 ;priority of email (1=highest, 3=normal, 5=lowest)
release_time=3.0 ;amount of silence (in seconds) required before recording will stop (max=60 seconds)
email_from = emailuserid
update_interval = 60.0
audio_channel = mono



I am getting recordings of audio files saved in the audio section so i know my tones are being heard and copied correctly.

When i go into the tone editor and try to send a test email now I get:

Class 'smtplib.smtpauthenticationerror'
username and password not accepted......

I believe this is obviously my problem, but i have put the correct username and password in through the config file. I have tried the email with and without the gmail.com as I read somewhere that it should be added. That didn't work for me either.

Thanks again for any help!
Reply With Quote
Sponsored links
  #6 (permalink)  
Old 10-17-2018, 5:02 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2013
Location: Asheville NC
Posts: 136
Default

Gmail you must use the ssl settings and port, I also suggest updating two tone to the new version which is 70.

*** nvm 587 port should work, try using a different email processor, google can do funny things when it looks at spam,

Last edited by nated1992; 10-17-2018 at 5:06 PM..
Reply With Quote
  #7 (permalink)  
Old 10-17-2018, 5:36 PM
Member
   
Join Date: Apr 2014
Posts: 15
Default

I just tried to use my yahoo account...

now my settings are:
[Section1]
email_user = johnsonmitc@yahoo.com ;user id to log in to email account used for sending emails
email_pwd = XXXXXXX ;password to log into email account used for sending emails encoded in base64
email_server = smtp.yahoo.com ;SMTP server address of email provider
email_port = 587 ;port to access email server with
record_seconds = 30 ;number of seconds of audio to record after a valid tone set is found
record_delay = 6 ;number of seconds to wait after a tone set is found before starting to record
tone_tolerance = 0.02 ;tolerance of tone detection algorithm 1% = .01
input_device_index = 1 ;index of audio input device
output_device_index = 2 ;index of audio output device
audio_threshold = 54 ;threshold of audio squelch. audio signals below this level will be ignored
tone_offset = 0.0 ;tone offset in percentage. .01 = +1% tone offset, -.02 = -2% tone offset, etc.
mp3_bitrate = 32000 ;bit rate of mp3 encoder. Lower bitrate = smaller file size and lower audio quality
BCC = 1 ;1 = email addresses will be BCC'ed (hidden from other recipients). 0 = recipients will see other recipients
email_priority = 3 ;priority of email (1=highest, 3=normal, 5=lowest)
release_time=3.0 ;amount of silence (in seconds) required before recording will stop (max=60 seconds)
email_from = emailuserid
update_interval = 60.0
audio_channel = mono

I now get an email send error that is different....
errno 10060 a connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
Reply With Quote
  #8 (permalink)  
Old 10-17-2018, 5:40 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2013
Location: Asheville NC
Posts: 136
Default

Quote:
Originally Posted by johnsonmitc View Post
I just tried to use my yahoo account...

now my settings are:
[Section1]
email_user = johnsonmitc@yahoo.com ;user id to log in to email account used for sending emails
email_pwd = XXXXXXX ;password to log into email account used for sending emails encoded in base64
email_server = smtp.yahoo.com ;SMTP server address of email provider
email_port = 587 ;port to access email server with
record_seconds = 30 ;number of seconds of audio to record after a valid tone set is found
record_delay = 6 ;number of seconds to wait after a tone set is found before starting to record
tone_tolerance = 0.02 ;tolerance of tone detection algorithm 1% = .01
input_device_index = 1 ;index of audio input device
output_device_index = 2 ;index of audio output device
audio_threshold = 54 ;threshold of audio squelch. audio signals below this level will be ignored
tone_offset = 0.0 ;tone offset in percentage. .01 = +1% tone offset, -.02 = -2% tone offset, etc.
mp3_bitrate = 32000 ;bit rate of mp3 encoder. Lower bitrate = smaller file size and lower audio quality
BCC = 1 ;1 = email addresses will be BCC'ed (hidden from other recipients). 0 = recipients will see other recipients
email_priority = 3 ;priority of email (1=highest, 3=normal, 5=lowest)
release_time=3.0 ;amount of silence (in seconds) required before recording will stop (max=60 seconds)
email_from = emailuserid
update_interval = 60.0
audio_channel = mono

I now get an email send error that is different....
errno 10060 a connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

smtp.mail.yahoo.com for Yahoo also yahoo requires ssl, I'm 90% sure its because your not using ssl
Reply With Quote
  #9 (permalink)  
Old 10-17-2018, 5:50 PM
Member
   
Join Date: Apr 2014
Posts: 15
Default

is there anyway to turn ssl on in v65, or do i need to get v70 to turn ssl on?
Reply With Quote
  #10 (permalink)  
Old 10-17-2018, 6:36 PM
Member
   
Join Date: Apr 2014
Posts: 15
Default

I downloaded v70...i set it up....here is my config file:

[Section1]
email_user = johnsonmitc@yahoo.com ;user id to log in to email account used for sending emails
email_pwd = XXXXX= ;password to log into email account used for sending emails encoded in base64
email_server = smtp.yahoo.com ;SMTP server address of email provider
email_port = 587 ;port to access email server with
record_seconds = 30.0 ;number of seconds of audio to record after a valid tone set is found
record_delay = 6 ;number of seconds to wait after a tone set is found before starting to record
tone_tolerance = 0.02 ;tolerance of tone detection algorithm 1% = .01
input_device_index = 0 ;index of audio input device
output_device_index = 3 ;index of audio output device
audio_threshold = 54 ;threshold of audio squelch. audio signals below this level will be ignored
tone_offset = 0.0 ;tone offset in percentage. .01 = +1% tone offset, -.02 = -2% tone offset, etc.
mp3_bitrate = 32000 ;bit rate of mp3 encoder. Lower bitrate = smaller file size and lower audio quality
BCC = 0 ;1 = email addresses will be BCC'ed (hidden from other recipients). 0 = recipients will see other recipients
email_priority = 3 ;priority of email (1=highest, 3=normal, 5=lowest)
release_time=3.0 ;amount of silence (in seconds) required before recording will stop (max=60 seconds)
audio_channel = mono ;audio channel of sound card to record from. Valid options are 'mono', 'left', or 'right'. Default is 'mono'
email_from = johnsonmitc@yahoo.com ;email address to show in "From" field. Generally keep the same as email_user to avoid spam flagging
stacked_extend_record = 1 ;Set to 1 to extend recording time and remove stacked tone audio when a stacked page is detected during a recording.
start_minimized = 0 ;Set to 1 to minimize TwoToneDetect to the task bar when it is started.
instance_id = ;Put text here that you want to appear in the title bar of the program
email_security = ssl ;Email security type. Valid values are "none", "STARTTLS", and "SSL"
email_authentication = 1 ;Normally set to 1 to enable email authentication (username & password login). Set to 0 to disable authentication.
email_send_sequential = none ;Send emails one at a time instead of as a group. Valid options are "none" (send to group), "all" (send individual emails), and "Verizon" (send individual emails only to Verizon SMS & MMS addresses)
update_interval = 60
upload_ftp_server =
upload_ftp_port = 21
upload_ftp_username =
upload_ftp_password =
upload_file_prefix =


i get the following error...
class...socket.timeout
timed out
Reply With Quote
  #11 (permalink)  
Old 10-17-2018, 7:55 PM
Member
   
Join Date: Apr 2014
Posts: 15
Default

Now I am really confused and not sure what is going on...

I put v70 on my windows 10 computer.
I tried my gmail account and i also tried my yahoo account
I tried ssl, starttls, and none,
I also tried authentiacaion as 0 and 1 for each of the above sercurity options.

I am not sure what else to try but i keep getting errors and can't send the test email.
Reply With Quote
  #12 (permalink)  
Old 10-18-2018, 4:47 AM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2013
Location: Asheville NC
Posts: 136
Default

When you run the two tone detect program, there is a button that says "edit config info" try putting the settings in using the gui.
Reply With Quote
  #13 (permalink)  
Old 10-18-2018, 4:29 PM
Member
   
Join Date: Apr 2014
Posts: 15
Default

i tried that as well... i don't see any different results. all of the information in there looks correct, other than i can't see the password, so i retype the password in and also doesn't work.

i am getting a message that says socket timed out.
Reply With Quote
  #14 (permalink)  
Old 10-18-2018, 4:59 PM
UPMan's Avatar
Uniden Representative
  Premium Subscriber
Premium Subscriber
Amateur Radio Operator
Amateur Radio
 
Join Date: Apr 2004
Location: Arlington, TX
Posts: 12,606
Default

Maybe:

Quote:
SMTP Server Server for outgoing mail. Yahoo mail uses smtp.live.com or smtp.mail.yahoo.com (I found two different references)
SMTP Port Port for outgoing mail. The dafault Yahoo mail smtp port is 465, you can also use standard SMTP port 25 or 587.
__________________
Uniden Product Ninja
Who is UpMan and why doesn't he answer my email/phone call?
Personal Blog
For better help, tell us specifically what you are trying to scan.
Reply With Quote
  #15 (permalink)  
Old 10-18-2018, 5:03 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2013
Location: Asheville NC
Posts: 136
Default

Quote:
Originally Posted by johnsonmitc View Post
i tried that as well... i don't see any different results. all of the information in there looks correct, other than i can't see the password, so i retype the password in and also doesn't work.

i am getting a message that says socket timed out.
Make sure you are using the right port for ssl, which email are you currently trying to use and I'll post it
Reply With Quote
  #16 (permalink)  
Old 10-18-2018, 9:15 PM
Member
   
Join Date: Apr 2014
Posts: 15
Default

I've been trying both of those many different ways but I'm ultimately trying to use my melrosefiredeptpage@gmail.com

thanks

Can someone else post their exact settings or print screen etc of a yahoo or gmail account that is working for them as i can't seem to figure out what is going on with mine.
Reply With Quote
  #17 (permalink)  
Old 10-19-2018, 5:29 AM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 970
Default

Quote:
Originally Posted by johnsonmitc View Post
I've been trying both of those many different ways but I'm ultimately trying to use my melrosefiredeptpage@gmail.com

thanks

Can someone else post their exact settings or print screen etc of a yahoo or gmail account that is working for them as i can't seem to figure out what is going on with mine.
Here are my gmail settings that have worked for years. No two-factor authentication. Allow less-secure apps.
Attached Images
 
Reply With Quote
  #18 (permalink)  
Old 10-19-2018, 6:00 PM
Member
   
Join Date: Apr 2014
Posts: 15
Default

Quote:
Originally Posted by DC31 View Post
Here are my gmail settings that have worked for years. No two-factor authentication. Allow less-secure apps.
here is how i set mine...i think it is the same as yours minus the ftp settings... here is the message that i get when i try to send a test email. Any thoughts?
Attached Files
File Type: doc pic of tone config.doc (109.5 KB, 4 views)
Reply With Quote
  #19 (permalink)  
Old 10-19-2018, 7:31 PM
Member
  Audio Feed Provider
Audio Feed Provider
 
Join Date: Feb 2011
Location: Massachusetts
Posts: 970
Default

Quote:
Originally Posted by johnsonmitc View Post
here is how i set mine...i think it is the same as yours minus the ftp settings... here is the message that i get when i try to send a test email. Any thoughts?
Smtpauthentication error means that it is not accepting your user name or password
Reply With Quote
  #20 (permalink)  
Old 10-19-2018, 8:18 PM
Member
   
Join Date: Apr 2014
Posts: 15
Default

I have re-entered my password and username 5 times, and get same results... i am positive that the username and password are correct.

when i then go to the config file and open it up, my password shows up encrypted or something and it shows my password as a bunch of letters/numbers...

I then type my correct password in at that point.

I then go and try to send a test email again. when I do it at that point, i get a different message. this time, it says smtplib.smtp authenticaion erro.... but it actually says username and password not accepted...bad credentials.

because it says that at this point, it makes me think that my username and password were correct the first time, and the smtp authentication was in reference to something else,etc...

Does that make sense?

Thanks
Mitch
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 3:03 AM.


Powered by vBulletin® Version 3.8.2
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
All information here is Copyright 2012 by RadioReference.com LLC and Lindsay C. Blanton III.Ad Management by RedTyger
Copyright 2015 by RadioReference.com LLC Privacy Policy  |  Terms and Conditions