Alinco DJ-X2000 problems connecting to PC via RS232

Not open for further replies.


May 13, 2017
Hi, first time poster so be gentle,

I have owned this scanner for a couple of years and never had any luck connecting it to a PC. I assumed it was something to do with it not liking RS232-USB adaptors or the ERW7 USB cable. I recently got a toughbook, which is graced with an RS232 port so i thought here's my chance and have had another go at getting a PC connection working but with no luck. my setup:

panasonic CF-19 toughbook running Win7 pro
ERW4 2.5mm jack to RS232
Alinco DJ-X2000 scanner
Alinco DJ-X2000 clone utility

i have tried:

in device manager i set both COM1 and COM2 to match the settings given in the RS232 spec sheet:
Data bits 8
Parity None
Stop bits 2
Flow control hardware

I have tried both ports with FIFO on and with FIFO off. I have tried all 3 baud speeds the scanner offers

when I try to write from the scanner to the PC (clone>write) it says 'sending' for a few seconds then returns to the menu
when i try to 'read all data' using the software utility, it fails and i get the message 'A Communication Error Occurred: 1.' this also crashes the scanner and i have to cycle the power
doing both at the same time will result in one or other or both of the above behaviours

If i try to use Chirp (great software with other radios, esp Baofeng UV-5x variants) '>Download from radio' option, a box comes up with dropdowns that correctly identify an alinco radio on COM1 but Chirp doesn't appear to know of a DJ-X2000 model. attempting to clone anyway fails immediately, but the scanner display says 'clone interface err' and the scanner is crashed/frozen and only cycling the power fixes this (so there does seem to be the potential for 2-way comms between scanner and PC

I have tried to access the scanner or determine it's com port behaviour/settings with hyperterminal but without success (probably cause i don't know what to do with hyperterminal besides change COM port settings.)

it's such a great scanner, but programming through the hardware interface is laborious. any help would be greatly appreciated.


May 13, 2017

ok, this is how i fixed it:

1. get a proper ERW4c cable from a real vendor (in this case the ever excellent nevada radio) and bin the cheap ebay knock-offs

2. shut down laptop, enter BIOS (F2 or delete as it starts up) and turn off all the com ports
3. restart windows, log in
4. log out, shutdown windows
5. enter BIOS and turn all the com ports back on
6. restart laptop
7. start>right click on 'my computer'>manage
8. in device manager, right click on com port 1(or whichever you intend to use) select properties, check port settings match Scanner (baud rate, parity etc)
9. plug everything together, start scanner, run software, back up scanner memory (read all data, save (.ax file) and export (.csv file)
10. enjoy the brief moment of bliss between one technical problem ending and the next one starting ;-)

why these step?
a) a genuine cable has a chip/circuit in it that does the work of a driver. knock-off cables don't.
b) windows abstracts the hardware interface so that it can assign IRQ addresses dynamically on the fly (woo for plug and play). but it's windows so it gets confused after a while, which is why new re232/com devices never work first time (at least for me) disappearing and reappearing the com ports in bios will force windows to reassign the IRQ addresses correctly, making the com ports magically reappear and work correctly. trick learnt from trying to get GPS module working on a toughbook

thanks for your help guys /s

if a mod finds this can they move this thread to the appropriate place? thanks

if google bought you here, don't give up, you're so close. you have an excellent scanner

Not open for further replies.