BCD396T Speaker Problem?

Status
Not open for further replies.

adams6451

Member
Joined
Nov 13, 2008
Messages
50
Location
Tennessee
I recently dropped my scanner from around 3 feet, it did not even get a scratch. Too bad this was the 2nd time in 3 years. Every so often there is a strange rattle or vibration in the speaker. If I had to describe it I would say it sounds as if the scanner was lying on its back with a grain of salt on the speaker, bouncing around. The sound has a small distortion. Then again it reminds me of a cracked speaker or one with a tiny tear. Is it common for these speakers to go bad after a couple of years?
 

adams6451

Member
Joined
Nov 13, 2008
Messages
50
Location
Tennessee
Again it was not dropped too badly. It seems the speaker has gotten more abuse from loud signals and alerts.
 

sjlamb

Member
Premium Subscriber
Joined
May 27, 2007
Messages
883
Location
Sarasota County, FL
Again it was not dropped too badly. It seems the speaker has gotten more abuse from loud signals and alerts.
The 396T has a well documented history for speakers going bad. Typically though... it has been reported that they completely stop working as opposed to the distortion you describe.
 

adams6451

Member
Joined
Nov 13, 2008
Messages
50
Location
Tennessee
I May open it up and pull out the speaker. A piece of material could have made it in the speaker area and is causing the problem. I noticed last night it sometimes quit. I turned it up to 15 just now and it is almost like a small fiber or wire is against the speaker cone during transmission. Just a weird effect that may could be fixed.
 

shawnie

Member
Joined
Dec 26, 2009
Messages
20
bc scanner audio quite

my bc145xl uniden scanner has now went completely silent no sound it still scans yesterday i turned it on and the ext sp hole in the back started smoking does anyone know wht the problem could be and how i can fix it
 

sjlamb

Member
Premium Subscriber
Joined
May 27, 2007
Messages
883
Location
Sarasota County, FL
my bc145xl uniden scanner has now went completely silent no sound it still scans yesterday i turned it on and the ext sp hole in the back started smoking does anyone know wht the problem could be and how i can fix it
Given that you've hijacked the OP's thread... I'll just say that it sounds as if the audio IC has blown. Does it still receive (as in, stops scanning when a signal is being received)?? For further advice, I would suggest you start your own thread.
 
Status
Not open for further replies.
Top