BCD996T Reception Issues

Status
Not open for further replies.

jeff

Member
Premium Subscriber
Joined
Nov 29, 2001
Messages
643
Location
St. Augustine, FL
I am sending a BCD996T to Uniden for repair, but I'm curious as to what the problem is: Receives great except for the 700, 800, and 900 bands. Virtually nothing. Have tried antenna swapping, same issue. No problems with other scanners. Any ideas?
 

kruser

Active Member
Premium Subscriber
Joined
Nov 25, 2007
Messages
4,981
Location
Central St Louis Cnty, MO
Does the signal strength indicator show the same level as your other scanners when using the same antenna? That would be while holding on an active control channel.

Any type of attenuation turned on globally or per system on anything in those bands?

I still have an old 996T model that outperforms the newer XT models on simulcast systems. Primarily due to the fact that the old T models have P25 settings that can be truly set manually per system.
They removed that feature with the XT series and brought it back with the x36HP series. It's not needed for the SDS series.

I can't think of anything else other than maybe checking the antenna connector and maybe the cable connector where it attaches to the main board internally. Some of the more recent models do use a removable jack and plug where the antenna jack coax plugs onto the main board. I've seen those connectors pop apart before. If they come apart just slightly, that could affect the higher bands like 700 and higher more than the lower bands.
 
Status
Not open for further replies.
Top