BCT8 No Audio

Status
Not open for further replies.

zl2taw

Member
Joined
Mar 16, 2006
Messages
575
Location
Brisbane, Australia
Hey Guys,

My T8 has decided that it doesn’t want to play ball any longer.
When I power it up, & hit scan, it stops on every frequency (almost like the squelch is open, regardless where the squelch is set too) but there is no output . (Thinking it’s the AF output IC)
I can hear the key beeps when I push the buttons, and when I power up I get that beep as per normal
I have plugged in an external speaker but this makes no difference, tried different power supply, even gave it a slap around.

Anyone have any ideas ?
 

VernM

Member
Joined
Jan 11, 2006
Messages
207
Location
Arkansas' Ozarks
My BCT-8 has an open squelch. I tried asking Uniden for suggestions and they don't seem to have time for a long-time owner who doesn't have the latest rig, I guess. Anyone know someone who does good service work?
 

majoco

Member
Joined
Dec 25, 2008
Messages
3,302
Location
New Zealand
I have a BCT8 that works fine. Have you tried the low level audio output socket?
Somewhere on the 'mod' sites I have seen a mod to take audio direct from the detector IC before it goes through the de-emphasis networks, although I doubt that will be the fault as you have the squelch problem. Maybe the squelch pot is bust?
 

zl2taw

Member
Joined
Mar 16, 2006
Messages
575
Location
Brisbane, Australia
Hmm interesting find, today I turned it on, had the squelch hiss, then after about 5secs it went quiet again
Looks like I need to find a repair man here in VK for sure, thanks guys for the replies
 
Status
Not open for further replies.
Top