• To anyone looking to acquire commercial radio programming software:

    Please do not make requests for copies of radio programming software which is sold (or was sold) by the manufacturer for any monetary value. All requests will be deleted and a forum infraction issued. Making a request such as this is attempting to engage in software piracy and this forum cannot be involved or associated with this activity. The same goes for any private transaction via Private Message. Even if you attempt to engage in this activity in PM's we will still enforce the forum rules. Your PM's are not private and the administration has the right to read them if there's a hint to criminal activity.

    If you are having trouble legally obtaining software please state so. We do not want any hurt feelings when your vague post is mistaken for a free request. It is YOUR responsibility to properly word your request.

    To obtain Motorola software see the Sticky in the Motorola forum.

    The various other vendors often permit their dealers to sell the software online (i.e., Kenwood). Please use Google or some other search engine to find a dealer that sells the software. Typically each series or individual radio requires its own software package. Often the Kenwood software is less than $100 so don't be a cheapskate; just purchase it.

    For M/A Com/Harris/GE, etc: there are two software packages that program all current and past radios. One package is for conventional programming and the other for trunked programming. The trunked package is in upwards of $2,500. The conventional package is more reasonable though is still several hundred dollars. The benefit is you do not need multiple versions for each radio (unlike Motorola).

    This is a large and very visible forum. We cannot jeopardize the ability to provide the RadioReference services by allowing this activity to occur. Please respect this.

BF-888s Plus External Antenna Issue

Status
Not open for further replies.

cobraultra

Member
Feed Provider
Joined
Feb 2, 2010
Messages
52
Location
Pittsburgh, PA
So I got two of these radios to start doing some monitoring. I have a bunch of UV-5R's that I am using a SMA-Female to BNC connector on them to connect them into my Multicoupler. The 5R's are working perfectly. I go and connect up the 888s+ to the multicoupler and i get nothing. The signal is never making it to the radios. I have tired everything. Replacing SMA/BNC connector. Replacing cable. Different port on the coupler. In some testing as i pull the connector our of the coupler and its like half in and half out I can get a signal for a split second. I dont know what else it could be. Radio Seems to work ok with the stock antenna connected but that will not pickup what im trying to monitor. Anyone else seen this yet? I know its not something seen everyday. I have two 888S+ radios they both act the same.
 

riccom

That scanner geek in the big easy!
Premium Subscriber
Joined
Jul 2, 2004
Messages
1,266
Location
New Orleans, LA
It sounds like a short in the connection or the connector.


Sent from my C6730 using Tapatalk
 

cobraultra

Member
Feed Provider
Joined
Feb 2, 2010
Messages
52
Location
Pittsburgh, PA
I've replaced everything. Used a working connections over to the 888s+ from one of the working 5R's.

Its strange it seems just to be the radios themselves.
 
Status
Not open for further replies.
Top