BR330t with Unknown Problem

Status
Not open for further replies.

stuck22

Member
Premium Subscriber
Joined
Feb 16, 2008
Messages
7
Location
British Columbia
Hello all. My BR330t used to be a fine scanner. I am using for an Edacs Trunking system in Vancouver BC.

A couple of days ago it just crapped out. I havent dropped it. But I do frequently change the antenna on it. On Signals I used to get full strength I am getting almost nothing now. I have tried putting on different antenna's but still get 0 reception. I cant even listen to AM radio anymore. I have tried re-programming the radio but got nothing.

Any Suggestions?
 

garys

Member
Premium Subscriber
Joined
Jun 13, 2002
Messages
5,144
Location
Eastern MA
I would try the WX scan frequencies. If you get nothing there, then it's likely the unit has to go back to Uniden. Just because you didn't drop it, doesn't mean that some component didn't fail.
 

stuck22

Member
Premium Subscriber
Joined
Feb 16, 2008
Messages
7
Location
British Columbia
I would try the WX scan frequencies. If you get nothing there, then it's likely the unit has to go back to Uniden. Just because you didn't drop it, doesn't mean that some component didn't fail.
Tried it and still didnt work. I guess I will have to send it back to Uniden/

Did you have your bar antenna turned on when you tired AM?
Yes.
 

JoeyC

Senior Member
Joined
Dec 19, 2002
Messages
3,512
Location
San Diego, CA
Sounds to me like you've broken the connection from the antenna connector inside the radio. I'm not familiar with that radio, but if the antenna connector has even the slightest bit of play in it, you risk the chance of loosening or breaking the (soldered?) connection especially considering you often change antennas. I've had this happen to a scanner or two over the years where I would repeatedly change the antenna.
 
Status
Not open for further replies.
Top