BCD436HP: Bug: ID Search vs service tags

Status
Not open for further replies.

Jay911

.
Feed Provider
Joined
Feb 15, 2002
Messages
9,307
Location
Bragg Creek, Alberta
Not sure if this has been discovered yet, but I just found what I consider to be a bug - I'm not sure how it could be rectified, either.

I have a large Motorola system in my favorites list, as downloaded from the main database. I turned off certain service tags and turned on ID search. I'm receiving all sorts of "unknown" IDs which I thought was odd since the system has been around for a while in a well-covered area. As it turns out, I'm receiving talkgroups in ID search from the service tags which I have disabled, and of course they have no data (they come up in the "Unknown" department, with no info except the ID in the Channel section).

UPMan - any idea if this could be rectified? My understanding of how the system works with regards to service tags is, the disabled tags aren't even loaded, so the radio has no way of knowing that these IDs aren't to be received during search (like IDs which are avoided/locked out aren't received).
 

kruser

Active Member
Premium Subscriber
Joined
Nov 25, 2007
Messages
4,252
Location
West St Louis Cnty, MO
Not sure if this has been discovered yet, but I just found what I consider to be a bug - I'm not sure how it could be rectified, either.

I have a large Motorola system in my favorites list, as downloaded from the main database. I turned off certain service tags and turned on ID search. I'm receiving all sorts of "unknown" IDs which I thought was odd since the system has been around for a while in a well-covered area. As it turns out, I'm receiving talkgroups in ID search from the service tags which I have disabled, and of course they have no data (they come up in the "Unknown" department, with no info except the ID in the Channel section).

UPMan - any idea if this could be rectified? My understanding of how the system works with regards to service tags is, the disabled tags aren't even loaded, so the radio has no way of knowing that these IDs aren't to be received during search (like IDs which are avoided/locked out aren't received).
Good catch!

I tried the same thing and instantly saw what you found as well. Only difference is I'm using the 536HP.

I guess the 'workaround' is to turn those service tags back on and load and avoid all the TG's that you don't want. Seems like a lot of work just to keep a bunch of "Unknowns" from popping up all the time!

It should work just as Service Types do on the HP1 if they are turned off regardless if you are in ID Scan or Search mode.
Unless we are both misunderstanding how they work on the x36HP models but I sure don't see any difference in how they should work between the models.
 

ofd8001

Member
Premium Subscriber
Joined
Feb 6, 2004
Messages
7,089
Location
Louisville, KY
If I was a betting guy, I'd say this probably is not a "bug". Rather it is because "Service Type" isn't data that is included in the control channel data stream for the system you are monitoring.

When in ID Search, the scanner gets a Talkgroup ID number from the control channel, along with other information such as which voice frequency to use, and Unit ID (depending upon system type).

The scanner then looks in its memory and if the TGID is stored, the information associated with that TGID is displayed on the scanner (alpha tag, service type. It also checks whether you have told the scanner to avoid that TGID number.

But if it is a "fresh" TGID number, then all you see is that TGID number (and possibly UID). Since "Service Type" is not included in the system's control channel data stream, your scanner isn't getting information it needs to "react" according to your sevice type selections.

As I write this, I'm doing an ID search. The scenario you describe is happening, but for the reasons above, I believe this is normal behavior.
 

Jay911

.
Feed Provider
Joined
Feb 15, 2002
Messages
9,307
Location
Bragg Creek, Alberta
How you're describing it is not how the radio works. It takes data from your profile stored on the SD card and loads it into working memory. When it pulls the data from the SD card into working memory, it pulls in data which matches your current profile settings, of which service type is one element. And because one chooses to have service type such-and-such disabled, those TGs aren't brought into working memory. Now, coming at it from the other angle, ID Search works by displaying all traffic except that which is explicitly avoided (and including alpha tags, etc., for traffic which matches a stored ID). Because of the procedure which causes the radio to not bring into working memory talkgroups which have service tags which are disabled, the x36 line is treating those TGs like "unknowns" (because they technically aren't in the system in the form in which was loaded into working memory).

I haven't ever noticed this in the past with my x36 at home nor with my HP1. I am going to bed now prior to getting on an airplane back home in the morning so testing with my HP1 will have to wait until I get wheels-down tomorrow afternoon.
 

ofd8001

Member
Premium Subscriber
Joined
Feb 6, 2004
Messages
7,089
Location
Louisville, KY
We probably are saying the same thing only a little differently.

The main point I was trying to make is that a "fresh" or unknown TGID discovered via search doesn't have any service type data associated with it. So it will appear on your scanner regardless of service types have been turned on or off.

In short, service tags are not applicable to newly discovered TGIDs while searching. There isn't any "linkage" for service types.
 

troymail

Silent Key
Joined
Dec 19, 2002
Messages
9,982
Location
Supply (Lockwood Inlet area), NC
So effectively what needs to happen is to have the radio LOAD all talkgroups (even those for SERVices you don't want) and then have it"auto-avoid" those talkgroups rather than not loading them at all.
 

DataSquid

Member
Joined
Jan 1, 2015
Messages
102
Location
Waterloo, Ontario
I'm discovering talk groups I think are already in the DB as well. A clearer understanding of how this process works would be appreciated.
 

shew

Member
Joined
Dec 10, 2001
Messages
309
Location
PIERRE PART, LA.
also make sure that in your systems....u have the id search turned to off ....u won't get any new tg's that is not in the system show up on ur screen
 

Jay911

.
Feed Provider
Joined
Feb 15, 2002
Messages
9,307
Location
Bragg Creek, Alberta
also make sure that in your systems....u have the id search turned to off ....u won't get any new tg's that is not in the system show up on ur screen
Um, the whole point of this thread is about having ID search turned on, so turning it off is not advisable.

Also please spell out words in full and use full case and punctuation.
 
Status
Not open for further replies.
Top