cannot get Trunk Recorder to install

SDEC_SCAN

Member
Joined
Jun 23, 2015
Messages
6
I have tried on multiple systems MacOS 10.15 and 10.13 as well as Ubunto 16.04 and it fails every time although i have followed the instructions from the Git Page... has anyone gotten this to work? if so, what are you using and what did you do?

Any help is greatly appreciated.
 

SDEC_SCAN

Member
Joined
Jun 23, 2015
Messages
6
for those of you willing and able to help here is some more information...

I have tried multiple times to get this to work and I am hopelessly stuck. Im running 10.13
If anyone can help or point me in the right direction it would be greatly appreciated!
My steps that I followed.
  1. installed installed Xcode 9.4.1
  2. Installed Apple's Command Line Developer Tools
  3. agreed to Xcode license terms
  4. installed macports
  5. installed GNU radio with sudo port install gnuradio uhd gr-osmosdr
  6. Installed tools to compile trunk recorder with sudo port install cmake boost uhd libusb cppunit
Now here is the issue when i enter the following commands to build trunk recorder...
Code:
mkdir trunk-build
git clone https://github.com/robotastic/trunk-recorder.git
cd trunk-build
cmake ../trunk-recorder
make
It stops at
[ 69%] Building CXX object CMakeFiles/recorder.dir/trunk-recorder/main.cc.o
and I get the following error:

1 warning and 7 errors generated.
make[2]: *** [CMakeFiles/recorder.dir/trunk-recorder/main.cc.o] Error 1
make[1]: *** [CMakeFiles/recorder.dir/all] Error 2
make: *** [all] Error 2
old-mbp:trunk-build josh$
there is far more information that gets spit out but RR will not allow me to post it all. check out my post on github for full text

thanks again for the help.
 
Top