Can't update firmware on a WS1098

Status
Not open for further replies.

mikewazowski

Forums Manager/Global DB Admin
Staff member
Joined
Jun 26, 2001
Messages
10,995
Location
Central Ontario
Hello all, I'm having a problem updating my WS1098 to version 3.4 firmware.

I was prompted to update EZ-Scan (which I did) followed by a CPU and DSP update.

EZ-Scan checks the scanner's current firmware, finds version 3.3 and prompts me to update it.

The firmware is downloaded, the scanner restarts and enters the firmware update mode (Main Appl code update mode waiting for USB). During this time, the PC indicates a device has been unplugged and something has been plugged back in.

EZ-Scan says that it is erasing the flash memory and that's as far as I get. An error message pops up "No data received from the scanner. Please restart this process from step number." The scanner shows "Main Appl code update in progress.....".

I've tried different USB cables and I've installed EZ-Scan on another computer with the same result.

I can upload and download my configuration fine.

Anybody have any suggestions?

The DSP seems to have updated though. It shows 3.0 as Current and Available. Not sure how that happened though?

I did try the standalone firmware updater where you hold the Menu key in as you plug in the USB cable but all that happens is the screen flashes and the scanner never enters the firmware update mode.
 

WhistlerWendy

Whistler Representative
Premium Subscriber
Joined
Sep 9, 2015
Messages
328
Location
Northwest Arkansas
Hello all, I'm having a problem updating my WS1098 to version 3.4 firmware.

I was prompted to update EZ-Scan (which I did) followed by a CPU and DSP update.

EZ-Scan checks the scanner's current firmware, finds version 3.3 and prompts me to update it.

The firmware is downloaded, the scanner restarts and enters the firmware update mode (Main Appl code update mode waiting for USB). During this time, the PC indicates a device has been unplugged and something has been plugged back in.

EZ-Scan says that it is erasing the flash memory and that's as far as I get. An error message pops up "No data received from the scanner. Please restart this process from step number." The scanner shows "Main Appl code update in progress.....".

I've tried different USB cables and I've installed EZ-Scan on another computer with the same result.

I can upload and download my configuration fine.

Anybody have any suggestions?

The DSP seems to have updated though. It shows 3.0 as Current and Available. Not sure how that happened though?

I did try the standalone firmware updater where you hold the Menu key in as you plug in the USB cable but all that happens is the screen flashes and the scanner never enters the firmware update mode.
Hi Mike -
Which Windows version are you using and have you had a windows update lately?

Thanks,
WW
 

n2pqq

Member
Premium Subscriber
Joined
Dec 19, 2002
Messages
899
I have the same problem scanner also stays stuck in mode

usb power
charging backup battery

Only way to get out of this mode is to disconnect power .
wait 30 seconds while holding power button and reapply power cord


This happens when you get here please restart this process from step number


Windows 10 up to date.
 
Last edited:

mikewazowski

Forums Manager/Global DB Admin
Staff member
Joined
Jun 26, 2001
Messages
10,995
Location
Central Ontario
Windows 7 for me.

Last update was December 3rd and that was a Windows Malicious Software update.

The last non Windows Defender update was back in October.

I've got 23 recommended updates. Might try letting the computer update and then try the firmware update again.
 

eddie8965

Member
Premium Subscriber
Joined
Mar 1, 2015
Messages
86
Location
Hamilton Co. Illinois
its gotta be the software....again....im having the same problems as u guys are...nothing has changed on either computer ive tried,so its a buggy update
 

Forts

Mentor
Database Admin
Joined
Dec 19, 2002
Messages
5,583
Location
Ontario, Canada
I have 3 laptops (XP, 7, 10) and had no issues at all with this update via Win10. My Win7 laptop I can't get to recognize the scanner to save my life, and the XP laptop usually works well too.
 

scan_this

Member
Premium Subscriber
Joined
Nov 25, 2014
Messages
12
Location
Detroit
The nxdn was released today but a lot of the scanners can't do it so a lot of the scanners probably don't need the update.
 

AggieCon

Member
Premium Subscriber
Joined
Nov 25, 2015
Messages
1,444
Location
Texas
Yea, I've been in this position before too; these problems are not fun. A lot of the information previously covering this is no longer on this website, and I'm too busy right now repeat specific troubleshooting.

The most concise advice I can give is this: Sometimes different versions of the EZ Scan software cause problems on some machines. See if you can find the installation file for an older version of EZ Scan that you know worked with your PC. Load that. Try the CPU update. See if that solves the connection problems.

Prior to today, when was the last time you updated your EZ Scan Application? If it's been a long while (perhaps summer or before), reverting to an old version might do the trick.
 

dmaria

Member
Premium Subscriber
Joined
May 24, 2010
Messages
247
I have the same problem scanner also stays stuck in mode

usb power
charging backup battery

Only way to get out of this mode is to disconnect power .
wait 30 seconds while holding power button and reapply power cord


This happens when you get here please restart this process from step number


Windows 10 up to date.
Exactly the same situation for me.
 

KevinC

Moderator
Super Moderator
Joined
Jan 7, 2001
Messages
4,845
Location
Somewhere other than home :(
It has been confirmed that Whistler has an issue with the CPU update.

So no, we weren't doing anything wrong, using the wrong version, having computer issues or anything else that we had no control over. :wink:
 
Status
Not open for further replies.
Top